EndevourOS randomly freezing

I was just using endevour OS and then it just freezes. It doesnt respond to keyboard inputs but the audio is still playing so I have to manually hold the power button. This happened on arcolinux too when I was using tha and it also happened on when I was using pop OS. In ArcoLinux i tried using the linux lts kerenel but it still freezes. Pop OS was using the 5.8 Kernel and EndevourOS/Arcolinux was using the 5.11 kernel and 5.10 for the lts on. Most of the time this happens when I am watching a YT vid in fullscreen.

My hardware:

Ryzen 3600x
Nvidia GTX 1600 super with the proprietary nvidia drivers
16gb Ram

If graphics is the problem, here are some pointers:

You could use the eos-log-tool to show some journal info when the freezing has happened.

I found one thing of freezing in the wiki but that is related to flash which is now not supported. Most of the time I am just using brave browser and then it freezes

Disable hardware acceleration in Brave.

1 Like

try adding idle=nomwait as a boot parameter … this is the only thing that worked for me … one of my ryzen laptops was freezing 4 or 5 times a day with all linux distros that i tried … took about a month of troubleshooting before i found the solution on some forum or the other

adding the boot parameter fixed it full stop and is now the first thing i do when installing a new system on this laptop

that is idle=nomwait (with an ‘m’) … made that mistake once

here you go … this is the link that helped …under kernel boot parameters … now not a single freeze in 2 years or so on a machine i use as a plex server and is left on 24/7

no idea if the problem is the same but is sounds very similar to mine and it turned out to be a simple fix for a very bothersome issue that nearly had me scurrying back to windows

It might not be the same but in my experience that kind of random freeze that keeps happening even with different distros or kernels tends to be a symptom of a hardware problem. Last time something similar happened to me the issue was the PSU, not enough juice, the problem stopped after I bought a better PSU. I’m not saying that it’s definitely what’s happening to you but you should be aware of that option in case it keeps happening after you try every other option that doesn’t cost you money.

what config file do I have to edit

In the article already linked (https://archived.forum.manjaro.org/t/amd-ryzen-problems-and-fixes/55533) above:

Kernel Boot Parameter

Adding a kernel boot parameter for GRUB in Manjaro:

  1. Open the file /etc/default/grub in a text editor.
  2. Add the parameter, in this case idle=nomwait (notice the m), to the line starting with >GRUB_CMDLINE_LINUX_DEFAULT=, at the end, within the quotes, like so: >GRUB_CMDLINE_LINUX_DEFAULT="<current parameters ...> idle=nomwait".
  3. Save the file.
  4. Update GRUB: sudo update-grub.
  5. Upon next reboot the default boot option should include the parameter.

But as EndeavourOS has no update-grub, instead you need to:

sudo grub-mkconfig -o /boot/grub/grub.cfg

With the hardware you have you should not be getting any freezing. If it happened on two other distros then the question is why? Hardware? Changes made to the install. Changes to your UEFI Bios? Software or packages added or that you are using. Is nvidia set up correctly? Is the rendering running off the card or is it using mesa only. :thinking:

I also had problems with my old Ryzen, turned out that it was only stable when reducing cores (8 —> 4). New board and cpu fixed it. Try running stress on the Command line (have a Look at the man page and use the mentioned default with adapted core count), if it crashes it is probably a hw failure. You Mighty also want to grep dmesg for „error“ or „mce“ (Machine Check Error).
Or its something different ;D