Stuck with bootresolution being too low

Dear fellow members!

During boot, after selecting boot loader option almost until login monitors display pretty low resolution for the text outputs (a split second before login screen it becomes normal after a blink).

I spent a couple hours already trying to modify config files based on forum entries and Arch Wiki.

  • kernel command line options for video [video=DP-3:2560x1440@60]
  • loader config as well for console-mode max

Next step would be edids, but hoping someone has some knowledge that could point me (and others with OCD :smiley: ) in the right direction.

I have an RX 6600 XT and using the amdgpu driver. I have 2 monitors attached one FullHD and a 2k if that matters. System is UEFI using systemd-boot and dracut, kernel version is 6.1.64-1-lts.

Please let me know if there is any more info I could provide :pray:t3:

Any suggestions would be appreciated, much love,
M

1 Like

You could try early loading your GPU driver.

Create a file named /etc/dracut.d/gpu.conf and put this line inside it:

force_drivers+=" amdgpu "

Then run sudo dracut-rebuild

1 Like

During boot, after selecting boot loader option almost until login monitors display pretty low resolution for the text outputs (a split second before login screen it becomes normal after a blink).


Here is a small post on how I “fixed” the same issue on my system (when I wrote the post I was using a NVIDIA GPU but it still works on my new AMD one):

EDIT: But I would remove this first when trying the video=efifb method:

1 Like

Thanks @android for the guide!

I have tried your steps with partial success. I have listed the modes and interestingly the selected one was 2560x1440. Manually setting it to the mode with 2560x1440 did nor resolve the issue, I still got the 640x480 ish boot screen.

If I set the mode corresponding to 1920x1080 it produces the expected output so it looks much nicer. Could the issue be that I have 2 monitors connected and secondary being only FullHD?

I could definitely live with the results, so thank you again for the help! :pray:

Thank you for the suggestion, unfortunately didn’t do the trick :no_mouth:

I guess you are spot on.

I am pretty sure you are interpreting things incorrectly. Can you check in your monitor if the resolution really is low?

On my system, the boot process is in 2560x1440 but the kernel unfortunately uses scaling for high Resolution displays, meaning the text appears enormous.
Some AUR-Kernels don’t use scaling during boot (if I remember correctly, linux-ck does not use scaling but I haven’t used it in a while - so no guarantee that it still is that way)

Boot process takes less than 2 seconds so it would be hard/impossible to check manually, after initial video signal my monitor does not display any info about the resolution.

Still incorrect resolution would be my best guess since after @android 's suggestion modifying the resolution via video param in kernel config does have an effect on the looks.

By getting to FullHD it looks much better for sure and I’m happy with the results. Still this is a great opportunity to find out more on how all this works and maybe get it fully working :slight_smile:

I think your interpretation and mine are not so different, I’m sure there is scaling happening somewhere. Just trying to figure out if and how its possible to increase the initial resolution so it does not have too be scaled.

lower resolutions also disable scaling - so it might do the same but also lead to resolution switching which also flickers the display of the process.
If I remember I will check how linux-ck behaves on my system now regarding scaling.

Unfortunately, linux-ck synced most of its configs with the official Arch kernel, it uses scaling now, too.

But linux-lqx does not - the boot process is 2560x1440 without scaling on my system. It is also available via https://liquorix.net or directly via https://liquorix.net/archlinux/liquorix/x86_64/

Had this problem just recently.

Have you tried:

When the boot menu appears:

Pressing one of the arrow keys to stop the countdown on the boot menu.

Then press the r key repeatedly to cycle through the available resolutions.

Once you have found the resolution you want just choose your kernel to boot. Next boot your choice of resolution will be remembered.

You can set your preferred kernel by moving to it and pressing d.

You will probably have to set it again if there is an update to systemd.

Hope this helps.

1 Like

Wouldn’t it be possible to set the desired resolution permanently via console-mode in loader.conf:

esp/loader/loader.conf

timeout  4
console-mode 0

e.g. when following your advice:

Then press the r key repeatedly to cycle through the available resolutions.

“Consolde mode changed to 0.”

I see that 0 gives me the highest resolution so I set console-mode 0 in loader.conf.


Also thank you for the tip. I always used console-mode max in the past but it never had the desired effect… I did not even think to try other values.

EDIT: @mansuetum I think with @Melways approach I can get rid of my video=efifb:mode=0 entry again! :slight_smile:

1 Like

@mansuetum I finally investigated the “boot log display scaling” …
The kernel actually does not scale, on HiDPi it just sets the console font to Terminus 16x32 …

To get the “unscaled” default size that linux-liquirox uses, you only have to add fbcon=font:VGA8x16 to your kernel boot parameters, no need to change console-mode, resolutions and such …

1 Like

Thank you for your suggestion!

I have tried, loader options do look perfect with it, has no effect unfortunately on what comes afterwards.
For clearest results I removed @android 's suggestion of the video param from kernel config for the test.

I still have a strong feeling that my 2 monitors with different resolutions are the culprit.

Just before login the resolution does change to the correct one, I attached images below for clarity.



Appreciate your efforts!

Pacman does not state that I have the linux-liquirox package installed, the system might be using a different kernel. Changing it might be out of my capabilities for now as I’m still very much a learner in this world :face_with_peeking_eye:

If it is only a font issue and there is no scaling why would setting the screen resolution only in kernel config have an effect on the looks?

Nevertheless I gave it a go, removed the video param and it looks perfect!

Thank you very much, for you and all on the discussion!

Still would be interested in finding out why changing the video mode has an effect on the looks. Do you perhaps have a take on it?

well:

with my new identification of the font-changing which looks like scaling (16x32 simply looks like the 8x16 font at 2x scaling) changing the resolution at boot also uses the 8x16 font, but at a lower resolution which makes it appear smaller compared to the 16x32 but still bigger than the 8x16 at native resolution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.