Uefi + systemd-boot: low resolution

I noticed that whenever I boot with my main pc, I get this kind of odd low resolution during boot. However I experience the same symptoms while I’m booting from the Live ISO Usb stick, the resolution is all fine.

My pc: https://0x0.st/XXnO.txt
Using nvidia propietary drivers + plasma

I tried every steps mentioned in these topics, with no luck:

here’s my /proc/cmdline:

initrd=\3fda0e8f58f744179d0b95a8d41a1be3\6.8.9-arch1-1\initrd nvme_load=YES nowatchdog rw root=UUID=d2d08cbd-b
ff2-48f2-909a-c3ea684b6b02 nvidia_drm.modeset=1 systemd.machine_id=3fda0e8f58f744179d0b95a8d41a1be3

When I tried to press ‘r’ to switch the resolution during the boot, my system just froze, in a state where I had to longpress the powerswitch in order to reboot…

Early loading nvidia within dracut did not help.

Writing video=efifb:mode=4 (mode 4 for me was the fullHD mode) into my /etc/kernel/cmdline also made my system unable to boot, so I had to press ‘e’ and delete that entry from the cmdline to get back to my system.

Currently I’ve reset everything (kernel cmdline and dracut) to eos factory defaults, till it’s unclear why none of the above topic solutions does not work on my end.

The most odd thing is, that its all good out of the box uses max resolution during boot on my Fujitsu Esprimo E510 and on my Lenovo T430. Could it be my bios then? In my bios I disabled Legacy, and only UEFI is enabled, and I did not find any entry mentioning CSM because I was looking for that also.

Any ideas are greatly appreciated.

It probably is in your BIOS. I had the same issue for over a year, and it was my BIOS settings the whole time.

You probably just need to switch to Hybrid graphics.

Gonna try it now, seems a very logical thread, and reading through the WM problems you had, I hope I get mine resolved too by turning hybrid on :open_mouth: be right back

1 Like

My bios is too dumb, despite it’s an UEFI bios from 2017ish. It doesn’t have hybrid switch :cry: It only has an integrated graphics OR discrete graphics switch, but can’t handle them both. However when I selected to use the onboard graphics, it booted into my rig, and I saw intel + nvidia next to each other lmao xD

It sure is something to do with the hybrid option, but then my main rig’s bios lacks from that option (all my other machines have it, and there the bootup is truly sharp fullHD mode). Screw you MSI… :smiley:

I’m still open for some other ideas, I hope there are still options.

It’s possible that the wording in your BIOS isn’t quite representative of what it is actually doing.

If you have Blender and CUDA installed, you can test it easily by going into Blender’s “System” settings tab.


Or try some other method because CUDA takes a while to download if you don’t already have it.

Installed blender for this :smiley: I have this, idk if it says anything to ya.

Also I forgot to mention in my latest post, that when I selected the “IGD” (Integrated Graphics Display) option within my BIOS, while it was booting, my screen was totally black (aka, my monitor said no signal), until the actual bootin happened, and the Plasma was started, then I got screen already, and that way I saw I got intel + my nvidia. So I couldn’t force it to display any image during bootup, if IGD was selected. When I selected “PEG”, Multi montior options show up. And I was like, A-ha! So I’m gonna use ONE VGA cable to get the signal from my onboard video chip during boot, and one DVI cable from my Nvidia for when the boot ends and goes back to my discrete xD It worked, but the fonts were still blurry during the boot… So i was like… sigh

Here’s my manual of the bios, also my bios has the latest possible version from late 2018s.

Yeah, it looks like Hybrid graphics has been enabled because you would normally see an error instead of your two graphics cards.

You can do a further test by actually doing something graphics-intensive in Blender or another app while having your system monitor open to see if your Nvidia GPU gets used.

It is, I played world of warcraft, and it was utilizing from my Nvidia yeapp.

I was thinking some crazy ideas, like, what if DVI cable is “OLD fashioned” so I tried using DP, but it was still blurry during boot. I don’t know why in the hell my computer freezes in the EFI menu, whenever I press R key to switch resolution manually, or when i used efifb mode:thinking:

That sounds like something I don’t have the knowledge or experience to help with, to be honest. Apart from the family computer that hasn’t worked in over a decade, I’ve been using laptops with just one screen (the laptop screen) for a while now.

You can close this thread and open a separate one for cable/hardware-related queries.

It was only a wild idea, I work with hardware all day all night, but I confirmed this to myself and others reading this thread in the future, that it has nothing to do with cables it seems (hence it was a random wild idea from my side, but I isolated that also) :smiley:

No worries pal, topic will remain opened, because it is under the hardware topic + awaiting other people if they have any other thoughts they can share. If not, I’m gonna mark your first answer as solution for your efforts, because I too am thinking this is BIOS related at this point.

Seems maybe I didn’t understand what happened so far. After switching to integrated graphics, did your manufacturer splash and/or systemd-boot screen have the correct resolution?

Its ok, and no, it was all low res, like 800x600 or maybe 1024x768 instead of my native resolution which is 1920x1080, no matter what option I used (integrated or dedicated). :confused:

I see. That means my suggestion wouldn’t be a solution either way.

1 Like