Steam not launching

Hi everyone,

I updated my system today, I didn’t see if Steam was updated, but I guess so since it’s not launching anymore. Either with a wayland or Xorg session. I tried to reinstalled but it didn’t change anything.

I tried looking for similar problem (which are numerous) but couldn’t find any fix or similar consol output.

Steam refusing to open
Steam (and Steam-Native) won't launch

$ steam[6530]: Running Steam on endeavouros rolling 64-bit[6530]: STEAM_RUNTIME is enabled automatically[6604]: Steam runtime environment up-to-date![6530]: Steam client's requirements are satisfied
[2023-07-07 14:51:08] Startup - updater built Jun 21 2023 21:17:38
[2023-07-07 14:51:08] Startup - Steam Client launched with: '/home/pcb-heavy/.local/share/Steam/ubuntu12_32/steam'
07/07 14:51:08 Init: Installing breakpad exception handler for appid(steam)/version(1687386907)/tid(6658)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2023-07-07 14:51:08] Loading cached metrics from disk (/home/pcb-heavy/.local/share/Steam/package/steam_client_metrics.bin)
[2023-07-07 14:51:08] Using the following download hosts for Public, Realm steamglobal
[2023-07-07 14:51:08] 1., /, Realm 'steamglobal', weight was 1000, source = 'update_hosts_cached.vdf'
[2023-07-07 14:51:08] 2., /client/, Realm 'steamglobal', weight was 1, source = 'update_hosts_cached.vdf'
[2023-07-07 14:51:08] 3., /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
[2023-07-07 14:51:08] Checking for update on startup
[2023-07-07 14:51:08] Recherche de nouvelles mises à jour...
[2023-07-07 14:51:08] Downloading manifest:
[2023-07-07 14:51:08] Manifest download: send request
[2023-07-07 14:51:08] Manifest download: waiting for download to finish
[2023-07-07 14:51:08] Manifest download: finished
[2023-07-07 14:51:08] Download skipped: /steam_client_ubuntu12 version 1687386907, installed version 1687386907, existing pending version 0
[2023-07-07 14:51:08] Nothing to do
[2023-07-07 14:51:08] Vérification de l'installation...
[2023-07-07 14:51:08] Performing checksum verification of executable files
[2023-07-07 14:51:09] Verification complete

(process:6658): GLib-GObject-CRITICAL **: 14:51:09.561: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:6658): GLib-GObject-CRITICAL **: 14:51:09.561: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xe9238db0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xe9237500
GetWin32Stats: display was not open yet, good
Loaded SDL version 3.0.0-1782-g214d5daa3

(steam:6658): Gtk-WARNING **: 14:51:10.307: Unable to locate theme engine in module_path: "adwaita",

(steam:6658): Gtk-WARNING **: 14:51:10.311: Unable to locate theme engine in module_path: "adwaita",
GetWin32Stats: display was not open yet, good
ComputeStartupMode: found registry default startup mode: 0
Switching to desktopui, since -vgui was not specified[6693]: Runtime for steamwebhelper: defaulting to /home/pcb-heavy/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[6693]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
Could not connect to X session manager: None of the authentication protocols specified are supported
CAppInfoCacheReadFromDiskThread took 45 milliseconds to initialize
Failed to init SteamVR because it isn't installed
Assertion 'device' failed at src/libsystemd/sd-device/device-private.c:103, function device_get_tags_generation(). Aborting.
crash_20230707145111_26.dmp[6869]: Uploading dump (out-of-process)
/home/pcb-heavy/.local/share/Steam/ : ligne 798 :  6658 Abandon                 (core dumped)"$STEAMROOT/$STEAMEXEPATH" "$@"
[pcb-heavy@PCB-Heavy ~]$ crash_20230707145111_26.dmp[6869]: Finished uploading minidump (out-of-process): success = yes
crash_20230707145111_26.dmp[6869]: response: CrashID=bp-be5eb088-d0d5-4ed2-b37f-b99002230707
crash_20230707145111_26.dmp[6869]: file ''/tmp/dumps/crash_20230707145111_26.dmp'', upload yes: ''CrashID=bp-be5eb088-d0d5-4ed2-b37f-b99002230707''

I cannot grasp what is the error here. Can anyone help me ? Thanks a lot !

Same, I’m guessing it’s the latest kernel that’s causing it. I’ve tried reinstalling or using the open source nvidia drivers but no help. Only thing i haven’t tried is using an older kernel.
For me I can’t even launch games through Heroic Proton/ProtonGE, or at least while they are in the background they run normally but once in the foreground it freezes or just runs with 1FPS.

1 Like

Steam still works for me, I run it in a Flatpak though so that I don’t have to install any 32 bit libraries just to be able to run Steam and Lutris.


Its working fine for me on the LTS kernel, both 6.1.38-1-lts and 6.1.37-1-lts (2 separate machines.

I did have a problem launching steam when they updated the steam UI a short while ago, that turned out to be an issue with a xdg library. The solution was to remove it. xdg-desktop-portal-gnome


A lot of people are pointing finger libgudev 238-1, it works just fine for me, though do note I am on nvidia and I do not have the lib32 variant of libgudev 238-1


@Cphusion the more I use arch, the more I start to understand why people insist flatpak is just better for user installed gui-apps

Edit: looks like someone on the github issue page more or less confirmed its the lib32 variant of libgudev 238 that’s the issue

I was using Flatpaks when I was using Fedora(I just switched to EndeavourOS two weeks ago) as well to avoid having to install 32 bit libs and because it’s nice to be able to run proprietary applications in a sandbox even though it’s not a perfect sandbox.

Similar problem here but I can launch Steam fine but after system & Nvidia AUR update, I can launch Steam still but none the games will launch today eg Dead Space, creaks, Stray etc all wont launch…ie …the green play button just turns blue and nothing happens?? Everything was fine last night before I updated today?? Is there a fix?

A lot of people have problems with Steam now after recent updates. Here is a Issue-Thread on GitHub:

Quote from GitHub (User:

Here are some solutions that worked for me. I have only tested these on Arch Linux:

  1. Installing lib32-libudev0-shim
    This causes Steam’s version of libudev to not load.
  2. Installing lib32-libnm
    Steam uses a library called libnm. If a version of this library exists on the system, it uses it; otherwise, the one provided by Steam is used. libnm makes calls to libgudev, which subsequently makes calls to libudev, causing the crash. Using a version of libnm provided by Arch does not cause the crash.
  3. Preloading/installing an older version of the libgudev
    Older versions do not call the failing function.

I used Option 2. to solve this issue. Will check in a couple of days/weeks if it works again without this package. But after installing it Steam starts just fine again.


I tried the first one and it looks like *-shim is already installed on my machine for some reason, so no luck there.
Number 2 worked for me, I just am crossing my fingers that it doesn’t do anything funky to break my network connections :sweat_smile: I have a troubled history with the networkmanager package family

Had this same problem yesterday after running updates.
Error was also[10400]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
Could not connect to X session manager: None of the authentication protocols specified are supported

Installing steam-native-runtime and letting steam reinstall proton solved the problem temporarily. Using steam-native-runtime is not recommended because it might break some games due to binary incompatibility and miss some needed libs.

For me installing lib32-libnm (yay -S lib32-libnm) solved the issue.

Is anyone having this problem when no Proton-enabled games are installed? For me, this issue never came up (only have native Linux or Electron-based games at the moment), libgudev was upgraded on 7/9.

Thank you so much! I searched and found this answer. Steam now works!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.