Steam not visible

After updating my PC yesterday when I came back from vacation steam is now failing to show up. I can launch games through the bottom task bar, but I receive continuous GLib errors when it tries to display the actual window.
I recently saw an issue with an Nvidia driver causing steam to break, and as I am running Nvidia could this be the issue? Another strange factor is, it will randomly work if I close and launch it repeatedly, which seems to be similiar to this issue: however, the proposed solution to launch steam without hardware acceleration didn’t work for me. I also tried installing lib32-libnm and shim via AUR as seen in this post without avail:
Steam not launching - #8 by Shamshiel
Ryzen 9 5900x
RTX 2080TI
GTX 1060 6GB
32GB 3600mhz
Kernel = 6.4.2-zen1-2-zen
GPU Driver = nvidia-dkms 535.54.03-1

Steam Log:

Some people reported Steam flatpak was working better have you tried that? There has definitely been a couple bugs in the new kernels. Also apparently there is a new lts kernel out some people reported some improvements also from the previous crashes…but it’s not perfect yet for all .

(I have rolled back to 6.1.35-1-lts kernel via a clone backup I had, and all is fine…i havent updated yet until the bugs are all fixed…)

mentioned here Black Screen on Boot Up that Never reaches Login screen - #53 by robb71 and here …flatpak mentioned here After update Nvida just now, Steam Games wont play/launch.pls help

1 Like

Yeah, have been using flatpak as a workaround, would still like normal version to work since the flatpak versione behaves differently and I dont like having to deal with slow flatpak updates for GPU drivers in nvidia

How does it behave differently I haven’t noticed a difference between the normal version and the Flatpak version, except for it taking a few seconds longer to launch but for the rest the experience is the same And the system Nvidia drivers and the Flatpak Nvidia drivers take about the same amount to install.

1 Like