After update Nvida just now, Steam Games wont play/launch.pls help

Just did an update all AUR packages. Saw Nvidia was updated. But now I can open Steam app but Dead Space game wont play. The play green button just turns blue and nothing happens. The game does not load after Nvidia update. It was working fine all last night.

edit…actually none of the games will launch eg Dead Space, Stray, Creaks etc none will lauch…after press the green play button it turns blue and does nothing…no launch…no fans working overtime…Games just dont launch after Nvidia update? Is there a fix?

Which AUR Nvidia package are you using and do you have Steam installed as a normal package or as a Flatpak?

I have steam installed as a normal package.
I just have the Nvidia-dkms package installed from before installation. Didn’t change anything.

Was all working fine yesterday but after update today Steam launches still but none the games will launch…:sob:

Downgrade the nvidia-dkms package to the version you were using before the upgrade, then reboot and see if you are able to launch your games again. Why are you using an AUR package for the Nvidia driver?

Not sure why I am using AUR package for Nvidia driver…which one should I be using?

I tried to change driver after reading this nvidia-470xx drivers not loading after update to 6.4 kernel / Kernel & Hardware / Arch Linux Forums because I had no idea basically and was wondering if it was same issue, but I got error message

error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: nvidia-470xx-utils and nvidia-utils are in conflict
→ error installing: [/home/sz/.cache/yay/nvidia-470xx-utils/nvidia-470xx-utils-470.182.03-2-x86_64.pkg.tar.zst] - exit status 1
error making: nvidia-470xx-settings - exit status 8
error installing: [/home/sz/.cache/yay/nvidia-470xx-utils/nvidia-470xx-utils-470.182.03-2-x86_64.pkg.tar.zst] - exit status 1

How to downgrade safely and install other nvidia drivers? Which driver should I install?

Which Nvidia GPU do you have?

Asus Vivobook pro 14x , AMD Ryzen 7 5800H cpu, Nvidia RTX3050Ti

Yous should be able use the same driver(535.x.x) as me since I have a gpu from the same generation or is there a reason you are using a more recent driver?. I have the following packages installed from the default repos and the endeavouros repo.


Try remove the 470 driver and install the same pacakges as me and then reboot.

I was never able to install the 470 driver. Thats why I got errors. I was trying just to install another Nvidia driver see if that fixed it. So my current drivers are same as you?

all I did was an update this morning

yay -Syyu

and none the games in steam will launch suddenly after that? Steam opens fine but cant launch any games.

That wasn’t clear, yeah then I have the same drivers installed as you. The only difference is that I’m using the Flatpak version of Steam. I don’t see any recent Nvidia updates, only kernel updates. What kernel are you currently using, the vanilla kernel or another kernel?

BTW I also happen to see in Steam community discussion mentioning many same problem with the new Nvidia driver?

Note: while process was updating this morning, I did notice the terminal mention nvidia updating so not sure which package…?

I am using the standard kernel ? Kernel: 6.1.38

When a kernel gets update nvidia-dkms will update the Nvidia driver to create a kernel module to work with the new kernel. Try installing the linux-lts kernel, boot into that and see if you get better results? That discussion is about the Windows Nvidia driver since they are mentioning WHQL. Which Dead Space game are you trying to play?

from the Steam Dead Space discussions I saw this also
and here but seems fixes are Windows solutions?

Fixed Dead Space (2023) report DirectX errors CTD issues (NVIDIA Driver R536.40)

If you get an error in the game. try the following steps.

WHQL refers to Windows Nvidia drivers. You are trying to play the newest Dead Space game?

Yes …it was working fine last 4 days until I updated today

I can buy the game to see if I can run it but try installing the “linux-lts” kernel first and then booting into it to see if it runs then?

I checked pamac and seems installed already?

Remind me how do I boot into this kernel ? Been ages since I done this…

Reboot your system, then you should get a menu where you are able to select it and then press enter to boot into that kernel.

Ok i try that,

BTW the new DeadSpace 2023 is great. Considering I just got 16Gb ram it is definitely playable on Endeavouros in Steam package

I rebooted into Kernel: 6.1.38-1-lts
but still same games wont launch in Steam…
Wondering If i uninstall then reinstall the game will do anything? It funny how many people in steam discussions saying same thing but they on windows…ie game wont launch

is there a way I can roll back to an older driver?