After update Nvida just now, Steam Games wont play/launch.pls help

I don’t think there were Nvidia updates in the past few days just kernel updates because I haven’t seen any in my pacman log file. Is it just that game having that problem or all of your games?

You could try using “sudo downgrade nvidia-dkms”

all the games wont play in steam. Ya could be an update from the kernel causing this because like I said it was fine last few days…

I might just try to install Steam flatpak completely because after wiping cache in steam, (steam settings say might help) and now steam wont even launch lol

I have been using Steam Flatpak for quite a while now without any issues, would recommend it over the normal package and it saves you from having to install 32 bit libraries on your system just for Steam.

Look in your pacman.log do check what was upgraded during the upgrade when it was still working?

I will try flatpak…because nothing seems to work in steam AUR for me now…games wont launch at all…

BTW some on steam are saying limit FPS to 40 as a work around? How to do that in steam? I tried install libstrangle but I keep getting error message? Anyother way limit fps in steam in linux?

I don’t see a Steam AUR package?

In the settings of the game you can set a max refresh rate and otherwise you can lower the refresh of your monitor under display settings or via nvidia-settings.

in my display settings i see only 90Hz and 60hz cant set to 40fps?

Also my nvidia settings I cant see anywhere set FPS?

My steam in PAMAC says official repositories? i assumed that was AUR?

BTW do you have libstrangle installed? I cant install it on Endeavour but I had no problems on my old Ubuntu laptop.

edit: also yeah I cant get into the game at all so I cant change the fps in the game settings as you suggested.

I installed flatpak just now but do you have to run

flatpak run com.valvesoftware.Steam

each time you run it?

It looks like you are using a Wayland session when I look at your nvidia-setting screenshot. What happens when you switch to an Xorg session?

No, when you have the Flatpak installed you get an additional menu item. I just use a menu item to open Steam.

yeah I been running Wayland…Will try Xorg later.

I might just try downgrade the driver as some on Steam suggested. So if i just run

sudo downgrade nvidia-dkms

I can choose which one to downgrade to in terminal?

(This is so frustrating cos I wasted alot time to get the game running good in Steam>proton…wasted alot of hours in the game settings getting it playable and without motion sickness lol…was really enjoying it…but now none my games will play).

Nvidia is known to still have more issues with Wayland sessions than AMD gpu’s so I would definitively try it.


Do you remember what day what do you still had a working Dead Space and what day you updated after which you weren’t able to launch any games anymore?

I bought the game, it launches and runs for me using the Flatpak version of Steam.

1 Like

Thats good. I installed Flatpak and Steam and the Game runs in Flatpak…but I noticed in settings it is not using the NVidia driver in the anti aliasing settings? Does that mean the game is not launching via the Nvidia driver?

I am worried if I switch the setting to use Nvidia driver it might not load again …it seems a bit jerkier with this amd setting instead of nvidia?

That doesn’t select the driver just what type of AA to use, since you have an Nvidia gpu that should be Nvidia DLSS. I ran it with Nvidia DLSS as well.

1 Like

1 Like

before yesterday I could see the Nvidia DLSS option but after update today and reinstall, it’s not available now…just AMD and TSS or something…So I feel there is definitely something wrong with my Nvidia driver… I might have to try to downgrade the nvidia driver unless nvidia comes with a fix for all the other dead space players who saying its due to new update in nvidia…? The resolution seems lower for sure on this AMD setting…

I’m using the nvidia-dkms 535.54.03-1 version of the driver, which is the most recent one available from the repos.

I can see these two were recently updated…wonder if the problem is related to this

? because during the upgrade process I definitely saw the word nvidia pop up in the log while updating evreything

I want to try that…how do I change to this driver exactly?

actually says I am using same already? Which kernel are you using?

The default kernel: 6.4.2-arch1-1.

It may be useful to know I use the following launch options:

Be sure to install gamemode and enable it.

sudo pacman -S gamemode
systemctl --user enable gamemoded --now