Steam refusing to open

I ran the usual Syu update, and rebooted. When I tried launching steam, I received the following error:

[XXX@YYYY ~]$ steam[1869]: Running Steam on endeavouros rolling 64-bit[1869]: STEAM_RUNTIME is enabled automatically[1943]: Steam runtime environment up-to-date![1869]: Steam client's requirements are satisfied
[2023-06-15 22:33:39] Startup - updater built May 30 2023 20:40:12
[2023-06-15 22:33:39] Startup - Steam Client launched with: '/home/XXX/.local/share/Steam/ubuntu12_32/steam'
Installing breakpad exception handler for appid(steam)/version(1685488080)/tid(1994)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

I checked to make sure I don’t have any testing repos enabled in my pacman.conf, and have tried reinstalling both steam and the nvidia drivers as well as the vulkan utils through the AUR (a solution I found elsewhere) with no luck.

Anyone have any ideas, please?

1 Like

People are reporting similar issues in this thread:

It has most likely something to do with the major Steam update that just happened

1 Like

I followed the recommendation from the issue in the Steam for Linux github page and reinstalled mesa-utils. After a reboot that seemed to fix it for me.

I also saw mention in the German language thread of downgrading some Nvidia packages to resolve the issue.

Hopefully one of those works for you.

Edit: Just kidding… It seems I can get steam to launch if I run steam-runtime --reset but any reboots that steam needs results in the same issue if the launch failing.

1 Like

Ran into this same issue today - couldn’t figure it out. Ended up planning to reinstall to get a clean XFCE install and Steam is working just fine now. Go figure :upside_down_face:

1 Like

Fixed it by enabling the testing repo and downloading the lib32-nvidia-utils (version 535 at the time of posting) and rebooted, which got steam running again.

Found solution on


My issue wasn’t resolved by updating the lib32-nvidia-utils. Even with everything up to date and matching it was still failing to launch.

For some reason steam would launch the first time after resetting it, but then any subsequent launch would error out. I came across this thread on the steam forums and there was a mention of deleting xdg-desktop-portal-gnome. Since I don’t use gnome I removed that and steam is now launching as expected

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.