Sound isn't working on new install

Today, I received a new ThinkCentre M90a PRO Gen 4 All-in-one. (I will share photos later when I am ready to get it to work)

I have been scratching my head for almost 2 hours now but I can’t get the sound working on both the internal speakers as on wired headphones. (I haven’t enabled Bluetooth yet, so I haven’t tried wireless headphones yet.)

Pipewire is running, the Intel audio is recognized and I have tried both mainstream and LTS kernels.

This is my inxi output:

[bryan@Quicksilver ~]$ inxi -Aa
  Device-1: Intel Alder Lake-S HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:7ad0 class-ID: 0401
  API: ALSA v: k6.6.16-1-lts status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

BTW, I also tried the live environment and it isn’t working over there as well. (I didn’t check the audio before install, thinking it would work out of the box being last year’s Intel Alder Lake.)

Let me guess…i’ts actually Realtek’s ALCxxxx something something…

What does

aplay -l


I’m afraid you’re right

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Well…last time i’ve seen one of those - personally i was able to launch it only via jack - which is just perfect for me since i do it anyway! :smiley:

So, what does that do, replace pipewire-jack?

In my case yeah, but you can try with pipewire-jack, it should work pretty much the same i believe…at least it intends to, for your needs, unless you’re musician / producer - it should be enough.

Personally i had no direct experience with pipewire-jack though, so tread carefully!


P.S. You’ll need to force route all audio through pipewire-jack. otherwise it will be only jack aware programs

Isn’t jack for external speakers? I have internal speakers.

No it has nothing to do with your audio setup, it’s just an audio backend that is geared more towards pro-audio and musicians…that’s why it has the most direct access to inputs / outputs for nearly any DAC / audiocards…that’s your best chance i think, unless there’s something i don’t know…but usually Realtek is absolute mess!

1 Like

So, how do I force the sound through it? Pipewire-jack is installed and it is enabled with the pipewire.service

I’m afraid you’d have to consult someone who’s in the knows or dig it yourself, i have experience only with pulseaudio + jack2 + cadence so far, i haven’t really dug into pipewire at all…so if someone else could help or you’d figure it out and write a little instruction - it would be great! :upside_down_face:
You may need some nice GUI connector to figure it out easier during first stages:

When i do it with pulseaudio + jack2
Basically in Cadence i set plugin bridge like that:

So it makes auto-connections of any input to my DAC input-outputs automatically, like that:

At least in my case that thing is called PulseAudio JACK Sink, not sure about pipewire…hopefully it will help you some

I give up, for now, I enabled pulseaudio + jack2 and it still doesn’t work. Perhaps tomorrow when I look at it with a fresh pair of eyes. At the moment, I have the urge to throw the entire machine through the room…

While Ubuntu isn’t generally my favorite distro, they are probably the best distro to cover hardware support.

Maybe give it a go and if it does work, we can check out what’s missing from our install.


That’s actually not a bad idea!

I tried both Ubuntu and Fedora and they both show the same behaviour. The hardware is recognized but the sound isn’t coming out. (And it isn’t muted either)

Back to jack then! :smiley:

!!! Warning !!! - it’s likely outdated, it’s my older guide…but since you decided to go pultseaudio + jack2 route… it might help.

Here’s basic setup…

Install those packages:


Launch Cadence and do it’s most basic settings (to route all audio through JACK):

JACK Settings
[x] Auto-start JACK or LADISH at login

ALSA Audio
Alsa -> PulseAudio -> JACK (plugin)

[ ] Auto-start at login

[x] Realtime

[x] ALSA
    [x] Duplex Mode !
    Device/Interface - your audio card
    Sample rate - 44100 kHz
    Buffer size - 512
    Period/Buffer - 2

System settings - Audio
[x] JACK sink (PulseAudio JACK Sink)

Smaller buffer size - obviously smaller will be latency, but if you just listen and don’t create music - it should be safe starting value (although outcome heavily depends on Audio hardware, usually you should aim for as small value as possible, which doesn’t introduce crackles / xruns)

Inside Cadence there is Tools - Catia - here you can route anything to any connection like an octopus :slight_smile:

I would also try uninstalling the sof-firmware package.
Could be a false detection…
And check boot journal for firmware:

journalctl -b -0 | grep firmware

1 Like

Okay, I have tried several things, including @keybreak’s guide and now I can’t properly get back to Pipewire or pulse audio.
Since it is a new install and I have backups, I’m going to start from scratch again and do a reinstall. But it is a peculiar hardware failure. In the worst case, I don’t need audio to do my tasks for EOS :woozy_face: :grimacing:

Work without music?!
NO! We won’t allow that.

1 Like

I did a reinstall (offline) and while updating the system, I got the message couldn’t write to pipe (broken pipe)

Okay, everything is back on by default, I haven’t removed or added anything yet but as @joekamprad suggested me elsewhere, I ran and the output is this:

EDIT: The headphone jack is working now, and all I did was go to the shop to get some groceries. In other words, I didn’t do anything.
Next step, is speakers.