Sound disappears after editing i3 config

After installing EOS I edited the i3 config file. The edits had nothing to do with sound. I can post the config file if needed. I had saved the original config file. But when I replaced the edited file with the original I still had no sound. I can’t for the life of me figure out why sound doesn’t come back when using the original file. By the way, I’d rather not post the edited file. I don’t have a copy of that. The only way to get that back would be to edit the file again which breaks sound. The only way I got sound back was to reinstall EOS. But if I have to I’ll edit the file again. At this point I’m about ready to give up on EOS. I never had such problems with Mint. I have my system set up for dual boot so I can still go back to Mint.

That’s less than useful. Eos is arch based and just different than Ubuntu based distro. It’s your choice what you prefer, it’s freedom of choice.

Please post hardware info and config file if you need help, without info’s no one can help solving your problem. :man_shrugging:

It is not very common, I also use i3wm and never ran into sound issue. Did you install/uninstall anything alsamixer or pulsaudio related? Can you at least post the part of your config with the audio?

Here’s what was asked for.

[richardw@richard-inspiron155501 ~]$ inxi -Fxxc0z --no-host | eos-sendlog
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3164 0 24 100 3140 140 18388 --:–:-- --:–:-- --:–:-- 18502
https://clbin.com/CgIPF
[richardw@richard-inspiron155501 ~]$ journalctl -b -0 | eos-sendlog
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 179k 0 24 100 179k 122 917k --:–:-- --:–:-- --:–:-- 921k
https://clbin.com/Ch0nu
Config file audio section## Multimedia Keys

Summary
# volume
bindsym XF86AudioRaiseVolume exec amixer -D pulse sset Master 5%+ && pkill -RTMIN+1 i3blocks
bindsym XF86AudioLowerVolume exec amixer -D pulse sset Master 5%- && pkill -RTMIN+1 i3blocks


# Pulse Audio controls

#volume up
#bindsym XF86AudioRaiseVolume exec pamixer -i 5 --allow-boost && dunstify -h string:x-dunst-stack-tag:volume volume: $(pamixer --get-volume)%
#volume down
#bindsym XF86AudioLowerVolume exec pamixer -d 5 --allow-boost && dunstify -h string:x-dunst-stack-tag:volume volume: $(pamixer --get-volume)%
#mute
#bindsym XF86AudioMute exec pamixer -t && dunstify -h string:x-dunst-stack-tag:mute mute: $(pamixer --get-mute)!

# gradular volume control
bindsym $mod+XF86AudioRaiseVolume exec amixer -D pulse sset Master 1%+ && pkill -RTMIN+1 i3blocks
bindsym $mod+XF86AudioLowerVolume exec amixer -D pulse sset Master 1%- && pkill -RTMIN+1 i3blocks

# mute
#bindsym XF86AudioMute exec amixer sset Master toggle && killall -USR1 i3blocks
#mute
bindsym XF86AudioMute exec pamixer -t && notify-send "mute: $(pamixer --get-mute)"

bindsym XF86AudioPlay exec playerctl play
bindsym XF86AudioPause exec playerctl pause
bindsym XF86AudioNext exec playerctl nextw
bindsym XF86AudioPrev exec playerctl previous

I didn’t install any audio software or anything else for that matter.

Do you use the Endeavour grub or mint? Just curious.

This is extremely unlikely that an edit of the i3 config would change your sound if not directly related to audio. Is this only after reloading the config file, or is this after a full reboot? Does this occur on the lts kernel as well?? Please post the terminal command you used to edit tht file, I don’t know which file you specifically edited at this point and I need to verify we’re both in the exact same place.

That would be like asking a mechanic to fix your car without actually seeing it. It likely won’t be possible to help you.

Thank you for giving EOS a try. The reality is we’re not for everyone. We’re here for intermediate terminal centric users. Mint is fantastic, but you’re not going to get i3, and you’ll likely not grow much as everything just works. That’s up to you and your Linux journey. We’ll be here later as you progress.

And I looked over your eos-log, my Dell I use for testing is a Dell 15 Inspiron with basic Intel graphics also. I don’t know I’ve ever had issues with the hardware on Linux in 5 years with the computer. I would venture it’s a config file issue, although I could be wrong.

1 Like

Also your post is looking almost like a simple rant, i will try helping.

from boot logs i see only this:

Nov 13 23:25:37 richard-inspiron155501 alsactl[628]: alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HDA Intel PCH at 0x6001130000 irq 146)
Nov 13 23:25:37 richard-inspiron155501 alsactl[628]: alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6
Nov 13 23:25:37 richard-inspiron155501 systemd[1]: Finished Save/Restore Sound Card State.

but Hardware info shows that Soundsystem is started and working:

Audio:     Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:34c8
           Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no

On eos-i3 you can click on the panel (little speaker symbol) do get audio setup and mixer tool open:
2021-11-14_12-19
And paprevs to handle pulseaudio server behavior.
check if your audio output device is chosen correctly:

  • If your config shows more than one device it can be that you need to disable others to unmute the one you want to use for output.

  • And in some cases you need to enable simultaneous output with paprevs tool.

  • And there is an easy way to reset pulseaudio settings to default:
    mv ~/.config/pulse ~/.config/pulse.bak this move the users pulseconfigs to a backup folder and after logout – back in you will use default settings again.

  • alsamixer can show issues also choose your audiodevice (F6) and see if may some output sliders are muted e.t.c.

  • https://discovery.endeavouros.com/audio/getting-information-while-having-sound-issues/2021/03/

1 Like

Would you mind elaborating a bit who this “we” is referring to?
As far as I understand, apart from being “terminal-centric”, EnOS isn’t intended for any particular user category.

I am convinced that anyone who has been capable of downloading the ISO, making a bootable USB and installing the operating system, is also perfectly capable to copy/paste in a terminal the instructions to get going Bluetooth for example:

I’m not sure why you were editing the i3 config files but it probably wasn’t necessary to reinstall i3. That is something you chose to do because you couldn’t fix what ever the problem was that arose. You should have posted the config files to show what you did if you wanted help. This is an Arch based distribution and is nothing like Mint which is ubuntu based and this is also a Window manager nothing like anything Mint.

I use i3 occasionally and i find the setup perfect and have never had any sound issues.

1 Like

Often it boils down to a proprietary driver issue. It may be available as .Deb package but not for Arch, and the necessitates separate install via AUR and perhaps some tweaks often found in the arch wiki which is very comprehensive. So the first thing I would do is check that sound card and whether it is supported on Linux. Then pulse audio etc. For the i3 config, start with the default one and fix audio first. Just my two cents. I am not good at audio fixing.

Yeah but that link is confusing, Bluetooth has nothing to do with topic…

And if user jump to mint or Ubuntu if a problem arises, then obviously they are not ready for arch based distro. Forum can help, but requires user patience too

I consider myself an intermediale terminal user. I was able to edit the hell out of the i3 config file while using Mint without a problem. I tried a few different wms including XMonad . I like i3 the best because the config file is so easy to edit. To reiterate a few essential points: Sound was working after installing EOS so whatever sound software is installed is working. The first thing I did after installing EOS was to edit the i3 config file. No other other software was installed. I can go ahead and edit the i3 config file again but that will break sound. The only way I’ve been able to get sound back was to reinstall EOS. Even going back the the origiinal i3 config file did not bring back sound. I can do the edits if I have to in order to send the config file that broke sound but rather not have to reinstall EOS.

We = EOS. It’s not generally intended for completely new users, as new users are rarely accustomed to the terminal. So advanced/ambitious beginners and up. Intermediate is just easier to type.

You should NEVER blindly copy and paste anything into the terminal. If you’d like to talk to me more about this, I have already messaged you. I would prefer to keep this thread on topic to help the OP if possible.

It’s not. Dell Inspiron 5510 with all Intel everything. It’s almost 100% not this problem.

Mint i3?? Now I’m confused. Are you using Mint XFCE with i3 inside of it? How did you set this up??

It is obvious to me that the OP tried to edit the config files and either replace them with something other.
Sound issues can be difficult to diagnose and fix to begin with.

1 Like

the EndeavourOS i3 config does not set up anything related to the Soundsystem itself (pulseaudio) config only has some switches to handle multimedia stuff and starters for common tools to handle audio.

And EndeavourOS do not configure anything different from default using pulseaudio by choosing the packages to be installed. Pulse enables itself when login in to any DE/WM.

So if @Whatmeworry wants to endeavour on the sound issue please try the stuff I do already write above. If not? This thread will get closed soon.

3 Likes

With Mint I originally used the Cinmamon DE. I downloaded i3 and it works like a champ. I’m curious that one person who responded was confused about how I could be running i3 under Mint. I actually tried a few other WMs such as XMonad but came back to i3 because the config file is so easy to understand. I may not be able to provide what’s necessary for someone to help with this. The only other thing I can think of to do is to edit the config file again so I can send the config file that breaks sound. But so far the only way I’ve been able to get sound back is to reload the OS. I’ve already done this a few times

Thank you!

I would appreciate if you could point out to me that an intended user category is explicitly defined for EnOS. The fact that someone may make use of a terminal would not necessarily mean that they are intermediate or advanced. Same as, an advanced user might make use of a GUI tool even in EnOS, does that make them less advanced?

Even if that includes me as well as EnOS users, I might or might not agree with you on the point you are trying to make. I actually don’t.

I am not taking this any further here. Perhaps at some point I will make a new thread to dissipate some doubts about who really EnOS is intended for.

Thanks for your time and response!
So long!

PS-

Sorry @Whatmeworry for the OT.

@moderators please feel free to split, move, delete or what else you would see fit.

As has already been stated by @joekamprad i3 config files do not set up anything related to sound. The i3 setup is perfect as configured in the download and installation and everything works perfectly. There is no issue with i3.

It was me. Linux Mint ships Cinnamon, XFCE and MATE. No i3. https://linuxmint.com/download.php

If you used it within Mint (especially Cinnamon) I’m REALLY impressed, that’s not easy (I know, I’ve tried. I’ve tried putting i3 in literally everything - see my post about running i3 within EOS XFCE for instance).

That would work. . . and try what Joe posted. Otherwise I don’t see this thread going on much longer.

you could also simply say what you change on i3 configs and what files you had changed and how could be given a hint too…