Installing i3wm after installing EOS

I was unable to do the installation online so I did it offline. So I just have the default environment currently. Could someone help me install i3wm? I tried instructions I found online but it didn’t complete the job. If you need the exact instructions I’d have to go back and run them again. Hopefully someone will bear a fool kindly and just give me the instructions. If I can copy and paste the commands that would be great.

Post inxi -Fxxxza --no-host from a terminal/tty.

Please link to “instructions I found online.”

Here ya go. I ran pacman to install i3 and i3blocks but that didn’t complete the job.
System: Kernel: 5.15.2-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-linux
root=UUID=f17abd40-f6af-4b3f-beb2-aeb55b71682e rw quiet loglevel=3 nowatchdog
Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux
Machine: Type: Laptop System: Dell product: Inspiron 15 5501 v: N/A serial: Chassis:
type: 10 serial:
Mobo: Dell model: 07GGFN v: A00 serial: UEFI: Dell v: 1.3.0 date: 05/20/2020
Battery: ID-1: BAT0 charge: 54.2 Wh (100.0%) condition: 54.2/53.0 Wh (102.2%) volts: 16.8
min: 15.0 model: SMP DELL 9077G06 type: Li-poly serial: status: Full
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake
family: 6 model-id: 7E (126) stepping: 5 microcode: A6 cache: L2: 6 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19048
Speed: 1300 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1300 2: 1301 3: 1301
4: 1300 5: 1160 6: 1201 7: 1174 8: 1201
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 3-6:3
chip-ID: 0bda:5538 class-ID: 0e02 serial:
Display: x11 server: X.org 1.21.1.1 compositor: xfwm4 v: 4.16.1 driver: loaded: intel
unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_icl bus-ID: 00:1f.3 chip-ID: 8086:34c8
class-ID: 0403
Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: yes
Sound Server-4: PipeWire v: 0.3.40 running: no
Network: Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
chip-ID: 8086:34f0 class-ID: 0280
IF: wlan0 state: up mac:
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
chip-ID: 8087:0026 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block:
hardware: no software: no address: see --recommends
Drives: Local Storage: total: 536.1 GiB used: 5.81 GiB (1.1%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
type: SSD serial: rev: 11001101 temp: 26.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Glide 3.0
size: 59.16 GiB block-size: physical: 512 B logical: 512 B type: N/A serial:
rev: 1.00 scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition: ID-1: / raw-size: 97.77 GiB size: 95.68 GiB (97.86%) used: 5.8 GiB (6.1%) fs: ext4
dev: /dev/nvme0n1p4 maj-min: 259:4
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 4.6 MiB (0.9%)
fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
Swap: Alert: No swap data was found.
Sensors: System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info: Processes: 227 Uptime: 2h 0m wakeups: 5872 Memory: 7.54 GiB used: 1.98 GiB (26.2%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 787
lib: 204 Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.07

wiki useful + should read

info near end

git clone https://github.com/endeavouros-team/no -i3wm-setup.git
cd endeavouros-i3wm-setup

sudo pacman -i3
–and chose 2 3 to install i3 and i3block

cp -R .config/* ~/.config/
–and no such directory exists. This where I get stuck
–The next command is
chmod -R +x ~/.config/i3/scripts
but scripts doesn’t exist yet. So where do I go from here?

So, not to sound like a jerk, is there a really good reason you can’t do an online install? Imo, it’ll be a lot cleaner of an install if you can do it correctly the first time instead of this second setup after the setup??

And since it’s a right new install, you may be happier with the outcome, and have no old stuff you’re trying to save.

1 Like
git clone https://github.com/endeavouros-team/endeavouros-i3wm-setup.git
cd endeavouros-i3wm-setup
cp -R .config/* ~/.config/
chmod -R +x ~/.config/i3/scripts
dbus-launch dconf load / < xed.dconf
sudo pacman -S --needed - < packages-repository.txt

if you have xfce installed

comment this line in i3wm config
#exec --no-startup-id dex -a -s /etc/xdg/autostart/:~/.config/autostart/

btw i dont use eos

1 Like

Only do this if you’re using i3 within xfce. Alone it should be as is I believe. I’m not 100% on this, but almost. . . Can anyone else verify this?

If the goal is to use i3 within xfce, let me know and I’ll post the tutorial for that.

1 Like

The only reason I didn’t download an i3 version of EOS is I couldn’t get online until after the install. I did the install many times and never could get online till after the install :=(

:rofl: no everyone does … that ok

1 Like

I’m more interested in why this doesn’t work on the live iso but then does get installed with the offline install. That seems odd.

@joekamprad @manuel

yes that is true
therefore I wrote if you have installed xfce

i did not know one could install i3wm offline
only thought it was xfce one could install offline with eos

Whoever said try installing the i3 version of EOS was right. I was able to get online and download the i3 version. All I needed to do was sign in to my wifi connection. I’m good to go now - I hope. At least I have i3 installed now. I had no trouble with the config file Linux Mint. Hopefully I can just use my old config file.

You cannot on Endeavour, but you can install it after.

Um. . . What? I have absolutely no idea what you’re trying to say or ask here.

I got i3 installed by following the suggestion that I reinstall EOS this time including i3wm. I was trying to follow instructions I found in a Google search to do the i3wm installation separately but they didn’t work.
Am I missing something?

This is the essential question.

@Whatmeworry
After booting the live iso, can you
ping 8.8.8.8
?

Yes you are missing something. You are not answering most of the questions we are asking you.

So, you reinstalled Endeavour i3 now?? You were able to connect properly to the internet on your installation media this time??

Does this mean when you installed xfce OFFLINE you didn’t know to sign into wifi, or does this mean you were unable to connect? Earlier you said you couldn’t connect, and that is very very different: