[SOLVED] Unable to Load Cinnamon Session

Just installed Cinnamon Desktop, but when I went to log in, I got “Unable to Log into Cinnamon Session” with a button to Log Out. I can log back into Xfce just fine.

So, how did you Cinnamon users get yours to work? TIA

Did you change to Cinnamon at the top right? It’s the little round icon that say’s xfce.

Hi @ricklinux. Yup. That’s where I started. I didn’t try the Software version of Cinnamon, though. I’ll try that now.

I’m wondering if I missed something during the install of Cinnamon. I did the following:

sudo pacman -S cinnamon nemo-fileroller

No that’s all you need. After you’ll need to install the xdg-users-dir whatever it’s called and also the addon for Nemo for archiving file so you can right click and extract etc. There will also be some gnome stuff i can tell you all of them if needed. So why won’t it log in? Did you try a reboot? Also did you log out of Xfce first? I guess you’d have to. :thinking: I’m a big time Cinnamon user. :blush:

I’ve shut down, waited, then rebooted. When I try to log in, I get the following even with Software Rendering…

I’m not going to uninstall Xfce until I know I can get Cinnamon to work.

I would boot up and not log in and then Ctrl Alt F2 into tty and reinstall cinnamon as you did and then when it’s done reboot. So you’ll log in as root in tty.

Something similar happened to me, with the refresh rate of 75Hz and I use 60Hz, so when the monitor application and resolutions were hidden, looking blindly I could change it, but clearly there is something that does not work well in cinnamon.

Just tried this, and it didn’t work. :thinking:

I can’t say i have any issue with Cinnamon. That is one of the reasons i used it in Antergos as it seemed to have the least amount of package issues for me anyway.

Hmm? This doesn’t make any sense. I have never had one issue with Cinnamon. I’m running it right now and just reinstalled it this morning after desktop hopping. lol

1 Like

I wish I could try it. Weird stuff.

Did you add anything extra that I didn’t?

The job of choosing which DE to start belongs to lightdm. For a start, from the Ctrl-Alt-F2 console window, do the following after Cinnamon isn’t successful.

systemctl status lightdm

and see what you get.

Pudge

No i only install cinnamon and nemo file-roller. I would try removing cinnamon from the terminal when logged into xfce. sudo pacman -Rs cinnamon then you could try again only if you have no other luck.

No luck with @Pudge’s suggestion for lightdm? Is lightdm working?

[rick@endeavour-os ~]$ systemctl status lightdm
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2019-09-08 18:39:51 EDT; 34min ago
     Docs: man:lightdm(1)
 Main PID: 411 (lightdm)
    Tasks: 6
   Memory: 78.2M
   CGroup: /system.slice/lightdm.service
           ├─411 /usr/bin/lightdm
           └─447 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Sep 08 18:39:49 endeavour-os systemd[1]: Starting Light Display Manager...
Sep 08 18:39:51 endeavour-os systemd[1]: Started Light Display Manager.
Sep 08 18:39:52 endeavour-os lightdm[468]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Sep 08 18:40:19 endeavour-os lightdm[543]: pam_unix(lightdm:session): session opened for user rick by (uid=0)
[rick@endeavour-os ~]$ 

Here ya go. Sorry it’s not more clear…

Looks like it’s working to me!

Hi @ricklinux. Sorry, that didn’t work in Xfce or from the login screen in LightDM and Ctrl+Alt+F2. Still get the same error message.