[SOLVED] Screen flickering when scrolling through firefox

I installed bspwm community edition today and while installing i chose not to install the package for xf86-vedio-intel as it was more buggy and way more screen flicker while having that in my previous install and was also suggested same in endeavour discovery blog.Its the only thing i changed from default endeavour online install for bspwm edition. Now everything seems perfect expect a little screen flickering when scrolling through web pages. its not that much but as i have hopped into lot of distros and would always settle in endeavour os so thought to make it perfect as it can be this time. could you please help me with this.


and for the next query i would provide example that i have firefox open now while typing this. if i press super+enter it would open up a terminal in the same tab of window manager. i want the functionality to become like when i press the super+enter to open the terminal it open up in new workspace and window automatically switch to that workspace with the opened terminal.
sorry for my english as i am not the native english speaker.


specs:
intel i3-10th gen cpu with dedicated intel graphics; dell vostro 14, 3000 series

For query 1: Firefox screen flickering - can you check if hardware acceleration is enabled and try turning it off? (I had a similar issue on mine, turning it off fixed it… Blank sections that appear and disappear is how I would describe the issue I faced)

For query 2 (super+Enter = Terminal): Instructions will depend on desktop environment, terminal - for bspwm, add a rule like the one below (configured for your terminal) in your bspwmrc:

bspc rule -a alacritty desktop=^3 follow=on

(I took that one from: https://www.reddit.com/r/bspwm/comments/6sr7ix/open_application_in_a_specific_desktop_and_then/)

1 Like

welcome to Endeavour, btw…

thanks a lot

disabling hardware acceleration made the scrolling smoother but didn’t completely fixed the problem. I would define the issue as weird transparent horizontal line appearing and moving along the scrolling.

Try removing the intel driver and using the modesetting fallback driver.

sudo pacman -R xf86-video-intel
# Reboot
1 Like

Disable smooth scrolling, the option is in the preferences. That should fix your issue.

3 Likes

thanks a lot; it does the job but the smooth scrolling feature seems much needed as removing that made the scrolling experience more laggy. i would settle with how it is or until find the better solution.

It must be “screen tearing” what you mean, see here for Intel in the Tips and tricks:

P.S. Welcome! :partying_face:

2 Likes

i haven’t installed it in the first place.

Thanks all. Disabling smooth scrolling feature and hardware accelaration of firefox would solve the issue. All the helping hands are appreciated a lot.
Thanks devs for creating this beautiful distro.

1 Like

lastly i couldn’t change the brightness using shortcuts in keyboards the increasing and decreasing button on f6 and f7 in my case. i am using terminal to change the brightness. any way to solve that too.

thanks a lot. With xf86-vedio-intel installed i couldn’t even properly use browser with excessive flickers and random black boxes. prior to installation i had read this blog post and disabled the xf86-vedio-intel and i haven’t faced that issue in this installation.

1 Like

Yeah, but for your issue check Tips and tricks section of this article for fighting screen tearing. that should help with transparent lines :wink:

1 Like

Open the ~/.config/sxhkd/sxhkdrc file and edit relevant lines 159 - 165

1 Like

The XF86… shortcuts work for me, but you could always create new ones, some laptops the Fn+KEY does not work.

2 Likes

the tearfree option in xorg config should work also on modesetting driver :wink:

2 Likes


I was trying to install pamac using yay and it failed in middle. wanted to remove all the packages that came with the failed install and took the help of the arch wiki . but i accidentally also changed all the package installed as explicitly to dependency only by using the following command as specified in the screenshot: pacman -D --asdeps $(pacman -Qqe)
now i feel like if i ever try to remove orphan packages all the explicitly required packages would be removed too as a i have changed it to dependency. how can i undo the effect of this command and keep everything as it was before.

i am a bit novice into this thing. I noticed i have the same config as specified by you. but the brightness toggle doesn’t work still.


This i what exactly i did. how to undo this?