[SOLVED] Nvidia error

I recently started noticing an error when updateing.

ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.

After some digging around for info, I decided it’s probly safer to ask for help, but I have a few outputs that may help.

$ ldconfig
ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.
ldconfig: Can’t create temporary cache file /etc/ld.so.cache~: Permission denied

$ sudo modprobe nvidia-dkms
modprobe: FATAL: Module nvidia-dkms not found in directory /lib/modules/5.4.46-1-lts

$ lsmod | grep nvidia
nvidia_drm 53248 1
nvidia_modeset 1056768 13 nvidia_drm
nvidia 14729216 605 nvidia_modeset
drm_kms_helper 221184 1 nvidia_drm
ipmi_msghandler 69632 2 ipmi_devintf,nvidia
drm 520192 4 drm_kms_helper,nvidia_drm

Occasionally the video freezes up, so I’m wondering if fixing this may help, either that there is something very wrong.

Maybe just reinstall it?

Also, since you use the 390 driver I assume you have a vintage card?

dkms reinstall didn’t fix it

Reinstalling nvidia-390xx-dkms (390.132-38)…
Configuring nvidia-390xx-dkms…
ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.

and yes, GT 740

What is the reason you are using the 390xx drivers? Is this a laptop or desktop card? If it is a Geforce GT 740 then you should be using the 440XX series drivers.

https://www.nvidia.com/Download/driverResults.aspx/159360/en-us

You can use nvidia in the 440xx series or the dkms version…
Dkms is better choice as it rebuilds kernel modules with all updates so you can use it on both standard kernel and or lts kernel or other kernels too.

Most I can figure is when I set it up originally, the 390 drivers was the one that worked, the nvidia drivers did not support this card or the 730 which I had previously.
It was sometime during Antergos the nvidia driver stopped supporting them and had to switch to 390 drivers. They must have added them back in.

I have now changed back to nvidia drivers using the dkms, utils and lib32-nvidia-utils all 440 version

I still however get this

$ ldconfig
ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.

So I’m wondering how to get rid of it as I’m sure this means it will show again during next update.

Do you have nvidia-settings installed and did you purge them before installing the new 440xx version?

Edit:

Maybe run this and see what it shows?

pacman -Qkk | grep warning

Edit:
Don’t run this as it will show all kinds of unrelated stuff as i tried it on mine.

It is now installed, I thought it was, but it is now, so whats next

Reboot and see…

Edit: After reboot check nvidia settings in start menu? Not sure what desktop you are using? You should be able to bring up the gui settings panel.

Edit: Should look something like this.

I’ve got the settings panel
and output of

> $ pacman -Qkk | grep warning
> warning: audit: /etc/audisp/plugins.d/af_unix.conf (Permission denied)
> warning: audit: /etc/audisp/plugins.d/au-remote.conf (Permission denied)
> warning: audit: /etc/audisp/plugins.d/audispd-zos-remote.conf (Permission denied)
> warning: audit: /etc/audisp/plugins.d/syslog.conf (Permission denied)
> warning: audit: /var/log/audit (Permissions mismatch)
> warning: cups: /etc/cups/classes.conf (Permissions mismatch)
> warning: cups: /etc/cups/printers.conf (Permissions mismatch)
> warning: cups: /etc/cups/subscriptions.conf (Permissions mismatch)
> warning: cups: /var/cache/cups/rss (Permission denied)
> warning: cups: /var/spool/cups/tmp (Permission denied)
> warning: filesystem: /root (Permissions mismatch)
> warning: gvfs: /usr/share/polkit-1/rules.d/org.gtk.vfs.file-operations.rules (Permission denied)
> warning: java-runtime-common: /usr/lib/jvm/default (Symlink path mismatch)
> warning: java-runtime-common: /usr/lib/jvm/default (Modification time mismatch)
> warning: java-runtime-common: /usr/lib/jvm/default-runtime (Symlink path mismatch)
> warning: java-runtime-common: /usr/lib/jvm/default-runtime (Modification time mismatch)
> warning: lib32-colord: /var/lib/colord (UID mismatch)
> warning: lib32-colord: /var/lib/colord (GID mismatch)
> warning: lib32-colord: /var/lib/colord/icc (UID mismatch)
> warning: lib32-colord: /var/lib/colord/icc (GID mismatch)
> warning: libvirt: /usr/share/polkit-1/rules.d/50-libvirt.rules (Permission denied)
> warning: libvirt-dbus: /usr/share/polkit-1/rules.d (GID mismatch)
> warning: libvirt-dbus: /usr/share/polkit-1/rules.d/libvirt-dbus.rules (Permission denied)
> warning: lightdm: /usr/share/polkit-1/rules.d/lightdm.rules (Permission denied)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.alias (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.alias (Size mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.alias.bin (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.alias.bin (Size mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.builtin.alias.bin (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.builtin.bin (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.dep (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.dep (Size mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.dep.bin (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.dep.bin (Size mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.devname (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.softdep (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.symbols (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.symbols (Size mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.symbols.bin (Modification time mismatch)
> warning: linux: /usr/lib/modules/5.7.2-arch1-1/modules.symbols.bin (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.alias (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.alias (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.alias.bin (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.alias.bin (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.builtin.alias.bin (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.builtin.bin (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.dep (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.dep (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.dep.bin (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.dep.bin (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.devname (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.softdep (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.symbols (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.symbols (Size mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.symbols.bin (Modification time mismatch)
> warning: linux-lts: /usr/lib/modules/5.4.46-1-lts/modules.symbols.bin (Size mismatch)
> warning: mariadb: /usr/lib/mysql/plugin/auth_pam_tool_dir/auth_pam_tool (Permission denied)
> warning: packagekit: /usr/share/polkit-1/rules.d/org.freedesktop.packagekit.rules (Permission denied)
> warning: pcp: /etc/pcp/nssdb (UID mismatch)
> warning: pcp: /etc/pcp/nssdb (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmda (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmda (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmie (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmie (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmie/crontab.docker (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmie/crontab.docker (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmie/crontab.docker (Permissions mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/config.pmstat (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/config.pmstat (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/config.pmstat (Permissions mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/crontab.docker (UID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/crontab.docker (GID mismatch)
> warning: pcp: /var/lib/pcp/config/pmlogger/crontab.docker (Permissions mismatch)
> warning: pcp: /var/lib/pcp/tmp (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/bash (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/bash (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/mmv (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/mmv (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmcd (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmcd (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmcd (Permissions mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmie (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmie (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmlogger (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmlogger (GID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmproxy (UID mismatch)
> warning: pcp: /var/lib/pcp/tmp/pmproxy (GID mismatch)
> warning: pcp: /var/log/pcp (UID mismatch)
> warning: pcp: /var/log/pcp (GID mismatch)
> warning: pcp: /var/log/pcp/pmcd (UID mismatch)
> warning: pcp: /var/log/pcp/pmcd (GID mismatch)
> warning: pcp: /var/log/pcp/pmfind (UID mismatch)
> warning: pcp: /var/log/pcp/pmfind (GID mismatch)
> warning: pcp: /var/log/pcp/pmie (UID mismatch)
> warning: pcp: /var/log/pcp/pmie (GID mismatch)
> warning: pcp: /var/log/pcp/pmlogger (UID mismatch)
> warning: pcp: /var/log/pcp/pmlogger (GID mismatch)
> warning: pcp: /var/log/pcp/pmmgr (UID mismatch)
> warning: pcp: /var/log/pcp/pmmgr (GID mismatch)
> warning: pcp: /var/log/pcp/pmproxy (UID mismatch)
> warning: pcp: /var/log/pcp/pmproxy (GID mismatch)
> warning: pcp: /var/log/pcp/sa (UID mismatch)
> warning: pcp: /var/log/pcp/sa (GID mismatch)
> warning: polkit: /usr/share/polkit-1/rules.d/50-default.rules (Permission denied)
> warning: samba: /etc/sudoers.d/ctdb (Permission denied)
> warning: shadow: /usr/bin/newgidmap (Permissions mismatch)
> warning: shadow: /usr/bin/newuidmap (Permissions mismatch)
> warning: systemd: /usr/share/polkit-1/rules.d/systemd-networkd.rules (Permission denied)
> warning: systemd: /var/log/journal (GID mismatch)
> warning: vlc: /usr/lib/vlc/plugins/plugins.dat (Modification time mismatch)
> warning: vlc: /usr/lib/vlc/plugins/plugins.dat (Size mismatch)

I wouldn’t worry about this as i tried it on mine and i got a whole bunch of unrelated stuff too that isn’t a problem.

Edit: I don’t see that file anyway.

LOL I saw your “don’t run this” too late

Is the error gone? Also can you open the nvidia settings panel from the menu.(gui)

gui open

still get
$ ldconfig
ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.
ldconfig: Can’t create temporary cache file /etc/ld.so.cache~: Permission denied

When do you get the error?

Can you check if there is a nvidia-settings.conf in /etc/ld.so.conf.d

It actually showed up when I was doing updates.
But I guess i was assuming it will just keep showing whenever it needs to update again.
And since 390 drivers are no longer in there, I would think it would no longer show when typing ldconfig.

However, if it’s not causing any issues I could probly live with it unless you know of a way to get rid of it with nvidia-settings gui?

What does typing ldconfig do? I’m not familiar with that?

from what I’ve read, seems to be something with startup.

I started searching for it after I saw the error show up in an update.

The error in the last couple days show this

ldconfig: File /usr/lib/libnvidia-gtk3.so.390.116 is empty, not checked.

and so from a consol I just typed ldconfig and it shows up,
Also from what I’ve read, I’m led to believe it’s a broken package from the 390 drivers, I would have thought it was gone when changeing drivers but is still there.

I think if you can find the link and rename it maybe. Did you look in /usr/lib too see if libnvidia-gtk3.so.390.116 is there?

Edit: I’m just not sure how to rectify this. It’s from the 390 drivers don’t know why you were getting it other than the file don’t exist?

something very bad just happened, my entire usr/lib directory dissappeared when I deleted that file, the file was empty.
afraid to reboot
idk what happened

HELP HELP