[SOLVED]Installer can not create a new partition during installation

I am trying to install EndeavourOS wiping my existing windows installation. My hard disk is an MBR partitioned drive and I want to install it in BIOS-GPT mode. Hope that makes sense.

So here is the issue:

  1. firstly, my NVIDIA graphics card is not supported with the drivers packaged with the iso. Mine is NVIDIA GT 610 that would require 390xx series drivers as stated during boot. So I am booting with the first default option, from live Pend Drive.

  2. During my first few attempts, I ran into something similar to this Nothing happens when I click on "online" or "offline" in the "Start the installer" menu (solved), and the solution mentioned here actually worked, with the german ISO I got the online installer working

  3. So I continued with the installation, manually partitioned my drive. I had two drives in windows. C: and D:, And I didn’t want to loose the data on D: drive. so I chose this option. I partitioned the drives like so:
    - 8 MB Unformatted partition with BIOS_GRUB flag
    - 32 GB linuxswap partition with SWAP flag
    - Rest around 268 GB ext4 partition with mount point / and ROOT flag

  4. So after all is done, and I started the installation, the installation failed while trying to create the root partition. I tried this many times, by manually creating the partitions in gparted, before starting the installation. Choosing replace existing partition during installation, and anything else I could think of. But every time the installation fails at exactly the same point. I have tried the installation in both online and offline mode, both the time got the same result.

Here is the log files for both mode of installation:

  1. Online mode - https://termbin.com/vh0s
  2. offline mode - https://termbin.com/lf1y

installer log from live session:

cat /var/log/endeavour-install.log | eos-sendlog


cat: /var/log/endeavour-install.log: No such file or directory

Hardware information:


Boot log:


Any help would be greatly appreciated. I am pretty new to Arch, and Calamares, so unable to understand the issue.

1 Like

If you mean you want to install in BIOS mode on a disk with GUID Partition Table, I cannot tell for sure if the installer can allow for that since it would need a rather “special” partition scheme:

:eye: https://wiki.archlinux.org/title/GRUB#GUID_Partition_Table_(GPT)_specific_instructions

Perhaps one of the devs looking in here could give you instuctions on how you can do it with the current installer, if that is possible at all.

I am not sure about the mode. All I am trying to achieve is install endeavour on the partition where windows was previously. And keeping the second home partition safe, so as to not loose all my data. Is this possible?

From your live usb, post the output of the following commands:

sudo parted -l 

test -d /sys/firmware/efi && echo efi || echo bios

Please post the terminal output as text: copy, paste, highlight and press Ctrl-E to format

try maual partition (better do your own partition first, don’t let os do it)
Assume partitions are done.

  1. mark partition 1 of target drive
    check format
    choose vfat
    choose /boot/efi (mount point)
    choose bios-grub
  2. mark partition 2 of target drive
    check format
    choose ext4
    choose / (mount point)
    choose nothing
  3. check bios to be sure in UEFI boot mode (not CSM mode)

In past, i did meet situations similar to yours in some OSs.

If not works, use gparted to recreate gpt.
If not works, go to win 10 to recreate gpt. (This means win 10 leaves some kind of mark at MBR, i did meet this situation)

Hi, Here is the output that I got:

[liveuser@eos-2023.03.26 ~]$ sudo parted -l 
Model: ATA ST1000DM010-2EP1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type      File system     Flags
 2      9437kB  34.4GB  34.4GB  primary   linux-swap(v1)  swap
 1      34.4GB  322GB   288GB   primary   ext4
 3      322GB   1000GB  678GB   extended                  lba
 5      322GB   1000GB  678GB   logical   ntfs

Model: Sony Storage Media (scsi)
Disk /dev/sdb: 8011MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      1940MB  2060MB  120MB  primary  fat16        esp

[liveuser@eos-2023.03.26 ~]$ test -d /sys/firmware/efi && echo efi || echo bios

Have I done anything weird that I shouldn’t have? Thank you

You have got a disk with msdos partition table and have booted the live usb in bios mode.
Fine so far :+1:t5:

I would launch Gparted in the live session and delete both the current swap and EXT4 partitions:

You don’t need that 8MB Bios_grub partition either. So delete that one too.

Next, I would create only one EXT4 partition on that chunk of unallocated space.

Now, launch the installer and and choose the option replace partition and point it to the EXT4 partition you just created.

If you are given the option to choose a swap, you could do this from a dropdown menu. If not a swap device can be created post-install if needed. Don’t worry about it at this stage.

At the bottom of the installer screen there is an option for the location of the bootloader. Choose the default: disk /dev/sda (not a partition /dev/sdax)

Screenshot from 2023-04-21 11-55-24

On the screen for bootloader options, choose Grub and proceed.

I think this should do it.

If the installation fails, before you shutdown or reboot, launch the log tool on the live usb and check as many boxes as possible and let it produce a URL (you need internet connection for this). Post the URL on the forum.

1 Like

I would be cautious with suggestion like this without having any info of the disk layout in question. What partitions there are and what the contain.

In this case OP has an NTFS partition with data on. Creating a new partition table would have wiped out everything to the detriment and sorrow of OP.

1 Like

Sure, you are right, thanks for your caution to him, otherwise a big loss may occur.
I am unaware that he has a ntfs partition in that drive, only legacy bios boot can be used, sorry for that.

1 Like

This should be covered very well by the nouveau driver, especially since it’s EOL by Nvidia standards anyways.


I just did a test install on vm. I created a GPT partition. Then i created an unformatted 8 mb partition and flagged it bios-grub. Then i created the root partition and a home partition and swap with proper flags.
Installed Xfce and this is what you get.

I’m sure you can install it the way you have described also in the case where the OP is using his existing GPT partition already. They would just use manual partitioning and not touch the /home. I’m just not sure whether Calamares touches the /home on the install but i don’t think so? :thinking:

Edit: But I’m not sure!

Not sure what the difference in doing this 8 M partition unformatted does? It seems to install grub to it. :man_shrugging:

I guess the answer is this.

The BIOS boot partition is only needed by GRUB on a BIOS/GPT setup. On a BIOS/MBR setup, GRUB uses the post-MBR gap for the embedding the `core.img`. On GPT, however, there is no guaranteed unused space before the first partition.

Edit2: I would suggest the OP backup his data just to be sure.

This is exactly the case description of when you have a disk with Guid Partition Table and want to install in Legacy/Bios mode. In this case you would need that 8MB unformatted bios_grub partition for grub to write its core.img into as can bee seen from your picture.
Also, one should keep in mind that not all the Bios’ firmware support this setup.

In the case at hand, OP doesn’t have a disk with GPT.
The disk has a msdos partition table. Therefore no need for bios_grub partition. Grub will write its image to the MBR of the /dev/sda:

Okay… i didn’t see that it was DOS or MBR already. I thought the OP wanted to use GPT.

Yes. I thought so as well. At first. But then with the output of parted --list, things looked differently.

More, OP has booted the Live USB in Bios mode as well. So everything points in the direction of a Bios/Legacy install.

So i also installed it in vm with gpt and didn’t create the 8 mb unformatted partition. I guess it just installs grub at the beginning of the root partition? :thinking:

In this case, grub generically is installed in /dev/sda - and not in /dev/sda1.
So it is not installed in the partition, but the GPT (GUID Partition Table) of the drive itself.

In other cases, the partition table resides in the so-called MBR (Master Boot Record) of the drive, generically.

However, one CAN install grub on to a partition, too! :wink:

Okay. Yes i get that! :+1:

Edit: Why do they recommend using the 8 m unformatted partition then? Just to keep the grub core image separated?

  1. Who are THEY?
  2. The question seems ideological, if not philosophical to me.

…depending on whether you are multi-booting from a multi-boot system within another multi-boot system. :rofl:

Perhaps that is what happens. If it works that way then fine.
But the “recommended” way of installing in Bios mode with GPT disk is to have that bios_grub partition:

Some newer systems use the GUID Partition Table (GPT) format. This was specified as part of the Extensible Firmware Interface (EFI), but it can also be used on BIOS platforms if system software supports it; for example, GRUB and GNU/Linux can be used in this configuration. With this format, it is possible to reserve a whole partition for GRUB, called the BIOS Boot Partition. GRUB can then be embedded into that partition without the risk of being overwritten by other software and without being contained in a filesystem which might move its blocks around.

When creating a BIOS Boot Partition on a GPT system, you should make sure that it is at least 31 KiB in size. (GPT-formatted disks are not usually particularly small, so we recommend that you make it larger than the bare minimum, such as 1 MiB, to allow plenty of room for growth.) You must also make sure that it has the proper partition type. Using GNU Parted, you can set this using a command such as the following:

parted /dev/disk set partition-number bios_grub on


If there is any caveats installing it to the root partition, I don’t know.
I guess the answer to the above is:

GRUB can then be embedded into that partition without the risk of being overwritten by other software and without being contained in a filesystem which might move its blocks around

1 Like

Hear! Hear!! Hear!!! :point_up:

That is NEWS to me ole eyes… :eyes:

You know, I’m still running on old-timers!