So recently i tried to use pipewire-pulse to replace pulse but then

i had no sound and pavucontrol reported pulseauduio not active.

so how do i switch to pipewire if pipewire can’t make any sound on my system?

Pipewire is still buggy. I have to un-pair & re-pair my Bluetooth headset for “Headset Profile” to appear in the system settings.

What’s your output from:

systemctl status --user pipewire.service pipewire-pulse.service
1 Like

This is what i have installed and it’s working.

Edit:

[ricklinux@eos-plasma ~]$ systemctl status --user pipewire.service pipewire-pulse.service
● pipewire.service - Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-04-10 15:39:16 EDT; 15min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1940 (pipewire)
      Tasks: 2 (limit: 38415)
     Memory: 5.8M
        CPU: 86ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1940 /usr/bin/pipewire

Apr 10 15:39:16 eos-plasma systemd[1390]: Started Multimedia Service.

● pipewire-pulse.service - PipeWire PulseAudio
     Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; disabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-04-10 15:39:16 EDT; 15min ago
TriggeredBy: ● pipewire-pulse.socket
   Main PID: 1942 (pipewire-pulse)
      Tasks: 2 (limit: 38415)
     Memory: 8.4M
        CPU: 181ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire-pulse.service
             └─1942 /usr/bin/pipewire-pulse

Apr 10 15:39:16 eos-plasma systemd[1390]: Started PipeWire PulseAudio.
Apr 10 15:46:23 eos-plasma pipewire-pulse[1942]: pulse-server 0x55aa00b62060: [libcanberra] ERROR command:18 (PLAY_SAMPLE) tag:6 error:25 (Input/output error)
[ricklinux@eos-plasma ~]$ 

Edit2: I don’t have Mic or Headphones plugged in.

2 Likes

So do I just run pulseaudio —start

pulse commands no longer work youre on pipewire

make sure you have these installed and pulse audio is removed

pipewire
pipewire-alsa
pipewire-jack
pipewire-media-session
pipewire-pulse

Im not sure how pavucontrol works with pipewire, it may not but idk what DE you use or if you have another option

1 Like

Normal wired audio output is just fine, bluetooth is definitely still a WiP though

1 Like

I have what you have except also have jack

I run with a Scarlett 2i2 with Mic in and Line out to my JDS labs Atom which goes to my headphones and Monitors. Havent had a single hickup with pipewire setup for 20ms latency for months.

I also have it on my laptop and the mic/headphone jacks, built in mic, and built in speakers all work well though i dont tune the latency on that one as its audio chip is crap lol

1 Like

So how do I start pipe wire?

it should start automatically after you install it and reboot

1 Like

When it doesn’t. What command do I run? Because pulse runs independently of any init system with pulseaaudio —start

to my knowledge you dont launch pipewire that way

if youre having issues try looking at the documentation here

and run journalctl --user --unit=pipewire.service --unit=pipewire-pulse.service --unit=pipewire-media-session.service to check if its working. Its supposed to automatically unless youre running some odd configuration

Also make sure you have no pacnew files that could be causing issues

2 Likes

That might be of interest too

1 Like

Or or I can just use pulseaudio —start and run pulse audio independent of any init , de, or wm

1 Like

you could, but tbh it seems like youve got something broken somewhat in your system if pipewire doesnt just work. You dont have to use it but its a very powerful server with a lot of benefits, choice is yours.

1 Like

yah ok but i have to rtfm to make it work it seems more burden for me on my time and esp on my intellect and even more so on my delicate temperament ahahahahahahah. cost benefit analysis and suchness and whatnots… perhaps i wait until it matures to the point where there is a pipewire --start?

Must be a problem with me or my system. Couldn’t be the software. Nope not that

What I’m saying is you’re not supposed to have to do this, its supposed to be drop in.

I’m not gonna have an argument here as you’ve clearly already decided its not worth your time but was simply saying that if the cases is that everyone I’ve personally come across has been able to swap to pipewire with just a Sudo Pacman along with it being designed specifically for drop in no configuration replacement don’t you think perhaps “maybe” something is odd on your end? You can’t know if you bury your head in the sand.

Enjoy pulseaudio if you want, I was willing to help figure out your issue but not with that attitude

3 Likes

right. well in that case thank you so very much for informing me of the problem with my equipment and my attitude. have a wonderful day.

Did you install pipewire-alsa, pipewire-pulse? I’m assuming pipewire is already installed? Pipe wire-pulse will replace pulseaudio and pulseaudio-bluetooth i think.

1 Like

yes of course. i installed it all and rebooted. everything i could find listed in pamac-manager i installed via the command line.

doesnt even show my hardware in my sound settings with pipewire

shows fine with pulseaudio is running.

Do you have it running right now with pulseaudio then? All i know is i only installed the additional pipewire-alsa and pipewire-pulse which removes the pulseaudio. Pipewire has already made it into the installed packages and some of the others are additional packages which may or may not be needed such as jack for instance. I would only install the two if i was checking it and reboot and see. If you want otherwise nothing wrong with using pulseaudio if its all working. :wink:

1 Like