Set systemd-boot Default to LTS?

I am on systemd-boot, it was defaulting to LTS.
I am on BTRFS, dracut, snapper,…

I just discovered my boot menu has LTS but it is not the default. I wonder why it changed!
This is what I have in /efi/loader/entries/

[limo@asus entries]$ ls
[limo@asus entries]$ 

During boot I have arch, arch fallback, LTS, LTS fqllback in this order.
Tried to update system, and even did

sudo reinstall-kernels

But still not having LTS as default.
Honestly I tried to read and search, but I could not figure it out.

I know there is a file I can edit to change the boot order to make LTS the default.
What can I do to have LTS as default and avoid this to happen again?

I am on EndeavourOS only, no other systems on my laptop.

I will appreciate any help.

I just noticed that the LTS version appears to be 6.1.14-1 (more recent than the arch 6.1.12) How could this be?

From the EndeavourOS Wiki:

How to change the default entry to boot

There is a default entry inside /efi/loader/loader.conf that determine the default boot entry.

On a new install, it will look something like this:

default 665eca4ae83246df8ec17d1cbc6a1763*

That first string of characters is you entry token which identifies the install. That is important if you are dual-booting with another Linux, otherwise it can be replaced with *. That line supports wildcards and so if you want to boot the LTS kernel by default you could use something like this:

default 665eca4ae83246df8ec17d1cbc6a1763*lts.conf

Alternatively, if you want to boot the mainline kernel by default, something like this should work:

default 665eca4ae83246df8ec17d1cbc6a1763-*-arch?-?.conf

These changes will take effect on the next reboot and nothing else is required except modifying the file.

1 Like
1 Like

Thanks @r0ckhopper
I remember while trying to find out I came across this file


which only has

timeout 3
# console-mode keep

Looks strange to me!

Are you saying the contents of /efi/loader/loader.conf are “/efi/loader/loader.conf”? :thinking:

My bad.
I don’t know why copy paste didnt work as expected!
I corrected
It has

timeout 3
# console-mode keep

Is that all it has? It looks like you have edited it at least once before - console-mode has been commented out.

I don’t know how to regenerate your entry token which identifies the install, which should be at line 1. Others may be able to assist here.

1 Like

I remember when Cassini/dracut came out I wanted to modify my system to be as the latest release. Convert to systemd-boot with dracut?

I remember I only changed /added timeout to “see” the boot menu of systemd-boot (as shown in the thread.
I do not not even know what is # console-mode keep, should I un-comment it? what does it do?

Thanks @r0ckhopper
Your feedback gave me a clue.
I added default *lts to the end of the file, rebooted and LTS was the default! :partying_face:
Still, it is not the first on the boot menu, it came third after arch and arch fallback!
I wonder how can I change it to be the first on top.
I know I am asking a lot!

Maybe boot loader was looking for “older” version (which is supposed to be the LTS) and it found the older version is arch, while the latest version is the LTS so it booted the older one thinking it is LTS?
Can this be the reason?

Good to hear :sweat_smile:

You may have to be patient. Before the LTS kernel switched to 6.1, it was on top of the menu for me. Once it “overtook” the main kernel, it dropped down the menu. I am assuming that the menu orders the kernels with the lowest number at the top, and once the main kernel in the Arch repos is 6.2, that the LTS kernel will be restored to the top of the menu.

We shall see…


1 Like

I might be missing something here but I highlight the one that I want to boot from as default and hit ‘Shift + D’


This -to me- sounds logical, same logic why it didn’t default to LTS though it was before.
First time to even think LTS could be the latest!

I will try this and report back!
This is the beauty of this wonderful EndeavourOS forum.
I am always learning new things.
AMAZING as usual.
It set the default and gives me a big arrow head pointing the default.
I will try to remember SHIFT-D

1 Like

I think you found something :+1:

1 Like

Just reporting back in hope it will help anybody reading this.

You are right @r0ckhopper
I got an update and it is back to normal and LTS is on top.
Thank you.

1 Like

I always am :stuck_out_tongue_winking_eye:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.