Second Display won't show content after update

Hi, everybody! I have recently been having some trouble with my second display after I updated my system. I can get the display to work in sddm but it won’t work in KDE. When i log-in the display just wont show my desktop or anything and comes up with no signal. I have tried re-plugged my display on my graphics card, downgrading nvidia packages and kernel to the latest stable version I didn’t have issues with, and installing the lts kernel, but it still won’t work.

System Logs:
Hardware Information:

Boot Log:

This points to a user space issue. Video and Xorg are fine.
I guess it maybe plasma/kde updates did it. I also had a bad experience today, switching to a Plasma session. It may be temporary and get fixed with updates, or you may try the usual test. Create and test a new user account.

I’m having the exact same issue: second display not working after updating, downgraded the kernel, still broken. And yes, I have done the new user account test, and no effect.

The theory that it could be Plasma causing this is plausible, though I’m not sure which particular KDE packages would be causing this issue, since unfortunately I’m not very advanced with troubleshooting this stuff.

Yeah, it’s probably a kde problem then. If I started my computer with my second display only it would work, but right after i turned on my main display, the second display just showed no signal.

Same problem here. New user, different kernel nothing helped until now.

OK so I just went down a bit of a rabbit hole.

TL;DR: I replaced the 510xx NVIDIA drivers I was using from the AUR with the main drivers in the repo, and the system was able to detect the second display, but still no picture came through.

So at first I had called myself a bonehead, because I didn’t realize that apparently both displays worked on SDDM for you. For me, SDDM still showed nothing on the second display.

So I looked at my inxi -Fazy, and it turns out that the system wasn’t detecting the NVIDIA drivers at all, while yours did. It turns out this may have been because I was using the 510xx drivers from the AUR, since I’ve had a bad experience with the main drivers in the repo bricking my second display in the past. So I took a chance and installed the main drivers, and that’s when things got interesting.

SDDM still didn’t show on the second screen (which I just realized is just normal behavior for NVIDIA Prime, since I have an iGPU) but when I logged in, I had noticed that it actually noticed the drivers and created the new display. However, the monitor still sees nothing. I assume this is more accurate to what you’re experiencing yourself? With the system still recognizing the second monitor but it not being displayed?

On an unrelated note, I’m have some REALLY BAD scaling problems on the 100% scale. All the icons in the applets, notifications, application menu, and settings are all gone. And when I right click, the menu appears to be HUGE; even the first option bigger than the display’s resolution! Yet there’s still no icons nor wording. 125% scale appears to look as intended, so I have no idea what’s causing this.

In any case, I can’t be sure if we’re actually experiencing the same technical issue, despite the same general theme of update → second display is borked → downgrade kernel → still doesn’t work.

1 Like

You are experiencing basically what i am experiencing. If I turn on my second display, it seems like it wants to display something, but then it just shows “No signal.”

Huh… uhh, well this is awkward. I woke up and my second display is working fine now – well, with one exception I’ll get into later – no immediate updates needed.

But after thinking about it more maybe the HDMI cable just wasn’t plugged in right when I first powered it up. Could be explained by the fact I was up all night monitoring this thread and occasionally troubleshooting.

Anywho, the scaling problem in Plasma still persists, and I’m having the exact same issue as I did when I had originally used the main drivers from the repo: when set to 1080p75, my second display just shows “Input Not Recognized”. I’ll try downgrading to the 510 drivers again (and perhaps the kernel as well) and see if any of those two are fixed, but yeah, turns out I was right about me being a bonehead.

As for you, maybe reinstalling the NVIDIA drivers could fix it? Or installing another version of the NVIDIA drivers (though I don’t know if the 3000 cards are supported in the 510xx drivers), since that’s essentially what I did to get it to work.

Yeah, and now I’ve installed the 510xx drivers again, I’ve come back full circle: the drivers not being recognized, even on a previous kernel version. But now the scale is fixed, interestingly.

Alright well it turns out the scaling issues were because my current theme seemingly corrupted. I just chose a Global Theme preset from the settings and the scaling issues have been fixed. Soooo for me everything is pretty much fixed now (apart from the 1080p75 issue, which I’ve already established was because of the drivers themselves, and unrelated to the main problem of this thread), so I’ll see myself out unless there’s something else I could possibly help with.

Edit: Welp, nevermind on that, the scaling problems came right back after a restart, and they’re not being fixed by the presets. I’ll just start a new thread or troubleshoot this myself since this is getting off topic.

Hi! I fixed this problem by deleting the ~/.local/share/kscreen/ folder, and restarted my pc. Now my second display works!

Nevermind, after the computer got into lock mode, and i typed in my password, the second display won’t work anymore.

Coming back to this thread because I think I did actually face the issue you were dealing with while I was testing out another monitor (turns out none of the previous issues I had were remotely technically related to yours). When I plugged my main display back in, nothing came through. I tried enabling the monitor in the settings, but no dice. Not even a reset could help. But once I deleted the kscreen folder and reset, everything was back to how it was before. I guess you can just delete that folder everytime you face this issue (even though this apparently happens when your computer goes into lock mode, it doesn’t occur for me even after a reset), and you’ll be good until an update hopefully eventually rolls around fixing this.

Thanks, I’ll use this as the solution temporarily until a update comes out to fix it.

So, I installed the lts kernel, and deleted the kscreen folder, restarted, and now it apparently works??? It dosen’t stop working after the lock screen pops up.

And there it happened again. This is very random so i won’t post anymore on this post until the problem is fixed.

Are you using an AMD Ryzen CPU? Found two other forum posts with similar issue. Seems plasma needs to iron out a new bug but wondering if it affects only amd users.

Yes, I am using an AMD Ryzen CPU. Specifically AMD Ryzen 5800X.

1 Like

Hopefully gets fixed soon. Maybe worth submitting a bug report to KDE, the more people do it the faster it will hopefully get fixed. Why it affects AMD is strange, if it is related. I would try main and lts kernels. If problem persist might really be related to recent plasma update.

The problem persists on both main and lts kernels, I will see if i can send a bug report to KDE.

1 Like