Realtime, Wineasio, Programs Specific settings

Hello All, I had a few questions, I have searched all that I can for days trying to find an answer and can’t seem to find one.

In order for me to be able to use Wineasio I have to install and use “realtime” otherwise the programs I am trying to run simply do not work, or wineasio doesn’t work or get recognized by the programs.

So I can activate/install realtime and the programs work.

The problem is, when I am using realtime it causing glitching issues with watching videos and sound on browsers streaming video or audio. But, on the programs running in Wine it works fine. I remove realtime the Wine programs don’t recognize Wineasio, but my streaming browsers audio and video is fine, I turn it on and the Wine programs work fine, but I am back to the streaming audio and video on the browsers not working.

My question is, is there a way to disable realtime for specific programs?

I know there are permission and groups and stuff like that, but I’m just wanting to turn off real time “TEMPORARILY” for specific programs like browsers. I really have no idea how to do this.
I’ve tried a lot of linux versions lately, from arch to ubuntu and debian, I always run into this problem with using realtime audio being required for wineasio.

I record music so this is why I am running realtime. I could set the buffer for jack up to 2048 but that would defeat the entire purpose of running wineasio and realtime. That stops the stuttering, but when recording an instrument the latency/delay is ridiculously slow.

Just wondering if there is a way to do this?

Thanks in advance for any help it would be appreciated.

See this, it’s likely you forgot something.

Also generally it’s not a good idea to use wineasio, you’re using something like Ableton Live or FL Studio as DAW i assume?

P.S. Oh, i have actually answered you before in another topic :sweat_smile:

Still, you’re missing something, try to follow all the steps again, it’s not asio or other program specific if you set it system-wide, browser is the most unlikely source of problem, compared to anything related to wineasio in terms of xruns, so clearly something is missing.

1 Like

I have resolved my issue.

Short summary, Running Arch or Ubuntu or Debian, the issue was in order to use “Wineasio” with “Wine” software I needed to have realtime privileges installed. Otherwise the software I was trying to run under Wine using WineAsio would not recognize WineAsio and simply would not work.

So, I fixed it “KEEPING REALTIME PRIVILEDGES INSTALLED” and it will vary by system, the way I did it on this arch based system was going into the permissions realtime file which in my case is located at /etc/security/limits.d/99-realtime-privileges.conf.

What I did was change the line which by default is

@realtime - rtprio 98


@realtime - rtprio 0

So that realtime isn’t always 100% active, I just need it when I run 1 program at a time, not the whole system. That seems to have cleared up the issues with my browsers and streaming audio.

Also, I use another file I created called “audio.conf” it is in /etc/security/ apparently at least for me it is required to have audio to begin with. I changed the

@realtime - rtprio 98


@realtime - rtprio 0


I am using a Tascam US122L so it is a bit tricky on how to explain things “Because I am explaining from trial and error not KNOW HOW”.

Anyway, consider this issue solved at least for me. I wanted to come back and HOPEFULLY I EXPLAINED everything right in the hopes that it may help someone in the future.

Settings are something to thin about regardless of what your issues are when installing new things I guess.

Thank you, I believe I’ve got it figured out, at least for my uses. I don’t need realtime all the time, I just need it for Wineasio to function with a few specific program running one at a time.

I replied what I did to fix my issues. Although if someone wants to run realtime for everything, I don’t have an answer for that one, I just run one program at a time.

Thank you for taking the time to help and answer. I hope my replies did not confuse anyone or cause them issues, I’m no expert, just learning and so far changing that file settings to 0 seems to be working great.

I am assuming that is a priority setting, I’m guessing, and changing the priority to 0 I’m thinking it will work just like every other program, or not override them and cause the glitches I was having. I’m guessing here. But either way, it worked, and so far everything is working great.

THanks again!

Well…Let’s just say rtprio doesn’t work the way you think :upside_down_face:
As for the “realtime”…It’s either works properly for everything or it does not.

For example, on my system i could launch hundreds of jack, alsa & pulseaudio streams simultaneously (all routed through jack) and it won’t crackle…

By default every user has a hard (and thus also soft) limit of 0. The value of the rtprio limit is the maximum realtime priority a process can get: the higher the value, the more priority the process is given.

By default jack requests minimum value of 10.

In my opinion, you shouldn’t install realtime package blindly, it’s far better to do Realtime config quick scan manually and follow it’s recommendation and then route everything through jack.

I still suggest you to carefully follow the recommendations above.

Also, to troubleshoot and solve such kind of problem in the first place, you’re doing it completely in reverse, it would be better to think of it this way:

  • What should i do / what have i done wrong that anything audio related on my system doesn’t work as intended

  • And only then you should think about Frankenstein monster of wineasio inside wine, after you solve problems with your core system.

My bet that wineasio itself is the problem, if you can you should be using Linux native DAW and use Wine only for vst plugins bridging - it’s much more stable setup.

But, as they say, whatever floats your boat :sailboat:

Let’s just say : It resolved my ISSUE 100%. Considering my situation and what I was trying to accomplish.

Yes, it is a “PRIORITY” setting where realtime goes. You can brainwave all you want, but like I said I has already resolved my issue.

First the setting in /etc/security/limits.d/99-realtime-privileges.conf.

Which is @realtime - rtprio 98 it sets your entire system to run at that PRIORITY.

Either way, thank you for trying to help, but I don’t need it, what I said resolves the issue “FOR ME”.
Not to mention, for others who may view the messages wondering why when they install REALTIME and get stutters. Realtime should not be installed with a default PRIORITY value or 98 or 99, it needs to be set to 0 IN MY OPINION.

Oh well, thanks for your thoughts, those are mine, have a great day! :slight_smile:

Exactly, i figured you’re not alone here, since it’s on public forum and a little misleading as an overall advice? :laughing:

Pro audio on Linux for newcomers can be a little overwhelming, although it’s easy when you know how to deal with it.

The answer was here all along:


Because when you do it manually you work with @audio group instead of @realtime, which does exactly what you want and prioritize only audio related workloads.with high (but not maximum) priority, without introducing any additional issues by setting it to 0 (which you will likely notice sometime later too).

That’s why realtime package should be avoided, for pro-audio purposes.