Audio pitch being altered when launching certain applications


I’ve been having an odd audio issue for a while now. When I launch certain software whilst audio is running (Genymotion, Wine/Lutris software) the pitch of the audio is altered to either high or low and remains in this manner until I restart the computer. On some occasions it is sufficient to switch audio output back and forth to solve it, but this does not always work. I’ve tried a fresh installation, but this issue persists.

I don’t know if it’s relevant but I’m running my audio through an m-track 2x2 via usb c. It does not use a driver and works fine besides this issue.

Does anyone have any idea what’s causing this, or how to solve it?

Welcome! :slight_smile:

It’s caused by combination of some audio cards and difference in programs sample rate, if you experience such a problem - i strongly suggest you should route all your audio through jack

Common terms

buffer under-or-overrun, X stands for under or over. It’s a sign that your system did not process some buffers in time, so some data is missed. It is particularly true when you run at very low buffer size where the sound card should process incoming buffers very fast (overrun). Some chips cannot cope with small buffer sizes, so you have to increase the buffer length to ease the work done by the sound chip.

Realtime config quick scan

Run as:

perl ./

Use this script and all of it’s recommendations (except maybe CPU Governors & RT Kernel)

Route all audio through JACK

Here’s basic setup…

Install those packages:


Launch Cadence and do it’s most basic settings (to route all audio through JACK):

JACK Settings
[x] Auto-start JACK or LADISH at login

ALSA Audio
Alsa -> PulseAudio -> JACK (plugin)

[ ] Auto-start at login

[x] Realtime

[x] ALSA
    [x] Duplex Mode !
    Device/Interface - your audio card
    Sample rate - 44100 kHz
    Buffer size - 512
    Period/Buffer - 2

System settings - Audio
[x] JACK sink (PulseAudio JACK Sink)

Smaller buffer size - obviously smaller will be latency, but if you just listen and don’t create music - it should be safe starting value (although outcome heavily depends on Audio hardware, usually you should aim for as small value as possible, which doesn’t introduce crackles / xruns)

Inside Cadence there is Tools - Catia - here you can route anything to any connection like an octopus :slight_smile:


Oh, also you can use pipewire which is way easier to initially setup, but personally i have no idea if it will help with that kind of problem, with jack i’m pretty sure it will.

If you want to try and replace pulseaudio crap with pipewire, should do something like that:

sudo pacman -S pipewire pipewire-alsa pipewire-pulse pipewire-jack --needed

Maybe it will help, maybe it won’t :upside_down_face:

1 Like

Hey, thanks a lot for the help. I followed your instructions for jack and it seems to have resolved the issue :slightly_smiling_face:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.