"Reached target Graphical Interface" then nothing happens

If this is of any help i can: Boot into GRUB and select endeavourOS or the endeavourOS fallback and i can use the TTY as well. it starts daemons and stuff but then it gets to "Reached target graphical " before stopping doing things and nothing else happening

EDIT: i think i know the issue not how to fix it though before i turned off my PC i ran the yay command and pacman command to well update stuff and im guessing whats happened is two nvidia drivers are installed on my computer and i need to remove one

Welcome to the forum!

Please provide system info, are you running Nvidia? Is this a new install? How did you create the USB drive?

Ive got the logs with inxi and journalCTL What should i remove from them ive found some ips in them that i took out and what not (i think some mac addresses too) but surely its not good to just dump out all that info?

The logs should not log any personal infos like Mac addresses and serial numbers.

Most of the boot problems arise from 1) how users prepare USB stick, 2) formatting of hardrives and bootloader partition, 3) Nvidia graphics. The wiki was written by the eos developer and community, so I am not asking you to follow any obscure weird commands… :laughing:

You can also open the eos welcome app and click eos log or similar, it will dump out a url you can post here with system infos.

Start with inxi…for hardware.

Kernel: 5.15.2-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.1.0
Console: tty 2 DM: LightDM Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: Gigabyte model: B550 AORUS ELITE v: x.x
serial: BIOS: American Megatrends v: F10 date: 09/18/2020
Info: 6-Core model: AMD Ryzen 5 5600X bits: 64 type: MT MCP arch: Zen 3
rev: 0 cache: L2: 3 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 88668
Speed: 2135 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz):
1: 2135 2: 2061 3: 2136 4: 2050 5: 2136 6: 2112 7: 2045 8: 2203 9: 2326
10: 2193 11: 2114 12: 2051
Device-1: NVIDIA vendor: ZOTAC driver: N/A bus-ID: replaced
chip-ID: 10de:2489
Display: server: X.org driver: loaded: nvidia
unloaded: fbdev,modesetting,vesa alternate: nouveau,nv tty: 80x30
Message: Unable to show advanced data. Required tool glxinfo missing.
Device-1: NVIDIA GA104 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel bus-ID: replaced chip-ID: replaced
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID:replaced chip-ID: replaced
Device-3: Kingston HyperX Cloud Stinger Wireless type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: replaced chip-ID: replaced
Sound Server-1: ALSA v: k5.15.2-arch1-1 running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: no
Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel
port: f000 bus-ID:replaced chip-ID: replaced
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 2.73 TiB used: 73.06 GiB (2.6%)
ID-1: /dev/sda vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB
speed: 6.0 Gb/s serial:
ID-2: /dev/sdb vendor: Crucial model: CT1000BX500SSD1 size: 931.51 GiB
speed: 6.0 Gb/s serial:
ID-1: / size: 915.81 GiB used: 73.06 GiB (8.0%) fs: ext4 dev: /dev/sdb1
Alert: No swap data was found.
System Temperatures: cpu: 32.0 C mobo: 29.0 C
Fan Speeds (RPM): N/A
Processes: 220 Uptime: 1m Memory: 15.61 GiB used: 521.2 MiB (3.3%)
Init: systemd v: 249 Compilers: gcc: 11.1.0 clang: 13.0.0 Packages:
pacman: 940 Shell: Bash v: 5.1.8 running-in: tty 2 inxi: 3.3.07

What card is the Nvidia exactly? You could boot to a tty log in as root and run nvidia-installer-dkms -n and this will uninstall the nvidia drivers and after it completes reboot and see if it loads on the nouveau open source drivers. If nvidia-installer-dkms is not installed you would have to install it first.

sudo pacman -S nvidia-installer-dkms
1 Like

the exact card is a 3060TI

Okay …
Not sure what desktop you installed but i see lightdm so i assume it’s xfce. I would try what i have above first of all to see if it will boot to the desktop on nouveua open source drivers. Then we could reinstall nvidia and go from there. The you could run the installer in test mode and see if there are any errors first before installing Nvidia drivers.

1 Like

i do have XFCE that is correct and i checked if i have it installed or not i do it was up to date i tried

sudo nvidia-installed-dkms -n

it said to restart so i did grub worked fine and the debug menu for arch spit text good for a few seconds
then that thing happened you know where its like blue? like monitors use it to say the powers on but no signal is being recieved from a HDMI that happened BUT i did manage to turn my PC off by ctrl alt F2’ing then typing in my username and password and then poweroff so i know the terminal and stuff still works but its the graphics that dont exist so i cant see what im doing any ideas?

Do you have more than one monitor hooked up?

1 Like

If you can boot to a TTY and log in as root. Try running the nvidia installer in test mode.

nvidia-installer-dkms -t

This will test the install of nvidia drivers and it makes no changes to the system. See if it has no errors.

1 Like

no just the one

I also see this board has 3 newer UEFI Bios updates. You should update to the latest version.

Edit: From your hardware it shows F10 is your current version.

1 Like

This board also has SATA Raid support. Make sure that the mode for SATA is set to AHCI mode not RAID.

1 Like

I tried that but i couldn’t see the results as no graphics exist

It should be AHCI not RAID as ive been using it for a few weeks i should also add that for a few seconds before i lose all graphics when i boot up i saw some error that was like /sda/dev/ clean: and some numbers i forgot to include it in the original post because im an idiot

if no solution is apparent i can probably view the files system on windows 10 and copy them over before reinstalling the entire distro

You tried what?

1 Like

nvidia-installer-dkms -t but i couldn’t see the result of it

Oh i see. Were you booted into a TTY? Logged in as root? It should show on the screen?

Edit: You’re not trying to do this from the live ISO i hope?

Edit: Maybe i’m misunderstanding. You don’t have EndeavourOS installed at all? If that’s the case my bad. :man_facepalming:

1 Like

I am not trying to do this from a live ISO
I do have endeavour OS fully installed
i updated some core packages and had an issue where when i booted i would only get to “reached target graphical interface” and nothing else would happen