Question marks instead of cyrillic letters under Proton

Hi guys!

Got this problem probably 2 years ago, but only now I decided to ask for help on forum. When I try to type something in russian on game that is running under Proton (version doesn’t matter), instead of giving me word “привет” for example, it gives me “???”.

Does anyone know how to fix this problem?

P.S maybe this problem caused by my .zshrc?

Not sure what may be causing this but a short search brought up this (was linked from a similar issue to here) answer may be here, it might not

I tried solution from this github issue, but it didn’t work :frowning:

That’s unfortunate, hope someone can help you with this

1 Like

Which game?

Another question I never thought to ask, where is my mind at this evening?

1 Like

Every signle one.

Among Us, Teardown, Garry’s Mod and so on

1 Like

Well…If i’d have to guess - It’s clearly encoding related ??? indicates that characters are missing…so either you need Cyrillic font in your system (i assume you already have some Noto packs and stuff, so your system would also accept Cyrillic) or some additional winetricks to install default Windoze fonts (Arial, Times etc)

So I guess I need to install MS fonts on my system, right?

Not the system, but in WINEPREFIX if i’d have to guess…
btw, i wonder is it only happens when you input and not all Cyrillic ingame menus are also the same way?

Every menu and every word on any game that support russian language translation work perfectly fine.

But if I try to type smth it gives me ?

1 Like,_special_characters_and_cyrillic_letters_in_Source-based_games

Check this out, maybe it will help

update: no i think ignore it, since it’s not font issue.

Ok, then it’s not font but input issue.

Dude claims it’s KDE’s fault :thinking:

Nah, it’s definitely not. I had same issue on GNOME

1 Like

What happens when you paste something Cyrillic from clipboard?

I didn’t try it. I’ll check it now

1 Like

I think it’s the same issue:

Make sure you have en_US.UTF-8 UTF-8 locale enabled, as it is required by Steam to work correctly

Sorry for stupid question, but how do I enable it?

By reading 2nd link.

Its enabled already, I regenerated locales just to try booting game again and check input issue

1 Like