QOL updates to new system

I currently switched from Windows to Linux and after a few hiccups, I got my system up and running. So far it’s pretty great, but there are a few things I find I need guidance on.

I’m currently running Endeavour OS on an Alienware M17 R4 Laptop that has a few years on it. For the most part it works alright. However I have a few issues with certain things. The graphics use both an intel integrated option as well as an NVIDIA 1070 graphics card. I understand that NVIDIA doesn’t play well with Linux systems in general and I’m having issues.

The main issue I have is with my main monitor. I use and external monitor rather than the laptop monitor to work off of. It seems whenever I restart the system, I have to jump through hoops to get things back to where they were. Originally I tried Plasma Desktop, and enjoyed it, but I think Wayland is causing problems with my video care, so I switched to XFCE4.

Which leads to my questions. Is there a way to run Plasma Desktop with an NVIDIA card? Also I seem to lose my external monitor connectivity until I run optimus-manager --switch nvidia. That allows me to use my external monitor again, but I have to rerun it after every restart. So my second question is this: Is there a better driver to install and if not, how do I get optimus manager to switch to nvidia at startup?

Which leads to my third question. I have two internal hard drives on my system. The primary drive I have my system and personal files on. The secondary drive is a data drive for things like games. Whenever I restart I have to enter my password to use my secondary drive. Initially it was owned by root, but I was able to change the ownership through chmod. My assumption, incorrectly as it turned out, was that since my profile had full permission on the disk that I would not have to authenticate in order to use that drive. Yet every time I restart, I have to authenticate once more before I can use the drive. So my question is how do I ensure that I no longer have to authenticate my secondary internal drive?

Thanks for your help.

Not true. It’s just not as consistent as using Intel or AMD graphics.

Did you try to use x11(Xorg) when using KDE?

Wayland, though it is default on many distros, is actually experimental. At the very least, it’s seeing heavy amounts of development that can cause random issues on random devices/hardware.

You may want to have a look at: Plasma 6 Update some hints

I have no experience using an external monitor on Linux, so someone else will chime in on that.

I see. I’ve been thinking Plasma and Wayland were synonymous. To answer your question, no I was not using X11 when I had KDE installed. Is there a walkthrough on how to change desktop environments laying around somewhere?

That was very helpful, thank you.

No. They are separate things that work together. You have the option of using KDE Plasma with Wayland, x11, or other windows managers.

You change DEs/WMs at the login screen. If your account is set to autologin, then you’d have to log out, then switch it there.

Just look for the name or icon of the current DE/WM, click it, and you will see a list of your other installed DEs/WMs.

That being said, it is not recommended to have more than one DE. You can have as many WMs/WCs as you want, but DEs often times don’t play well with each.

DE — desktop environment (KDE Plasma, Xfce, Cinnamon, Gnome, etc.)
WM — window manager (Openbox, i3, Bspwm, Dwm, etc.)
WC — window compositor (Hyprland, River, Sway, etc.)

Extremely helpful thanks. How would I determine of I’m using Wayland or X11?

See the images here again.

If you are already logged in, you can check using the terminal as well:

inxi -G
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0

Thanks again. I need to get used to reading again. The age of YouTube has softened me.

1 Like

Yes, Arch-based distros aren’t for the non-reader. However, there is a Youtuber who actually does a great job of explaining lots of Arch-related things. As he loves to say, “It’s all Arch.”

He’s the founder of Arco Linux: https://www.youtube.com/erikdubois

Okay, figured out the monitor issue. It was a combination of the following:


Follow the install instructions for the drivers, optimus manager and the GUI. Then go into said GUI manager and select Optimus from the set of icons on the left and chose NVIDIA under startup mode. Hit OK, then restart the system.

The lid thing was a little trickier, but I found the following:

There’s a config file that needs to be changed and updated. Open using nano or some other text editor, make the changes in the post and viola, it works.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.