Probably encrypted Windows partition not allowing to boot from grub entry

Hi guys, I posted this problem on subreddit but nobody could help, so I’m here. After windows update I stopped being able to boot into it from grub, although I’m still able to do it from computer’s boot manager. When I try to boot into it from grub I get following error:

Error: file EFI/Microsoft/Boot/bootmgfw.efi not found
Press any key to continue

and here’s what happens after running “sudo update-grub”:

Generating grub configuration file ...
Found theme: /boot/grub/themes/EndeavourOS/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/amd-ucode.img /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot:  amd-ucode.img initramfs-linux-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
/usr/bin/grub-probe: error: unknown filesystem.
Found Windows Boot Manager on /dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
/usr/bin/grub-probe: error: unknown filesystem.
Adding boot menu entry for UEFI Firmware Settings ...
done

After posting this on reddit and giving the outputs of:

“fdisk -l”:

Disk model: KINGSTON OM8PCP3512F-AA                 
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: DED706D9-8D6B-4B5F-BE1A-B8E652B48003

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1        34     206847    206814   101M EFI System
/dev/nvme0n1p2    206848     239615     32768    16M Microsoft reserved
/dev/nvme0n1p3    239616  481411349 481171734 229,4G Microsoft basic data
/dev/nvme0n1p4 481413120  482494463   1081344   528M Windows recovery environment
/dev/nvme0n1p5 998117376 1000214527   2097152     1G Windows recovery environment
/dev/nvme0n1p6 482494464  584894463 102400000  48,8G Linux filesystem
/dev/nvme0n1p7 584894464  998117375 413222912   197G Linux filesystem

Partition table entries are not in disk order.

“sudo blkid”:

/dev/nvme0n1p7: UUID="45f6fb6d-015c-46fc-987e-80677c49f429" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="523a33d7-f684-9a4f-ab74-519b542c98b2"
/dev/nvme0n1p5: LABEL="Recovery" BLOCK_SIZE="512" UUID="2A164DB7164D84B3" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="07dd1ab1-6ffe-4c27-a8d9-b328f4e59193"
/dev/nvme0n1p3: LABEL="Acer" BLOCK_SIZE="512" UUID="A0284CEE284CC4CE" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="67786068-ade2-42d6-a0ea-5b7aed180391"
/dev/nvme0n1p1: UUID="312F-1B34" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="b2d5c386-744f-f540-9da9-841557378ade"
/dev/nvme0n1p6: UUID="6bd26b5d-d15a-4120-b6d4-baaba3c16e4c" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="48073d9f-9fa0-d440-93e8-dae2ce97c661"
/dev/nvme0n1p4: BLOCK_SIZE="512" UUID="8684EA8284EA73D9" TYPE="ntfs" PARTUUID="a4a31fee-c6c7-4ee6-9b14-8e56686db7d9"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="0172ad06-c4b1-4426-8f6b-fdefa6d3dfc5"

and my /etc/default/grub

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="EndeavourOS"
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 nowatchdog"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

GRUB_DISABLE_OS_PROBER=false

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y
GRUB_DISABLE_SUBMENU=y

Based on those outputs I was said that my windows boot partition is encrypted. I got no response how to decrypt it or make grub decrypt it so that’s why I’m here…

My lazy ass cannot accept booting after pressing f12. Anybody knows how to fix it?
Thanks!

no expert . os-prober come to mind . :innocent:

search forum i think other have same problem before .

welcome to Endeavouros forum BTW

So you had EndeavourOS installed and it was working before with grub having all the entries in it? Then a Windows update caused what? It doesn’t boot or it boots up to grub and won’t load Windows and only loads EndeavourOS?

If the Windows partition is encrypted then it is encrypted using Bitlocker and Bitlocker requires Secure Boot and TPM to be enabled.

Enable Secure Boot - launch Windows - disable Encryption - reboot - disable Secure Boot.

But if it is not encrypted then your partitiontable and filesystem is in a very bad state.

1 Like

I used it for a while and it worked normally with entries etc. It boots up into grub and when I try to choose windows from it, I get the following error:

Error: file EFI/Microsoft/Boot/bootmgfw.efi not found
Press any key to continue

and it redirects me back to grub

I used already os-prober

Where do I need to search for disable encryption option?

Does this mean that Windows bootloader is missing?

And yet:

:thinking:

In EnOS, what does

ls /boot/efi/EFI/Microsoft/Boot

say?

Here’s the output:

BCD           bootmgr.efi   el-GR  fi-FI  it-IT           kd_02_15b3.dll  kd_0C_8086.dll       memtest.efi  qps-ploc   sr-Latn-RS       zh-TW
BCD.LOG       BOOTSTAT.DAT  en-GB  Fonts  ja-JP           kd_02_1969.dll  kdnet_uart16550.dll  nb-NO        Resources  sv-SE
BCD.LOG1      boot.stl      en-US  fr-CA  kd_02_10df.dll  kd_02_19a2.dll  kdstub.dll           nl-NL        ro-RO      tr-TR
BCD.LOG2      cs-CZ         es-ES  fr-FR  kd_02_10ec.dll  kd_02_1af4.dll  ko-KR                pl-PL        ru-RU      uk-UA
bg-BG         da-DK         es-MX  hr-HR  kd_02_1137.dll  kd_02_8086.dll  lt-LT                pt-BR        sk-SK      winsipolicy.p7b
bootmgfw.efi  de-DE         et-EE  hu-HU  kd_02_14e4.dll  kd_07_1415.dll  lv-LV                pt-PT        sl-SI      zh-CN

The file seems to be in there and is seen when you update grub but grub fails to boot it with the message file not found. Yet when you press Fn12 you can choose Windows Boot Manager and it will boot Windows. Odd scenario! Hopefully what @Root said above would help to resolve the issue. I’ll try to dig into it a bit out of curiosity, this issue being new to me.

So, I need to say that, after checking, I don’t have this option

Would you post the output of:

efibootmgr -v

?

here:

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0001,2001,2002,2003
Boot0001* Windows Boot Manager  HD(1,GPT,b2d5c386-744f-f540-9da9-841557378ade,0x22,0x327de)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...41...............
Boot0003* EndeavourOS   HD(1,GPT,b2d5c386-744f-f540-9da9-841557378ade,0x22,0x327de)/File(\EFI\EndeavourOS\grubx64.efi)
Boot2001* EFI USB Device        RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network   RC
1 Like

Thanks! It looks as it should normally. :thinking:

So, do I need to just reinstal the system to make it work? :rofl:

No, I wouldn’t go that far. If I were you I would use Fn12 … to boot Windows for the time being. There might be some minor issue. Just wait for having more eyes (and heads) to look at it.

There is however another option to try if you would like to go that route, namely creating a path to EnOS’ bootloader in Windows to boot it.

I don’t know - better ask that question in a Windows forum - that is - if the disk is encrypted.

thanks!

1 Like

It’s probably BitLocker:

Have a look in there, and try switching that off if it’s on.

2 Likes

It should have secure boot in the UEFI Bios screen.