Printer Issues after enabling mdns


I’m having trouble with my epson printer. I’ve followed all the directions here:
And have followed these discussions: Printer Woes and CUPS find my printer but doesn't find my printer

I have installed the drivers from AUR: epson-inkjet-printer-escpr
and have followed the instructions to enable hostname resolution with avahi and have double checked that the firewall is allowing ipp, ipp-client, and mdns traffic on my network. I have also tried adding the printer with both the print settings GUI and the localhost:631 CUPS interface.

I am able to add the printer just fine, but when I actually try to print, I get an error saying printer *“Unable to locate printer “EPSON255115.local”.”
If I restart the avahi-daemon and NetworkManager, the job will print, but I have to do this every time. I’ve double checked to make sure the /etc/nsswitch.conf file isn’t being overwritten. Could there be another configuration file conflict?

Here’s the output of uname -a:
Linux mason-M1 6.1.6-arch1-1 #1 SMP PREEMPT_DYNAMIC Sat, 14 Jan 2023 13:09:35 +0000 x86_64 GNU/Linux

Let me know what other log files you need.

What epson printer is it?

Edit: Read through this whole page here. I think your printer is similar and setup as network printer?

Thanks for getting back to me!
It’s an epson XP-4100.
Following that article, I was able to get it to work, but I’m not sure why. For some reason, the ipps and dnssd protocols weren’t working. But when I searched for the IP address in the print settings GUI and selected HP JetDirect option, it worked. It looks like this uses the socket protocol instead. I didn’t try it at first since it’s not an HP printer.

Glad you got it working. I’m not that familiar with every printer setup. They are all a little different and it’s not like i get to install many of them except my own which are hooked to usb so it’s a little easier.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.