CUPS find my printer but doesn't find my printer

I have a wireless printer (Brother 1210w, driver from AUR, works in Manjaro)
I have CUPS up and running.
Both in the GUI and in the web interface my printer is easily findable and configurable. But when I actually try to print, CUPS say it’s unable to locate the printer it located 10 seconds ago…

is the printer a static ip ?

DHCP. It works in Manjaro by default, so I wonder what they enable that I have missed…

sounds like : https://wiki.archlinux.org/index.php/CUPS/Troubleshooting#Unable_to_locate_printer

systemctl status avahi-daemon.service

1 Like

You said that your printer is wireless, but then mention DHCP.
How are you trying to access the printer, wireless or wired LAN?

If wireless, the printer doesn’t need a static IP, it uses network discovery to find it.
If wired Lan, as mentioned above a static IP is necessary.

The avahi-daemon would again be wired LAN oriented as Avahi is the wired LAN Network discovery. It sounds like the GUI is finding the printer on wireless, and actual printing is attempting to do so on wired.

Wireless. Never had a cable for it.

avahi-daemon.service - Avahi mDNS/DNS-SD Stack
Loaded: loaded (/usr/lib/systemd/system/avahi-daemon.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2019-07-29 19:09:34 CEST; 1h 41min ago
Main PID: 864 (avahi-daemon)
Status: “avahi-daemon 0.7 starting up.”
Tasks: 2 (limit: 4915)
Memory: 3.0M
CGroup: /system.slice/avahi-daemon.service
├─864 avahi-daemon: running [endeavourOS.local]
└─875 avahi-daemon: chroot helper

jul 29 20:35:57 endeavourOS avahi-daemon[864]: Joining mDNS multicast group on interface wlp3s0.IPv4 with address 192.1>
jul 29 20:35:57 endeavourOS avahi-daemon[864]: New relevant interface wlp3s0.IPv4 for mDNS.
jul 29 20:35:57 endeavourOS avahi-daemon[864]: Registering new address record for 192.168.10.221 on wlp3s0.IPv4.
jul 29 20:35:59 endeavourOS avahi-daemon[864]: Joining mDNS multicast group on interface wlp3s0.IPv6 with address fe80:>
jul 29 20:35:59 endeavourOS avahi-daemon[864]: New relevant interface wlp3s0.IPv6 for mDNS.
jul 29 20:35:59 endeavourOS avahi-daemon[864]: Registering new address record for fe80::8219:34ff:feb8:71a3 on wlp3s0.*.
jul 29 20:36:00 endeavourOS avahi-daemon[864]: Leaving mDNS multicast group on interface wlp3s0.IPv6 with address fe80:>
jul 29 20:36:00 endeavourOS avahi-daemon[864]: Joining mDNS multicast group on interface wlp3s0.IPv6 with address fd42:>
jul 29 20:36:00 endeavourOS avahi-daemon[864]: Registering new address record for fd42:beb9:1090:0:8219:34ff:feb8:71a3 >
jul 29 20:36:00 endeavourOS avahi-daemon[864]: Withdrawing address record for fe80::8219:34ff:feb8:71a3 on wlp3s0.

I stand corrected, your avahi output shows it is for both wireless and wired LANS.

Have you went to CUPS through a browser via localdomain:631 and registered the printer directly to CUPS

2 Likes

I stand corrected again, reread your OP and saw you used web interface and it sees it.

Sorry

2 Likes

btw did you use also the webinterface or system-config-printer ?.
(edit in manjaro)

System config.

@Beardedgeek72 May i ask what cups packages you have installed? I’m speaking only from my own experience with a couple of printers. Both are usb and not wifi. I have the following installed for cups. No avahi.

cups
cups-filters
cups-pk-helper
libcups
python-pycups
print settings (system-config-printer)

Well how do I check that easily?

Edit: scratch this below, apparently it was a one time event.

Adding to this, after trying to add a printer last night and enabling neccesary services according to the Arch wiki, EndeavourOS now has a 1.5 minute closing job for CUPS at shutdown…

$ man pacman
Quote from the command man pacman
-Q, --query
Query the package database. This operation allows you to view
installed packages and their files, as well as meta-information
about individual packages (dependencies, conflicts, install date,
build date, size). This can be run against the local package
database or can be used on individual package files. In the first
case, if no package names are provided in the command line, all
installed packages will be queried. Additionally, various filters
can be applied on the package list. See Query Options below.

then scroll down to “QUERY OPTIONS (APPLY TO -Q)” to see the various options, most of which you will probably never use. In this instance
$ pacman -Q will list every installed package, to cut down on the output use grep
$ pacman -Q | grep cups on my installation yields:
cups 2.2.11-2
cups-filters 1.25.1-1
cups-pdf 3.0.1-4
libcups 2.2.11-2
python-pycups 1.9.74-1

Hope that helps.
Pudge

1 Like

I am missing the cups-pdf package.

cups 2.2.11-2
cups-filters 1.25.1-1
libcups 2.2.11-2
python-pycups 1.9.74-1

Also this is the exact error I have:
processing since
Tue 30 Jul 2019 06:07:30 PM CEST
“Unable to locate printer “BRND85DE26E1AB2.local”.”

Also, I am no expert, but there seems to be two naming conventions of the printer going on. This is how CUPS identifies it:

Description: Brother HL-1210W series
Location: Right here
Driver: Brother HL-1210W for CUPS (grayscale)
Connection: dnssd://Brother%20HL-1210W%20series._ipp._tcp.local/?uuid=e3248000-80ce-11db-8000-d85de26e1ab2
Defaults: job-sheets=none, none media=iso_a4_210x297mm sides=one-sided

But when it prints it’s looking for: BRND85DE26E1AB2.local
Is this how it’s supposed to be?

that .local issue is probably like https://wiki.archlinux.org/index.php/Avahi#Hostname_resolution , even it detect the printer.

2 Likes

Thank you. That did it.

" Hostname resolution

Avahi provides local hostname resolution using a " hostname .local" naming scheme. To enable it, install the nss-mdns package and start avahi-daemon.service .

Then, edit the file /etc/nsswitch.conf and change the hosts line to include mdns_minimal [NOTFOUND=return] before resolve and dns :

hosts: … mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns …"

did it.
Interestingly enough it caused the printer to disappear and had to be re-found. But now it works.

3 Likes

When you go to print something, in the section where you choose the printer there is usually a “Print to file” option. The cups-pdf package provides that option.

Edit:
you entered your above response about fixing it as I was typing my response.
Anyway, Glad you got it going.

1 Like

See above, it’s solved. My guess is Manjaro adds that line in the .conf file by default.

Anyway thank you!

1 Like