Poor Gaming Performance On A Fresh Xfce Install

Hola Emigos,

I have just had a fresh Xfce endeavour os install , I mean I chose online installation and Xfce as my de .

After booting , I installed steam using Pacman and protontricks using yay .

When I booted up my game , I was surprised to see crap af performance, the whole thing was choppy . Tried switching games but didn’t work. Lutris gave same results.

I have encountered this issue on Garuda Linux as well and a simple Pacman -syu fixed it .

I have a 10th gen i3 1005g1 with uhd g1 and before endeavour all games on other distros worked butter smooth .

As I have a 10th gen cpu , no xf86 driver as well , only modesetting driver .

Tried using the endeavour wiki but if no use.

Gracias !

Hello 47, Diana here! :smiley:

  1. Read this, especially Requirements part, make sure everything is installed properly.
    Linux gaming [Guide]

Yes Madam/Sir ! Everything is installed correctly , I just changed the dxvk dll(s) for older ones and it seems that the problem is fixed , thanks fot the help though !

Good luck, 47!

1 Like

Turns out I was wrong , after a fresh Galileo Xfce install , the dxvk hue shows 42 fps but the gameplay is choppy af , in lutris and steam . And yes everything is correctly installed, and I am facing this issue in every arch based distro.

Give us some more intel, 47.

inxi -Fazy1

Which games have you tested, which wine / proton versions?

1 Like

Just cause 2 proton 8 and experimental , just cause 1 with same , ac 2 wine ge and pop sands of time proton 7

inxi output :

  Kernel: 6.6.2-arch1-1
    arch: x86_64
    bits: 64
    compiler: gcc
      v: 13.2.1
    clocksource: tsc
      available: acpi_pm
    parameters: initrd=\96d2fa53a8df4b5fb0ef99b63009e749\6.6.2-arch1-1\initrd nvme_load=YES nowatchdog rw rootflags=subvol=/@ root=UUID=55cd352e-5acf-45b5-955a-65e7719669a0 systemd.machine_id=96d2fa53a8df4b5fb0ef99b63009e749
  Desktop: Xfce
    v: 4.18.1
    tk: Gtk
      v: 3.24.36
    info: xfce4-panel
    wm: xfwm
      v: 4.18.0
    vt: 7
    dm: LightDM
      v: 1.32.0
  Distro: EndeavourOS
    base: Arch Linux

  Type: Desktop
  System: HP
    product: HP All-in-One 22-df0xxx
      v: N/A
      serial: <superuser required>
    type: 13
    serial: <superuser required>
  Mobo: HP
    model: 87A4
      v: 10100
      serial: <superuser required>
    v: F.36
    date: 08/07/2023

    model: Intel Core i3-1005G1
    bits: 64
    type: MT MCP
    arch: Ice Lake
      gen: core 10
    level: v4
      note: check
    built: 2019-21
    process: Intel 10nm
    family: 6
    model-id: 0x7E (126)
    stepping: 5
    microcode: 0xC2
    cpus: 1
      cores: 2
        tpc: 2
      threads: 4
    smt: enabled
      L1: 160 KiB
        desc: d-2x48 KiB; i-2x32 KiB
      L2: 1024 KiB
        desc: 2x512 KiB
      L3: 4 MiB
        desc: 1x4 MiB
  Speed (MHz):
    avg: 1081
    high: 1101
    min/max: 400/3400
      driver: intel_pstate
      governor: powersave
      1: 1035
      2: 1101
      3: 1100
      4: 1090
    bogomips: 9524
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
    Type: gather_data_sampling
      mitigation: Microcode
    Type: itlb_multihit
      status: KVM: VMX disabled
    Type: l1tf
      status: Not affected
    Type: mds
      status: Not affected
    Type: meltdown
      status: Not affected
    Type: mmio_stale_data
      mitigation: Clear CPU buffers; SMT vulnerable
    Type: retbleed
      mitigation: Enhanced IBRS
    Type: spec_rstack_overflow
      status: Not affected
    Type: spec_store_bypass
      mitigation: Speculative Store Bypass disabled via prctl
    Type: spectre_v1
      mitigation: usercopy/swapgs barriers and __user pointer sanitization
    Type: spectre_v2
      mitigation: Enhanced / Automatic IBRS, IBPB: conditional, RSB filling, PBRSB-eIBRS: SW sequence
    Type: srbds
      mitigation: Microcode
    Type: tsx_async_abort
      status: Not affected

  Device-1: Intel Iris Plus Graphics G1
    vendor: Hewlett-Packard
    driver: i915
      v: kernel
    arch: Gen-11
      process: Intel 10nm
      built: 2019-21
      active: eDP-1
      empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1
    bus-ID: 00:02.0
    chip-ID: 8086:8a56
    class-ID: 0300
  Device-2: Luxvisions Innotech HP TrueVision HD Camera
    driver: uvcvideo
    type: USB
      rev: 2.0
      speed: 480 Mb/s
      lanes: 1
      mode: 2.0
    bus-ID: 1-10:7
    chip-ID: 30c9:0013
    class-ID: 0e02
    serial: <filter>
  Display: x11
    server: X.Org
      v: 21.1.9
    compositor: xfwm
      v: 4.18.0
        loaded: modesetting
        alternate: fbdev,intel,vesa
      dri: iris
      gpu: i915
    display-ID: :0.0
    screens: 1
    Screen-1: 0
      s-res: 1920x1080
      s-dpi: 96
      s-size: 508x285mm (20.00x11.22")
      s-diag: 582mm (22.93")
      Monitor-1: eDP-1
        model: HP ALL-in-One
        serial: <filter>
        built: 2019
        res: 1920x1080
        hz: 60
        dpi: 102
        gamma: 1.2
        size: 476x268mm (18.74x10.55")
        diag: 546mm (21.5")
        ratio: 16:9
        modes: 1920x1080
    v: 1.5
      drv: intel iris
      device: 0
        drv: iris
      device: 1
        drv: swrast
        drv: iris
        drv: iris
      inactive: gbm,wayland
  API: OpenGL
    v: 4.6
    compat-v: 4.5
    vendor: intel mesa
      v: 23.2.1-arch1.2
    glx-v: 1.4
    direct-render: yes
    renderer: Mesa Intel UHD Graphics (ICL GT1)
    device-ID: 8086:8a56
    memory: 7.36 GiB
      unified: yes

  Device-1: Intel Ice Lake-LP Smart Sound Audio
    vendor: Hewlett-Packard
    driver: snd_hda_intel
      v: kernel
      alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3
    chip-ID: 8086:34c8
    class-ID: 0403
    v: k6.6.2-arch1-1
    status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire
    v: 0.3.85
    status: active
      1: pipewire-pulse
        status: active
      2: wireplumber
        status: active
      3: pipewire-alsa
        type: plugin
      4: pw-jack
        type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard
    driver: r8169
      v: kernel
      gen: 1
      speed: 2.5 GT/s
      lanes: 1
    port: 4000
    bus-ID: 01:00.0
    chip-ID: 10ec:8168
    class-ID: 0200
    IF: enp1s0
      state: down
      mac: <filter>
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard
    driver: rtw_8821ce
      v: N/A
      modules: rtw88_8821ce
      gen: 1
      speed: 2.5 GT/s
      lanes: 1
    port: 3000
    bus-ID: 02:00.0
    chip-ID: 10ec:c821
    class-ID: 0280
    IF: wlan0
      state: up
      mac: <filter>

  Device-1: Realtek Bluetooth 4.2 Adapter
    driver: btusb
      v: 0.8
    type: USB
      rev: 1.1
      speed: 12 Mb/s
      lanes: 1
      mode: 1.1
    bus-ID: 1-5:6
    chip-ID: 0bda:b00a
    class-ID: e001
    serial: <filter>
    Report: btmgmt
      ID: hci0
        rfk-id: 0
      state: down
        bt-service: disabled
          hardware: no
          software: no
      address: N/A

  Local Storage:
    total: 975.29 GiB
    used: 44.6 GiB (4.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda
    maj-min: 8:0
    vendor: Western Digital
    model: WD10EZEX-60WN4A1
    size: 931.51 GiB
      physical: 4096 B
      logical: 512 B
    speed: 6.0 Gb/s
    tech: HDD
    rpm: 7200
    serial: <filter>
    fw-rev: 1A03
    scheme: GPT
  ID-2: /dev/sdb
    maj-min: 8:16
    vendor: SanDisk
    model: Cruzer Blade
    size: 14.53 GiB
      physical: 512 B
      logical: 512 B
    type: USB
      rev: 2.1
      spd: 480 Mb/s
      lanes: 1
      mode: 2.0
    tech: N/A
    serial: <filter>
    fw-rev: 1.00
    scheme: MBR
    SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-3: /dev/sdc
    maj-min: 8:32
    vendor: SanDisk
    model: Cruzer Blade
    size: 29.25 GiB
      physical: 512 B
      logical: 512 B
    type: USB
      rev: 2.0
      spd: 480 Mb/s
      lanes: 1
      mode: 2.0
    tech: N/A
    serial: <filter>
    fw-rev: 1.00
    scheme: MBR
    SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?

  ID-1: /
    raw-size: 243.1 GiB
    size: 243.1 GiB (100.00%)
    used: 13.6 GiB (5.6%)
    fs: btrfs
    dev: /dev/sda2
      maj-min: 8:2
  ID-2: /home
    raw-size: 243.1 GiB
    size: 243.1 GiB (100.00%)
    used: 13.6 GiB (5.6%)
    fs: btrfs
    dev: /dev/sda2
      maj-min: 8:2
  ID-3: /var/log
    raw-size: 243.1 GiB
    size: 243.1 GiB (100.00%)
    used: 13.6 GiB (5.6%)
    fs: btrfs
    dev: /dev/sda2
      maj-min: 8:2

  Alert: No swap data was found.

  System Temperatures:
    cpu: 51.0 C
    mobo: N/A
  Fan Speeds (rpm): N/A

  Processes: 257
  Uptime: 1h 0m
    wakeups: 0
    total: 8 GiB
      note: est.
    available: 7.53 GiB
    used: 4.11 GiB (54.6%)
  Init: systemd
    v: 254
      default: graphical
    tool: systemctl
    gcc: 13.2.1
    pm: pacman
      pkgs: 906
        libs: 294
      tools: yay
  Shell: Bash
    v: 5.2.21
    running-in: xfce4-terminal
  inxi: 3.3.31

1 Like


pacman -Qs vulkan
local/lib32-vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver (32-bit)
local/vulkan-headers 1:1.3.269-1 (vulkan-devel)
    Vulkan header files
local/vulkan-icd-loader 1.3.269-1
    Vulkan Installable Client Driver (ICD) Loader
local/vulkan-intel 1:23.2.1-2
    Intel's Vulkan mesa driver

Everything seems to be fine on paper…I’m not expert on Intel GPUs though.

Let’s see what people say on protondb about Just cause 2 for instance.

Try this:

Custom Proton: GE, Set launch options

/dxadapter=0 /borderless=0 /dx11

On all other distros , except arch based , it runs butter smooth , but here about a couple of months around , all arch distros haved chugged me up , tried those launch options , didnt work.

Logically, it’s likely GPU drivers / config if rest of the stuff like steam / lutris / wine / dxvk etc were similar on other distros.

Let’s wait for some Intel GPU experts to come :upside_down_face:

What you suggest , should I try freebsd in the meantime , will give a bit a knowledge as well.

I think it’s absolute worst idea to try freebsd for gaming :rofl:
But what do i know, if you’re up for some challenge - go for it! :partying_face:

I think this to be a issue from mesa’s side , all this started when I was on garuda and a simple update f’ed it up.

Now it occurs on every arch based distro as I update , tried a fresh garuda install a few hours back , no gain.

I wonder if it may be shader recompilation or something, try to play a little longer and see if it improves and stop stutter over time.

Played for a total 30 mins , no use :rofl: man I hate mesa

(disclaimer) I know nothing about Intel graphics.
However, it’s been my experience that if you require modesetting, you’re in for a terrible performance hit on graphics.

1 Like

If I am on modesetting drivers , then a performance penalty ? wait a sec , let me install xf86 drivers.