Pipewire sound stopped working after latest update

As the title says, sound on KDE is no longer working after the latest update and is intermittent. Connecting to bluetooth headphones doesnt work either. Once or twice the sound randomly started working again only to stop again immediately afterwards. Going into alsamixer with a video playing on firefox i see nothing. I changed no settings and it was working perfectly fine earlier. I have no idea what the issue might be. Any ideas?

1 Like

I had some similar problems after updating today, with the addition of display freezes. I have configs for pipewire and wireplumber in ~/.config, but they were unchanged.

I restored a pre-update btrfs snapshot, deleted the config files in ~/.config, did the update again and rebooted. Now everything works, also after copying the config files from /usr/share/pipewire and /usr/share/wireplumber to ~/.config/pipewire and ~/.config/wireplumber again.

That could be a first try, if you have your audio config files in your Home directory.

This on KDE Plasma x11 session, by the way.

My issue is on KDE wayland as well

yeah i restored from a earlier snapshot with Timeshift and the audio is working. So im not really sure what broke in the latest update in regards to Pipewire audio. Im not really sure where to go from here other than holding off on updates

I will try this next chance i get

im using the default Pipewire - Wireplumber config that ships with endeavour, I haven’t touched my config files. I will report back if this works

Having the same problem. I deleted the configs in .config/wireplumber and that worked for me.

Also as a note it is probably related to that - the release notes for wireplumber 0.5 mention: https://pipewire.pages.freedesktop.org/wireplumber/resources/releases.html

The configuration system has been changed back to load files from the WirePlumber configuration directories, such as /etc/wireplumber and $XDG_CONFIG_HOME/wireplumber, unlike in the pre-releases. This was done because issues were observed with installations that use a different prefix for pipewire and wireplumber. If you had a wireplumber.conf file in /etc/pipewire or $XDG_CONFIG_HOME/pipewire, you should move it to /etc/wireplumber or $XDG_CONFIG_HOME/wireplumber respectively (!601)

https://forum.endeavouros.com/t/bluetooth-audio-suspend-on-idle-fix-no-longer-working-with-wireplumber-0-5-0/53169

I had a similar issue. The ArchWiki fix was updated sometime the past 4 days and bluetooth audio now works again for me.

I have a similliar problem. Sound in WarThunder is gone since a week or so. My headset (front audio 3.5mm connector) works fine in other apps under EOS. Audio settings and test works too.

While in WT, if I press volume up/down, I hear a beep in the headset so something works at least. But no other sound at all in the game. The game setting is “Analog built-in audio”.

The systemlog have this line, never seen it before. However, the headset is not on USB as I wrote.

[mån apr 1 21:18:34 2024] usb 1-6: 1:1: cannot get freq at ep 0x81

Anyone?