Bluetooth audio suspend on idle fix no longer working with wireplumber 0.5.0

I had (and now have again) an issue with Bluetooth audio cutting out. The only way to fix would be restart or reconnect headphones but it only lasts a few minutes before cutting out again. I previously fixed the issue by following guide on Archwiki and set session.suspend-timeout-seconds to 0. section 5.1.13

This worked until the recent wireplumber/libwireplumber update to 0.5.0. Reading up indicated that they changed config file format from lua so I followed the updated guide using new format but no luck. Also tried deleting all wireplumber config files and reinstall wireplumber/libwireplumber but no luck.

Temporarily downgraded wireplumber and libwireplumber to 0.4.17 and restored old lua configs and it solves the issue (again). Also added to ignorepkg. However, its obviously not ideal.

Can anyone assist in preventing the issue with wireplumber/libwireplumber 0.5.0 since the fix on the archwiki that worked for me previously, no longer does.

Kernel 6.8.1-arch1-1
Plasma 6.0.2 DE

Maybe wait until there is an updated wireplumber package and try again.

Thanks for the reply. I’ll wait for the 0.5.1 or.2 release and see how that goes. Otherwise I’ll open a bug report. Seems like this update caused many other issues for others as well.

There was just updates to pipewire?

Just posting to say issue is now resolved. Updated to wireplumber 0.5.1 today but it seems the fix is an updated config from the ArchWiki guide. The previous pipewire node suspension section (5.1.13) in the ArchWiki called for two seperate disable suspension configs for alsa monitor (in wireplumber.conf.d) and bluez (in bluetooth.lua.d) in two different folders.

The updated config now calls for a single config file in a single folder, namely: ~/.config/wireplumber/wireplumber.conf.d/51-disable-suspension.conf

In short, I deleted all previous configs, updated, placed the new single config file as per the updated ArchWiki article then restarted pipwire and wireplumber services. All working again without any issues.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.