Pinebook Pro image with External Monitor Support

Hey there,
I am coming from a horribly unstable experience on manjaro in the hopes of getting a system that does not self destruct when you use it for five minutes.

First of all - How can I install this on the pinebook pro without going through the lengthy manual installation procedure? I don’t wanna do this not only because it’s long, but also because this would be my first time doing it and I’d have to do it twice: PC → SD → NVME

Some feature I really want to get to work is my external display, so please tell if that will work. On manjaro I used the linux-pinebookpro kernel, and after I told them about my problems they said I’d have to try it with linux-lts and that they will remove the pinebookpro kernel. Does this apply here too?

I hope this does better once I manage to get it installed.


Welcome to the purple space!!
:enos_flag: :rocketa_purple:

We have public beta images available.
Follow the instructions on this repo:

This is not a lengthy procedure. There are two steps

  1. Run the script in the repo I gave you to flash pinebook pro image in a storage device of your choice. I have tested it on micro SD cards and eMMcs but haven’t tested on NVME.
  2. Insert the device to your pinebook, it will boot into a openbox environment with calamares to configure your install.

I haven’t tested the pinebook pro with an external image, so try and let us know how it goes.

We use the linux-arm kernel from manjaro (since it is the officially supported kernel for pinebook pro with required patches). I don’t know what the linux-pinebookpro kernel is. Give me the link of your communication with them I’ll take a look.

For me the pinebook is working as intended i.e. as a laptop with audio, video, keys all working. I haven’t tested it in other scenarios.

Try our image and let us know how it goes.


This is not a lengthy procedure. There are two steps

Oh thank you! It’s indeed very easy to use. Seems like I might be able to give it a shot tomorrow after all :slight_smile:

Give me the link of your communication with them I’ll take a look.

It was in a matrix channel, but their response was:

The linux-pinebookpro kernel is very old and likely does not work anymore.
To get external screen working you might be lucky with the linux-lts package instead.

1 Like


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for testing the PineBook Pro Beta image. After install feedback is appreciated.


1 Like

Sadly I’m already facing issues directly after the install: While the image does boot, the screen just stays black indefinitely. I waited about 10 minutes, but nothing happened. I did notice that the caps lock and numlock lights work though, so something seems to be initialised

The screen in this case is the pinebook pro screen right?

What batch of Pinebook pro did you get?

I have no clue how to find out what batch I got. I bought mine about 2-3 Years ago

I doubt that the screen is the issue. I noticed the backlight flicker for a second which indicates some communication between EOS and the screen (It did not)

I do own a UART cable though. If you want, I can check if there is anything going on. I don’t wanna open the PPP once again just for nothing, it’s always a somewhat annoying process. The UART switch should be on the outside

Did it come with manjaro pre installed or Armbain when you got device.

If it Armbain you prob need jump few hoop to get working eos install on eMMc .If Armbain then @lxnauta prob can help as he need small adjustment to install working system.

EDit. If I remember right kernel 5.7 or 5.10 was last with external display support. Only distro now I think is Armbain still patch kernel.( no sure )

Other thing is patch kernel your self for external display support. ( will probably break after kernel update, so will need fix+ repatch. )That why I think manjaro stop using the patch

Mine actually came with manjaro. Also I’m trying to install this on my NVME if it matters, but yeah, sd booting is currently not working,

so it 2year old … Nvme never be great ( hit + miss ) also no worth battery power drain imo. It your system your rule at end of day :blush: have you try different sd card? it well documented on pine64 wiki sd card ( hit + miss ) also what de or wm you install

have you try different sd card

I have in fact tried 3 different SD cards. One of them has booted many times on my PBP.

what de or wm you install

I can’t remember the installer script asking, but I would have probably picked gnome (Isn’t the installer booting into an openbox installation for setup?)

Yes, are you able to see that?

No, that’s the point. I can’t see anything. Caps- and Numlock change states when pressed though

Can you get to a tty?

I can’t even see a blinking cursor, no

Sradjoker means for you to press the following keys simultaneously, in order.

Ctrl + Alt + F3

and see if a Console window comes up with a login prompt.


sadly no ttys worked

ok. this what i would try. ( I no put blame on any one + no wish anger any one )

(1) use a sd card that work 100% before , reflash Endeavouros installer on it . ( maybe something go wrong last process ) try boot if that no boot again.

(2) try manual way … 1st install pre-built arch from here " "
( follow instruction for SD card ) try boot that . if that boot you could manual install EOS if want + i sure Sradjoker will help you in process ( at least you get working EOS install )

(3) if you have will/time work with Sradjoker find out what fail on your version of Pinebook Pro ( Sradjoker have new device that work , lxnauta have older than your + work with Endeavouros installer )

This only idea … your system your rule


I just tried the UART cable and it seems like the PBP does not get past the boot process. Maybe the kernel is not loaded

1 Like

Oh hey! Thanks for the suggestion! I did it manually and it in fact ended up booting. The installer script for the PBP seems broken.

To the test-image maintainer: Please enable UART output. I’m not able to see anything via screen. I know that I have it enabled via the hardware switch.

Edit: … Why is the kernel name shown in the tty something with MANJARO-ARM?

Edit 2: Hm, seems fine. I would however prefer to use a BTRFS filesystem