Pi400 initial boot no signal from screen

I followed the instruction on having EndeavourOS (Artemis) on a Pi400 system installed and created the SD.
The system boots, displays the rainbow screen and initial boot. When, I assume, it comes to the GUI the screen shows no Signal input. Is there a setting I have to do in the cmdline.txt or config.txt (there is actually a config.txt.org also)? Thanks

There is nothing you need to do, everything is configured for the boot into calamares environment.
Can you give further details, what is the storage device you are burning the image into?
Also, can you send a picture of the initial boot?

Mod edit:
Changed to #arm:installation category

Just send the screenshots. Easier to look at

here are two screenshots from the recording, at the beginning when starting up the Pi400 and the last entry before the screen goes black.


As filesystem I had selected btrfs when creating the arm install on the SD card.

It looks like the boot partition wasn’t done properly.
image

Is this where the screen stops or is there any other messages?
Did you use the ISO for flashing the image?
Can you reflash the arm image?

I downloaded the iso EndeavourOS_Artemis-22_6.iso, put it on a USB stick which has Ventoy installed.
booted the iso in the laptop, selected the ARM Installation, which has several steps and takes in total about 15 minutes (download, unzip, sync). shutdown the laptop. took the SD card out, plugged it into the Pi400 and booted. after the last message Starting Flush Journal to Persistent Storage … screen goes black. and nothing happens even when I let it sit for 5 minutes.
I will make a new ARM Installation and try it out. I will let you know tomorrow.
Thanks

2 Likes

You followed the instructions correctly, it should’ve booted properly. We haven’t seen boot partition errors in a while. It is a strange error, maybe @Pudge has an idea??

Your bootloader is rather old-ish. I would look into updating the bootloader on your RPi 400.
There was a recent case, not quite similar’ but a non-booting install nevertheless where updating the bootloader resolved the issue. (See here: [noob] cannot boot from base install on rasp pi 4 4gb)

:warning: Please do a bit of research of your own and make sure you understand the implications of modifying your device in any way. The responsibility is all yours :wink:

2 Likes

I have the Pi 400 and i have no issues. I wouldn’t be using ventoy first of all to create the image from. I say this because i have seen many times where that’s the issue with trying to install Endeavour when the live ISO is on ventoy. You should update the Pi 400 so it has the latest firmware (eeprom) and boot loader.

1 Like

I’m going with ricklinux on this one. Not a big believer in ventoy.

Pudge

I am not sure the issue is caused by Ventoy.

If it boots up the EnOS’ ISO fine, the welcome app comes up alright, the installer button works and starts off the script and the install process is completed without errors, then why it should matter what method or medium you have used to launch the Live EnOS’ ISO.

Ventoy, to my understanding, works pretty similar to having created a custom boot entry in grub for launching the ISO stored somewhere in your system.

Hello ricklinux,
I using Ventoy to boot into ISO image (aka live ISO), such as the EndeavourOS_Artemis-22_6.iso ISO.
When booted that image I follow the instructions which I did today again and after successful creating the ARM image on a different SD card, I am getting the same issue. it boots up and at some point black screen.
so it is not Ventoy as source of problem.

As stated by @pebcak and @ricklinux, the issue is most probably with the firmware (eeprom).
This solution fixed the issue of a user before.

I haven’t looked at this issue because I don’t have a Pi 400. The development team will discuss this issue and try to solve it.

I agree the process for not working bootloaders should we documented somewhere, maybe a forum post or a wiki post.
If your issue is solved, we can use the solution as a template to document it for other issues. This is a relatively new issue for us.

Hello pebcak,

yes the update of the bootloader solved my problem. Thank you for pointing it out. But I would not have seen it, if I hadn’t done a recording of the boot process.
Here are the steps with links I did to upload the bootloader from this Pi400.

  1. went to Raspberry Pi website and downloaded Raspberry Pi OS Lite
  • Release date: April 4th 2022
  • System: 64-bit
  • Kernel version: 5.15
  • Debian version: 11 (bullseye)
  • Size: 270MB
  1. created the SD card using etcher
  2. booted the Pi400 and went through the initial steps
  3. (modified the /etc/dhcpcd.conf assigning a static IP@ (that network of mine has no DHCP) restarted the system)
  4. followed the steps for upgrading the bootloader on that website
  • sudo apt update
  • sudo apt full-upgrade
  • sudo apt install rpi-eeprom

you could also just try

  • sudo rpi-eeprom-update

I have now a bootloader version from April 2022, seems there is one from June 2022 out there already(?).

  1. powered down the Pi400 and switched SD card (using the one I created yesterday for EndeavourOS ARM)
  2. and was able to boot all the way into Calamares and continue installing it using the Cinnamon DE.
3 Likes

this will get automatically updated in your system once you install it

That sound’s great! Glad you got it sorted out!

And also, good to know that what method or medium (in this case Ventoy) you use to boot into the live session won’t matter as long as you have successfully booted up the live ISO, have a GUI and can run apps and commands without issues. It is all loaded and run from RAM after all.

So now I think we would need to add to the documentations/instructions that an updated bootloader is necessary for a successful boot process of the installed image.

Thanks for reporting back and enjoy your EnOS ARM Cinnamon!

1 Like

@anon99017705

When the first boot failed, did you try to bring up a TTY console window using CTRL-Alt-F3?

If a console window was available, one should be able to update the EEPROM from the terminal.

If no terminal was available, we need to take a different approach.

I the RPi 400 kit includes a uSD pre-installed with Raspberry Pi OS. I am not sure if you get the keyboard (main unit) only, if a uSD with RPi OS installed is included or not.

Pudge

EDIT:
Thank you for working with us on this problem. And thanks to the other forum members who participated in solving the problem. :clap:

Also, out of curiosity, what was the Hardware Version of your RPi 400 as shown in neofetch.
Mine is Hardware version 1.0 and I had to update the EEPROM.

I am not sure if it is possible to bring up the TTY when the boot process is not completing or more like the screen goes black.

I just ordered the Pi400 without any additional items. no powersupply, no uSD etc.


Here is the information from neofetch. It also states Rev 1.0

In the meantime I tried installing EndeavourOS Arm onto a MSATA Disk, but running in all kinds of problems. I guess it is the controller of the USB case for the MSATA.

1 Like

@ricklinux had run also to some issues booting off of a SSD. He had resolved it by adding some kernel parameters. Perhaps he could lend you a hand on this.