[noob] cannot boot from base install on rasp pi 4 4gb

Hello everyone, I tried to install the latest EOS on my raspberry pi 4 - 4gb. I followed the guide to,

  1. prepare the liveOS usb and boot it up at a x84 computer,
  2. use the ARM installer to install base image to the microSD card (ext4)
  3. insert into pi and boot it up

But at step 3, the rasp pi 4 stuck at boot loader stage and show the following screen,

I am not sure the debug steps after this error screen. Perhaps I missed some obvious step, so any help is greatly appreciated! Thanks ahead!!

Hello @kalvin807
Welcome to EndeavourOS Forum :partying_face:

According to the screenshot you shared, it is clear that your SD card, the bootloader is indicating that the partition table is empty, as 0 sectors is written.
And also it is showing that it is not in FAT32 partition. Hence, reinstallation might be helpful.

I am not an expert by any means, hence I will relay this to @sradjoker and @Pudge to handle the situation efficiently.

Also,

https://forums.raspberrypi.com/viewtopic.php?t=294176

is what I found.

1 Like

Make sure your sdcard has anything written on it by putting in your x86_64 PC and checking to see you have a readable boot folder (contains files along with config.txt and cmdline.txt). If this is the case then try rewritting the image. If not, partition the sdcard as fat32 and rewrite the image to the sdcard.

1 Like

Welcome to :enos: forums!! @kalvin807
:enos_flag:

It seems your boot partition wasn’t installed properly so I would suggest you to reinstall and see if you have the same error again.

1 Like

Thanks all the guidance! I tried to reinstall it several time, but all ending in same error. :frowning:
I checked some pages (this issue, and the doc). All suggesting rp4 only boot on sdcard with MBR format. I wonder if this is the problem, because in the script, it use gpt to partition the drive.

Not sure if this would be the cause but your screenshot shows that the bootloader is from Apr 16 2020.

You might perhaps want to run Raspberry Pi OS and update it.

:warning: Disclaimer: please do your own research and make sure you understand the implications of any action you take to change or modify your device. The responsibility is all yours :wink:

1 Like

Thank you! That’s the trick.

1 Like

You are welcome!
Glad you got it working!

And welcome to the community @kalvin807!

:enos_flag: :handshake:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.