PCIE Error resulting in no GUI/ instant freezing after boot

I freshly installed endeavourOS on my Laptop that has a dual GPU setup. The primary GPU is an Intel HD graphics 620 which seems to not make any problems, the second one being a Ge-force 920m. This second one seems to throw some PCIE Errors and preventing my GUI from starting on most cases. When is start the system without GUI and try starting it following Error gets thrown.


I would be really happy if someone knows how to fix the problem. Just installing the NVIDIA drivers also did not fix it for me. But the automatic config file was a bit suspicious because it did not have any resolution or specifications besides the depth for my display nor seemed the GPU detected correctly.

The screenshot doesn’t show any PCIE errors, but if you have a hardware issue then no amount of software tweaking is going to help.

This is a Kepler-based GPU so you need the 470xx drivers.

It’s not included because it’s not needed.

i forgot to include the pictures of the errors.


Did these appear at some point or have they “always” been there?

If it has only started happening recently, what changed? (I assume it did work, and that you changed something very recently, so it should be fairly easy to work out what changed, e.g. the kernel).

i just installed the os yesterday and it froze on me before the login screen and then looking at the booting process i found those errors. this looked like the gpu was used besides it having the intel hd as display output but i tried installing the drivers for it but as i said the config file was wired.

OK. Go back to the live installer environment and check that works correctly, and whether the same messages appear on boot.

Then, reinstall the base OS and check whether that works without making any changes.

After that we can start working out what’s wrong.

1 Like

I suggest to install with nouveau driver (free driver) first then tackle the Nvidia driver as @jonathon mentions.

I also had some problems with hybrid graphics.

For the 470 driver here is the relevant info, also found as pinned thread on top of forum :wink:

Edit: if you feel comfortable on tty you could remove the nvidia driver and switch to open source like in my first link, then install 470 following the second link.

how do i do that i’ve not seen any option to select drivers for the install

the live os worked completely fine but the installed one instantly freezes on a grey screen with time and date on it(no login screen was ever displayed)


)

When you boot in live iso it normally shows an option with Nvidia (non-free) and another option free driver.

You just have one option showing up?

i just tried booting into live again is that before i get into the live os i have those options

is that what i should have looked for?

I think the second option, try to boot into it.

the secound one was what i just did and i did not see any options for video drivers in there

The screen you just showed gives two options, the first is with Nvidia and the second with open source drivers. There are no other options after that screen, it just boots into the live iso.

So you are now able to boot into the live iso with the open source driver?

yes the live version is booting and working as it was before but after installation it did not work anymore

Just to make sure… So you choose the second option (default) not nvidia, booted in live iso and installed. Then you had screen freeze on reboot.

Thanks for clarifying.

yes i selected default then i booted the live, installed endeavour os after the reboot it freezes on as it seems the first frame showed.

Ok. The strange thing is that the image you showed earlier with the top bar and date seems to be the login screen of gnome (GDM). The problem doesn’t seem to be related to Nvidia.

Perhaps @jonathon has more insights. I don’t know whether installing the 370x driver would fix that. Your best bet would be to post the journal log of your boot.

By the way, can you access the command line via Ctrl+Alt+F3?

No messages in the journal about PCIE?

“Freezes” as in the mouse doesn’t work and you can’t switch to a TTY?

This looks like GDM which implies you customised the installation. Given you’re having issues, it might be a good idea to try the defaults.

i can access that if i press it before it freezes so before it tries to boot into gui if it froze the system is unresponsive in any way.