Problem and solutions wih nvidia 495 driver troubleshooting

Just a heads up that on certain nvidia systems the eos nvidia installer script seems to be problematic. Here are the steps I followed and troubleshoot, in case someone else runs into the issue with recent hardware (doesn’t apply to incompatible nvidia, read up the pinned thread for that Nvidia drops 700 (Kepler) into legacy branch (470xx) - #37 by joekamprad).

EDIT: of course you can skip steps 1-3, which explain what did not work for my system, and how to troubleshoot.

  1. sudo nvidia-installer-dkms installed nvidia via script
  2. reboot hangs on black screen (tried lts and recent kernel)
  3. went to tty Ctrl+Alt+F3 and moved back to nouveau driver sudo nvidia-installer-dkms -n
  4. installed nvidia driver via pacman sudo pacman -S nvidia-dkms
  5. boot into 5.14 kernel (lts did hang, so better use the new kernel)

Here is my hardware info:

$ inxi -Ga
Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Lenovo driver: i915
           v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
           Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
           driver: nvidia v: 495.44 alternate: nouveau,nvidia_drm bus-ID: 01:00.0

I also want to mention that I just installed KDE plasma via online installer, and that the installer failed twice when I chose to install with nvidia driver. Installed then via nouveau driver. Previously I had gnome and most recent eos iso, and did not seem to have a problem with nvidia 495 driver, but who knows what is going on. Nvidia is a mess.

It’s been a rough week for users with nvidia I see. As an nvidia/intel user I count myself lucky, at least for this moment in time :stuck_out_tongue:

Others less fortunate have been seen here recently:
The first link below ended up being solved after a very, very lengthy discussion. The second link is still ongoing for a solution, not sure if you’re information may possibly be of use, hmm.

I am not out of the woods yet. Connecting a second monitor and everything is laggy. Could be better with gnome and wayland, will have to try another install. Hoped to use kde on this lappy, but not happy :sweat_smile:

Saw the long post, glad that it got solved.

Haven’t tried yet Optimus today… battery is draining on Nvidia.

1 Like

I’m running fine on Nvidia 495.xx but is single desktop GTX1060. It upgraded fine and i also have installed the 5.15 kernel and is working. :man_shrugging:

Edit: This is on Xfce with dual boot Windows 11

Definitely last time ever I will get a hybrid graphics with Nvidia, total :poop: show

Yes i will also never buy a Hybrid laptop. I have Ryzen using amdgpu on laptop.