PC has gone from blazing fast and responsive to slow and unresponsive.


For some time now, lets say a month, my laptop with endeavouros has gone from fast to laggy. I’ve postponed trying to fix the issue as I don’t have much experience with linux and hoped an update would take care of it at some point, but there doesn’t seem to be an end in sight.

Opening a project in vscode can take 20 seconds before vscode is usable. Once loaded it’s usually fairly fast, but it varies. Sometimes whatever I type can wait 3 seconds before it’s rendered, suggestions can be rendered slowly so it looks like it fades in.
Just loading a basic newpaper in firefox can take quite a while.

I realize I’ll have to post some logs here, but I don’t really know what is needed to diagnose the issue. Any help would be greatly appreciated :slight_smile:

Including suggested logs.

output from inxi -Fxxc0z | eos-sendlog

output from journalctl -k -b -0 | eos-sendlog

Hi @endeavourforums
First welcome to the wonderful world of EndeavourOS.
The first thing that came to my mind, I would like to have a look on your hardware, the basics, it can be lack of RAM (or others)

Is your drive SSD or HDD?
Can you post results of the command


Thank you.

If it was an all at once thing you may want to test your disk/RAM for failures AFTER making s backup. It could be software, but it kind of feels hardware related.

The welcome post should help you get started with a few basic logs to run and folks can ask more specifically after.

Here is the output from inxi

CPU: quad core 11th Gen Intel Core i7-1165G7 (-MT MCP-)
speed/min/max: 1503/400/4700 MHz Kernel: 6.2.2-arch1-1 x86_64 Up: 3h 33m
Mem: 10263.8/15717.6 MiB (65.3%) Storage: 476.94 GiB (25.5% used) Procs: 335
Shell: Zsh inxi: 3.3.25

Including logs mentioned in the video joekamprad linked to

output from inxi -Fxxc0z | eos-sendlog

output from journalctl -k -b -0 | eos-sendlog

Hi and welcome to :enos: forums.

This caught my eye. And you don’t seem to have a swap partition/file.

Do you remember what you had loaded when taking these logs? Did you have vscode or code-oss loaded?

I’m using aur/visual-studio-code-bin 1.76.0-1, and yes it was probably loaded.

Running inxi again to keep track of what I’m currently running.

CPU: quad core 11th Gen Intel Core i7-1165G7 (-MT MCP-)
speed/min/max: 1835/400/4700 MHz Kernel: 6.2.2-arch1-1 x86_64 Up: 4h 21m
Mem: 11011.8/15717.6 MiB (70.1%) Storage: 476.94 GiB (25.5% used) Procs: 339
Shell: Zsh inxi: 3.3.25

Workspace 1: Three firefox windows, total 11 tabs.
Workspace 2: Two firefox windows, total 4 tabs and vscode.
Workspace 3: Slack, paused spotify and teams PWA app

Are your bootup/shutdown laggy or just when trying to work with vscode?

Boot / shutdown is normally very fast. I just rebooted and haven’t opened vscode again. Got the firefox windows, teams and slack open. Nothing “going on in either of them”

So basically nothing drawing cpu power, youtube still took over 13 seconds to load according to this extension:

Google search result page took 6 seconds to load while screen sharing with teams.

Thanks @endeavourforums
I see your hardware is OK.
As I read the posts here from @fbodymechanic, @s4ndm4n and @joekamprad
and your last post:

Do you mean

a youtube app or from the browser? “13 seconds to load” load the app? open youtube page? load the movie and play it? in browser ro app?
Test your internet speed anyway.
I would suggest you try the LTS kernel, reboot to it and see how it goes.

I mean time it takes to load the youtube front page in the browser.
Internet is 1000/1000, ~750mbps when I checked right now.

I’ve tried both lts and zen kernel and there’s no difference

My experience ends here then!

Just curious, have you installed anything extra that might be running in the background? Antivirus?, Firewall?,

Something just popped up my mind, what if you uninstall “vscode”, no screen sharing, no networking… and see. I maybe wrong though. But I am assuming it is me who have this issue and think what would I do.
I am sure you will find help here in this wonderful forum.

I can’t think of anything I’ve installed that’s running in the background making such a mess of things.

I’ve tried re-installing vscode without that helping. I don’t think vscode is the bad guy here either way as it doesn’t have to run for the pc to be slow.

Thanks for your help :slight_smile:
Maybe someone else have a trick up their sleeve :stuck_out_tongue:

1 Like

How many file tabs do you open when you’re using vscode?

I’m linking another thread here. The user had a very similar experience to yours. I’ve listed all the steps here. Try those suggestions that might solve your problem.

You don’t have a swap partition/file. The creator of the post I linked also had vscode and it was eating his memory.

Please try the suggestion in that thread and see if your problem gets solved.

1-10 tabs

Thank you I will take a look at it :slight_smile:

I found this on Reddit. This suggests more files you have open more RAM it takes + the addons. Seems vscode relies on Chromium which kind of explains the memory usage.

You are welcome.
I am sure our friends here can help.

I took a look at the steps you mentioned in the other thread.

  1. I’ve tried LTS kernel without noticing any difference in performance. I figured I might as well set it to default though, but there’s no line with GRUB_DEFAULT in /etc/grub/grun.cfg
    Because of this I thought I might use systemd-boot as you mention, but I don’t have the /etc/kernel/cmdline file, so I guess not?

  2. You mentioned above I’m not using a swapfile, is the suggestion you make about enlarging the swap file relevant for me? No swapfile in / on my system

  3. As mentioned I don’t have a /etc/kernel/cmdline file.

  4. I’m using xfce, and from my understanding wayland is not a part of that