All app gets automatically closed

and indeed i can guid eyou but can be some learning for you included…

Sure sir,
if it helps me and helps to run my distro smooth then pease guide me

@Astra I too suggest trying this :point_up_2:

I’ve come across at least two cases in past weeks where a kernel update caused spikes in memory usage, and it eventually got fixed in a future kernel update.

There is no straight answer. Different hardwares have different needs. linux-lts is popularly said to give the least issues, so try that out.


thanks sir i will try it

sir and what about graphics
should i have to install some LTS graphics driver also ??

I want use my nvidia grapics

when you click on your users name in login this will appear when click on the little wheel bottom right… GNOME = default Wayland Session // GNOME on Xorg is X11 session…

Sir i wanna try the LTS kernel as you suggested and try it for some days
and lets see if the issue gets solved or not

to use your nvidia card first try if you can switch manually:
xrandr --setprovideroffloadsink nvidia Intel

sir just now i instalLed LTS kernel but it is still showing zen what should i do next sir ?

xrandr --setprovideroffloadsink nvidia Intel

it says : Could not find provider with name nvidia

Hi, I have the same problem with vs codium in this thread App closes itself - #5 by gonza01
I use a 512mb swap file and I have 16 gb RAM.
I think the problem is with vscode/codium because it doesn’t occurs the same with another app.
I’ll try too increasing the swap file.

And is there still problem ??

which kernel r u using now ?

yep, this weekend I’m gonna change the desktop to cinnamon to check if the problem persists (now using kde). Then the so is stable and working very nice.
I have only this problem pending to solve.

by default. I didn’t install zen to test

Lets see if my issues can be solved on not
if solved u can also try it !!!

I second this. I’m not running Nvidia graphics but Zen Kernel won’t boot for me right now.

1 Like

When you reboot, you should have option of choosing the LTS kernel.

you may do not have nvidia drm modeasetting added as boot parameter…

cat /etc/kernel/cmdline


I think there’s a lot of helpful information but it’s scattered. So, I’m trying to bring everything into one post.

  1. First, try installing the LTS kernel.
    You can use akm it’s provided by the EndeavourOS team and it should be already installed. Once installed it should make the LTS version the default kernel to boot from. If it doesn’t do the below steps. Edit your /boot/grub/grub.cfg you can open this file in a terminal text editor like this
    sudo nano /etc/default/grub. Then change the line GRUB_DEFAUT to GRUB_DEFAUT=1>2 then you need to run sudo dracut-rebuild to generate the grub file. If your system is using systemd-boot then follow this WiKi page to change your kernel.

  2. Enlarge your swap file @joekamprad gave you the perfect steps here

  3. Check the NVIDIA drm modsettings as @joekamprad says using cat /etc/kernel/cmdline, Look for nvidia_drm.modeset=1.

  4. Change the default display server from wayland to Xorg X11. As described by @joekamprad here.

Once all these are done REBOOT the system and try to see if the same problem pops up.


Yes sir after
Installing LTS kernel and increasing the size of swapfile as @joekamprad suggested
Now its working fine from yesterday until now there is no issues,

Thanks @s4ndm4n, @joekamprad for guiding me. It helped me a lot
And i was also able to learn to monitor my system memory thanks @s4ndm4n .
It was a nice experience to being guided by you all …


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.