All app gets automatically closed

Don’t know whats the problem but all the tabs and apps i m using gets closed and i need to login but the login prompt gets freeze and i have to reboot my distro again and again…

Need Help !!!

You meant to say your system restarts or do you get logged out? Your description doesn’t have any good information to go on.

try open app from terminal what could show the error…

yeah my system gets logged out and the apps i m working on gets closed
and when i try to logIn the login prompt gets freeze and i have to restart my system it again and again

Can you post the output of inxi -Fxxc0z | eos-sendlog. Past the link here.

  Kernel: 6.2.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: GNOME v: 43.3 tk: GTK v: 3.24.37 wm: gnome-shell dm: GDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Acer product: Nitro AN515-55 v: V1.00
    serial: <superuser required>
  Mobo: CML model: Stonic_CMS v: V1.00 serial: <superuser required>
    UEFI: Insyde v: 1.00 date: 03/19/2020
  ID-1: BAT1 charge: 25.1 Wh (62.9%) condition: 39.9/57.5 Wh (69.3%)
    volts: 16.2 min: 15.4 model: LGC AP18E8M serial: <filter> status: charging
  Info: quad core model: Intel Core i5-10300H bits: 64 type: MT MCP
    arch: Comet Lake rev: 2 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 2100 high: 2500 min/max: 800/4500 cores: 1: 2500 2: 2500
    3: 2500 4: 2500 5: 2500 6: 2500 7: 900 8: 900 bogomips: 39999
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
    driver: i915 v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9bc4
  Device-2: NVIDIA TU117M vendor: Acer Incorporated ALI driver: nvidia
    v: 525.89.02 arch: Turing pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f99
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-5:4
    chip-ID: 04f2:b64f
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: gnome-shell driver: X: loaded: intel,nvidia
    unloaded: modesetting alternate: fbdev,nouveau,nv,vesa dri: i965 gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 mapped: eDP1 model: ChiMei InnoLux 0x15e7 res: 1920x1080
    dpi: 143 diag: 394mm (15.5")
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel UHD Graphics (CML GT2)
    direct-render: Yes
  Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:06c8
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: snd_hda_intel
    v: kernel pcie: speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:10fa
  Sound API: ALSA v: k6.2.2-zen1-1-zen running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.66 running: yes
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 07:00.0 chip-ID: 10ec:2600
  IF: enp7s0 state: down mac: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:5 chip-ID: 8087:0026
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 1.14 TiB used: 144.32 GiB (12.3%)
  ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530
    SDBPNPZ-256G-1014 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4
    serial: <filter> temp: 41.9 C
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
  ID-1: / size: 232.7 GiB used: 48 GiB (20.6%) fs: ext4 dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 998 MiB used: 312 KiB (0.0%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: file size: 512 MiB used: 511.7 MiB (99.9%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 46.0 C pch: 57.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 304 Uptime: 26m Memory: 7.59 GiB used: 7.13 GiB (94.0%)
  Init: systemd v: 253 default: graphical Compilers: gcc: 12.2.1 Packages:
  pm: pacman pkgs: 957 Shell: Bash v: 5.1.16 running-in: kgx inxi: 3.3.25

As I thought you are running out of memory. That’s why you’re been kicked out. Check what is using that much memory in your system.

P:S: Use " ``` " marks to put things within a code block. Also, you could have just pasted the link.

1 Like

@s4ndm4n Thanks a lot sir i m new here on linux thats why i don’t know a lot things…

No worries we all started like you friend. That’s why I mentioned it so you’ll learn.


Sir its happening again…
The problem was like before now while i m using more apps and VS code it is taking too much memory and the memory runs out again like before
Sir now its have been 3 months it wasn’t like before its started happening just 4 days ago .Is there still anything left to do to solve my issue

Check htop or top or task manager to see what’s using so much RAM. Without knowing that it’s hard to troubleshoot.

And I just saw

You’re running out of SWAP as well. Normally it’s best to set the SWAP equaling your RAM.

But first, check what is filling your RAM up like this it’s really not normal.

EDIT: Also, remove the solved mark because the problem is still there.

Sir what should i do now to know what’s using so much RAM and how to set SWAP equaling to my RAM

Sir i m not understanding it …

You can use gnome-system-monitor. Use sudo pacman -S gnome-system-monitor or yay -S gnome-system-monitor. And use that to see what’s eating up your ram. Or you can use a terminal tool called htop you can install it the same way sudo pacman -S htop or yay -S htop.

Then use the command htop in the terminal which would show you a nice task manager interface to go through.

1 Like

Sir here it is

That’s top so %MEM is the percentage of your total memory used by any given program. Your top RAM users seem to be chrome and GNOME Shell.

Keep monitoring your resource usage until you see a spike in your memory usage. According to that screenshot, your chrome seems to eat your ram.

Just restart your computer and use firefox or any other browser besides chrome and keep monitoring your memory usage to see if the same thing happens.

1 Like

Sir its VS Code IDE which is taking too much memony
But sir this kind of problem wasn’t before how can i solve it ?

Sir can this type of problem can be related to kernal ?
Before i used to use LTS kernel but because of some problem i switch to zen and after that i start facing this problem

you can increase swap easily because you are using swapfile:
remove current small file 512MB:

sudo swapoff /swapfile
sudo rm -f /swapfile

create a new one:

sudo dd if=/dev/zero of=/swapfile bs=1M count=16000 status=progress

set permission:

sudo chmod 600 /swapfile

create swapfile:

sudo mkswap /swapfile

start it:

sudo swapon /swapfile

check it:

swapon --show
1 Like

and you can install the kernels from repo side by side and switch on boot…
A good idea is to install LTS as aFallback kernel in case the used one going nuts…

Sir with this can my problem will be solved ?
Sir i m frusteted until now its 7 times the problem have occured