PC freezing, crashing programs randomly

The issue

My desktop PC sometimes starts acting really slow with mouse & UI movements, before completely freezing, at which point i have to reset the PC manually. Software randomly crashes while the system is performing OK, firefox often times crashes, my games (via various game platforms like Steam and Heroic Launcher) have been crashing and freezing my PC all the time.

I’ve been Using Windows 10 where i had no issues, Pop!OS where i still haven’t had these issues, but in EndeavourOS (EOS) i’ve been facing this issues, not sure for how long.

Current attempts to solve the issue

Community in an EOS Telegram chat group has advised me, that perhaps it’s a faulty RAM or SSD (10 years old) issue, so i upgraded to 500gb ssd and 32gb ram, tested for faults and it’s OK, but the freezing issue is still present.

This issue is present for at least a year as i’ve been trying to, and failing to locate the issue and i really like EOS and KDE so if possible i’d like to retain those. I would really like to fix the issue but i’m unable to… I’ve been posting system logs to the Telegram chat and we’ve been unable to locate the issue. I’m relatively a newbie so please help me with commands and something so i can find the issue and fix it.

Random info

  • Bios is updated
  • Latest proprietary Nvidia Legacy drivers for my graphics card
  • New SSD
  • New RAM
  • I can’t afford to replace my entire PC

About this system

Operating System: EndeavourOS
KDE Plasma Version: 5.25.4
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.18.15-arch1-2 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-4770 CPU @ 3.40GHz
Memory: 31,3 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 760/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7850
System Version: 1.0

Hardware information

Boot Log

Systemd Journal

Xorg (X11)

Xorg.0 log.odt (43.3 KB)

Would also post xorg.old but i get a warning: Sorry, new users can only put 5 links in a post.

Welcome to :enos: forums!

Please update your post with system and boot logs according to:

Also if you are posting terminal information, put them in code blocks so that it is readable

Seems similar to an issue I had. I resolved by switching from X11 to Wayland which may not be possible for you, also someone else solved by always using windowed mode in games.

What type msi board?

MS-7850 / MSI Z87-G41 PC Mate

I had once very same issues with faulty RAM. Have you tried using it without XMP?

Another possibility is undervolting set in the bios causing instability, or a weak power supply. Causing a crash when the GPU wants more juice and can’t get it.

The power supply is a Corsair CX650 that is 2 years old so it should be good.

If you installed new ram then is it seated properly as that can cause errors also. Other then that i see you are using the 470.xx nvidia drivers which is correct. Gaming platform issues i can’t really comment on.

do you got also with the monitor as in xorg ?

Also have you tried running with a completely fresh user? Have you tried the lts kernel?

I have a new journalctl, freeze happened at around 01:06, where everything just froze, ui, mouse, music kept repeating the last 1 second before the freeze… http://ix.io/47ln

I memtested my RAM with no errors, also i tried using it without XMP an hour ago and my system still froze completely a while later, so that wasn’t the issue.

Freezing of my OS was present before, when i had 8gb of RAM, and also now when i have 32 gb of ram when i reseated all my RAM sticks. It’s not just gaming, it’s an entire OS that is affected.

I don’t understand the question

I have tried with as a fresh user as i have purchased a new RAM and SSD to which i reinstalled EOS. I didn’t try lts kernel tho…

I would definitely try the lts kernel.

What has happened since? We are no longer on the 5.18.15 kernel.