Partitions ... have been written, but we have been unable to inform the kernel of the change

Partitions … have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should probably reboot now before making further changes.

This is happening in both gparted & gnome-disk-utility on all of my disks (OS, data1, data2, etc…). Rebooting and then using either program results in the same error.

I’ve never had this error before, and I don’t want all of my harddrives ruined. What should I do?

Right now there is a libparted problem. See: Gparted - Libparted error


You typically get that error when you haven’t unmounted a disk prior to making changes. If you did that, and still getting it, :man_shrugging:


I just updated the kernel today :sob:

I hope this doesn’t brick my disks…

From what I’ve been reading, this is a 5.8.X kernel problem. There are GIT reports that the up-coming 5.9.X kernel does not have this…so hang tight.


Thread already here here.

It won’t break the disk, nor is there actually a problem with Disk or Gparted. Those messages as far as I can tell are erroneous ones created by the kernel update.



I used an older EndeavourOS live cd, and that version of gparted needed to run e2fsck before it made any changes.

I ran e2fsck on my drives and found several superblock errors. One partition of one drive was completely erased.

Be cautious.

Temporarily run the LTS kernel until this gets fixed. That worked for me.
Use AKA to install the LTS kernel if you don’t already have it installed.



Or simply:

sudo pacman -S linux-lts linux-lts-headers

completely unrelated. This is a kernel issue. Gparted itself has not had an update since long before this kernel update.


Thank you for the exact command. I’ll try that later today after work.

Don’t worry your selves its all fixed today with Arch testing soon be in stable just a Kernel update that’s all.


I can confirm @mandog 's comment: linux 5.8.9.arch2-1 fixes this issue.

1 Like

no it is NOT in 5.8.9 Stable kernel ( unless you have added these patch for Archlinux )
it will be added to next version 5.8.10

this actually breaks libparted & dm raid if not patched


Didn’t say anything about it being stable :wink: . Just tested the mentioned kernel from “Testing” and can confirm the message that’s been bothering some posters here is gone.

Did not check if something else breaks instead … :upside_down_face:

1 Like

Thanks much appreciated.

No issue with Gparted with 5.8.9-zen2-1-zen (from Testing repo).

1 Like

Now I just need to have that update available for me through official repos :sweat_smile:

1 Like

Patience is a virtue!

Something I unfortunately lack :sweat_smile:


Same here.
Funny how people complain when there is a kernel update every day and also complain when these updates stop :laughing: