Openbox-session not starting (Solved)

Hello. I have cloned and installed the community edition of Openbox, but I’m unable to login to the session, it tries to log in then pops me back to the login manager (gdm in this case.)
I have had openbox installed before on this machine, as part of LXQt, but I removed all of those packages since.
I’ll try to include relevant info, just ask for more

Xorg log:
https://clbin.com/srsxI
Openbox.desktop:
https://clbin.com/hpbP6
Autostart:
https://clbin.com/ExoZR

So did you try installing openbox on top of gnome? Since you use gdm, I am assuming?

Yes, I have Gnome 41 as my main DE on this system.

Could be some conflicting configs, I had the same happening to me with bspwm but that was back in Spring or Summer 2021. Does openbox EOS community flavor use dex like i3wm, could you try disabling in the config?

Edit: just in case, I am not that familiar with openbox but I can see there are several files that could autostart some programs that may conflict. Easiest is to login gnome and change the configs and see if it fixes things.

https://wiki.archlinux.org/title/openbox

Perhaps try disabling dex here

.config/openbox/autostart try commenting out


# Autostart
dex -a -s /etc/xdg/autostart/:~/.config/autostart/  

Just a possible suggestion. I know it is recommended for i3wm due to conflict issues. Then try logging in again in openbox.

Just tried commenting it out, that didn’t fix it unfortunately

Bummer, you could try also commenting out picom and gnome polkit just to try. Shot in the dark until an openbox user comes to rescue. Or just autostart items anyways, may be worth the try.

Commenting out picom and the arandr script worked. So now, I will dig in and see what it is about the picom config or the arandr script that is causing the issue
Thanks a lot for the pointers.

1 Like

Ok, try one then the other. For arandr could be that it points to a profile that hasn’t been yet created and saved as monitor.sh. You could just open arandr and save your profile in

 ~/.screenlayout/monitor.sh

For picom I would check what the additional options mean.

It’s picom that’s the culprit. Nothing is commented out in autostart now, but to get picom to work I changed from the default
picom -CGb &
to
picom --experimental-backends --vsync &
that’s just what I normally do for picom. The options -CGb disable shadows, and daemonize the process

1 Like

Good to know :+1: I am intrigued by openbox but last version I installed via the eos iso had some odd artifacts in the bottom panel. Did not have time to check it further yet. But I like trying out wm…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.