Openbox - inital problems after install

I did a fresh install of openbox using the
EndeavourOS_Atlantis_neo-21_5.iso on a Lenovo Z510 and immediately ran into a couple of problems.

  1. Could not login via the graphical interface. Problem was picom and solved as it was given in:
    Openbox-session not starting (Solved) - #5 by Zircon34

  2. Screen brightness was at 100% and the keyboard brightness keys did not lower it.
    In a terminal I executed the command
    xbacklight -dec 5
    and it worked
    .config/openbox/scripts/brightness-control up
    and it worked.
    .config/openbox/scripts/brightness-control down
    and it did not. Gave error of no closing bracket in line 7.

Looked at .config/openbox/scripts/brightness-control with the editor and found that in line 7 the square brackets [ ] did not match. Even though they were there, they did not match and were different colors. Tried to replace the ] and still they were a mismatch so I retype the whole line 7 and deleted the original line 7. Brackets matched. All worked like a charm; brightness down and brightness up keys work as they should.

My guess is the brackets were somehow encoded differently from what was expected even though they displayed as ordinary square brackets.


Thank you. You can make a PR (Pull Request) here: And make the corrections there.

if [ "$1" = "up" ]; then
    xbacklight -inc 5
elif [ "$1" = "down"]; then
    xbacklight -dec 5

there is no space after “down”


Yes, I realized that this morning after I took a closer look. Getting ready to make a pull request as @s4ndm4n suggested. Thanks for confirming. When I retyped I automatically put in a space without realizing it.

1 Like

I’ve never created a pull request before so I hope I did it correctly. We’ll see.

1 Like

Your first pull request merged :partying_face:




This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.