Only Office - Glitch

I’ve been trying out Only Office but both the one on the official repositories and the flatpack have this glitch…

The application doesn’t take up the whole thing and also doesn’t use the window decoration I use. How would i solve this? I tries it as a snap, flatpack and officially and all have the same problem.
Thank You

That’s how it works i’m afraid, uses own decorations :slight_smile:

Now that’s unusual…
I don’t see this with normal version (no flatpak / snap here)

Have your tried to maximize window and then go back to normal view?

Maybe it’s best to report as bug on their GitHub

But let’s wait for someone else here, perhaps something i’m not aware of :slight_smile:

I just installed onlyoffice-bin from the AUR. This is what it looks like. This is on Plasma full screen!

Edit: Not sure what desktop you are using but maybe is some window settings?

This is as small as i can make the box and i can adjust size or maximize to full screen. Is working normal for me.

Well if it means anything my display configuration is on 145.24% but surely only office should scale itself up
I’m using plasma

What is the reason for that? Mines at 100%

2 Likes

I would say that fractional scaling in general on Linux is pretty much borked / nonexistent etc. Even if hte DE/WM would support it, getting support for apps is another long run.

everthings top tiny for me to read, but this the first time its caused any problem

That is the problem, it works fine at 100%

1 Like

Thank You!

Please report this bug still :laughing:

of course yeah i will

1 Like

Have you tried zoom in and out. crt++ or crtl ± to make larger or smaller?
Edit: Or view zoom in or out.

Is there any way i could force that one app to use 100% scaling cause everything too small for me

yeah all it does is move the actual page on the application

If you open a document in only office and go to the top right corner and click on the hamburger menu and set the view size. (zoom)

Edit:

That only changes the actual document size so instead open the document and go into file advanced settings and set the default zoom level you would like and that changes the whole size of the app.

Edit : Here

That didn’t work for me but what did was manually editing the size of the application by adding and forcing propeties. When I find the right size I’ll add it.

Hope these help somewhat?

Wait, but that’s document zoom size, not program

Maybe … there are two options not sure if they both do the same. It’s hard to tell sometimes unless you get right into it. I just make some suggestions to try. I’m not sure where the issue is. The document itself or the border above with the tools is too small? Maybe it helps maybe it doesn’t? :man_shrugging:t2:

1 Like

Definitely document one there, since it has options “Fit to page” and “Fit to width” :wink:

1 Like