One of the power saving options keeps resetting

I’m using GNOME 42.4
At Power settings, Power Saving Options the option Screen Blank keeps resetting to its default value (5 minutes), after closing the settings. The setting resets even after switching section at the sidebar menu…

image

Is there an apply button somewhere?

No, it should keep the changes. Every other setting is saved properly.

There have been a couple of similar reports recently.
For example see:

2 Likes

Thanks, I tried to use the dconf editor, but had no success. I really hope this is a GNOME bug.

2 Likes

What else should it be?

I fully reinstalled the OS on the weekend, before that my system was also up to date last week and I had no issues.

Looks like there is an alternative solution, by using the CLI command: gsettings set org.gnome.desktop.session idle-delay <seconds>.

Hopefully this will work for you.

Same setting in dconf-editor:

Screenshot from 2022-10-26 06-38-27

What a mess, now both plasma and gnome keep getting bug reports :innocent: I am lucky, no problems yet on my hardware…

It’s fine on my end as well both on GNOME 42 and 43 on Intel and AMD machines (no dGPU).
:sunglasses:

1 Like

That’s where I got the fix from, but forgot to mark an answer as solution.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.