Screen Blank setting does not apply

Hello I just installed endeavour OS I’m on GNOME
but I cannot set the screen blank setting in the power saving options under.
The default is “5min” and I’m trying to set it to “never” but it does not apply.
Every time I close settings and reopen it it’s back to “5min”.

Can anyone help me troubleshoot?

There have been a couple of reports on this issue recently. See here for example:

As it looks the issue is not reproducible by everyone but some seem to be hit by it.


Maybe you could use xset until it’s fixed?


The issue is reported upstream. Please see:

And also, welcome to EnOS’ community!

1 Like

thx for the replies

I use the Espresso extension to keep from screen blank/suspend…

… so that might be a work around since you are looking for ‘never’


thx this works, I`m keeping this until the bug is fixed

is that the same as the caffeine app/extension?

It started as a fork of caffeine, but the two have diverged a bit. Espresso has some additional settings for docks/external monitors and device charging, and the Caffeine setting UI has been reworked since the two diverged.

1 Like