nVidia hybrid, used installer, text/black screen freeze

I tried 3 times, each time system reboots to some disk text+black / frozen screen. Just reporting, no reply needed, I’m not sharp enough for arch

I wonder why bumblebee is installed by default, and why optimus-manager is needed, given the current Nvidia drivers will do render offload already… :thinking:

I don’t get it, and I have no time to work on another boot issue, Manjaro had no issues, either intel vmd crap or nvidia hybrid, but I’m OUT or arch world forever, it’s not for me

2 Likes

Sep '19
the article is from 2019… :wink:

1 Like

Oh, that would explain it. :sweat_smile:

Black screen on hybrid intel / nvidia:

I used the installer, installed driver, rebooted > frozen black screen with some drive related text.
No idea how to do it

Followed:

You can also use our tool to check your card:

nvidia-installer-check

this will give you something like this if your card is supported by the latest NVidia-driver:

Your graphics card (id: 128b) is supported by the nvidia-dkms driver.To install a driver for this card, you can use **nvidia-installer-dkms**.

If you have PC with a dedicated card plugged in you can use nvidia-installer-dkms to get latest driver installed, for more info go here:

nvidia-installer-dkms

I don’t think Bumblebee should be installed in my opinion. Also does the laptop support vulkan?

@d3viant6
If you want to install Nvdia with optimus-manager the proper way i suggest doing it the following. First install nividia drivers as per the wiki.

This will tell you if your card is listed in the data base.

 nvidia-installer-check 

Then run the installer in test mode.

nvidia-installer-dkms -t

If no errors then install nvidia drivers

sudo nvidia-installer-dkms

Then run

sudo systemctl reboot

Make sure you have have mesa-demos installed and check if the drivers are installed properly with

inxi -Ga

Then proceed to install Optimus manager as per the wiki

If you have kde plasma installed make sure you follow the wiki steps

1 Like

this guy has VERY similar problem, but I didn’t use any special kernel

so you are out, or you want to get knowledge about how to get Nvidia running on your system ?

This Guy is Eric Duboix from Arcolinux showing how to install nvidia-dkms driver if you are running zen kernel… Not the same issue if you are on a optimus system.
Giving some info and get knowledge about your system will help a lot.

lspci -vnn | grep '\''[030[02]\]'

2 Likes

sorry, flustered, installed says compatible, installs fine, same exact issue as the youtube dude

000:00:02.0 VGA compatible controller [0300]: Intel Corporation TigerLake-H GT1 [UHD Graphics] [8086:9a60] (rev 01) (prog-if 00 [VGA controller])
0000:01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] [10de:2520] (rev a1) (prog-if 00 [VGA controller])

The guys here are the best and they will help you up and running. Be patient and help them to help you.

1 Like

The video is just showing that you need the dkms version of nvidia in order for it to work with the zen kernel. I had ask you in a pm to check your settings in the bios related to the graphics. I don’t know what type of system it is whether it only works on dedicated graphics only and has no switching feature? The manuals they have online don’t show the details of anything useful. I only know you have an acer predator and the model which doesn’t really help me. Also did you look at the Arch wiki info? Some of this stuff is you have to do it and look at info & logs. That is the only way to resolve it.

https://wiki.archlinux.org/title/NVIDIA_Optimus#Use_NVIDIA_graphics_only

Currently the output looks to be running strictly on dedicated graphics. Check your Bios settings. You can’t use optimus-manager and switch if Intel isn’t even loading.

What does this show?

lspci -k | grep -A 2 -E "(VGA|3D)"

Edit: You should get something like this although this is running on Nouveau

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
	Subsystem: Acer Incorporated [ALI] HD Graphics 630
	Kernel driver in use: i915
--
01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1)
	Subsystem: Acer Incorporated [ALI] GP106M [GeForce GTX 1060 Mobile]
	Kernel driver in use: nouveau

Edit2: This is from an Acer Predator

here’s what kubuntu shows: https://i.imgur.com/mNcSES0.jpg
0000:00:02.0 VGA compatible controller: Intel Corporation TigerLake-H GT1 [UHD Graphics] (rev 01)
Subsystem: Acer Incorporated [ALI] TigerLake GT2 [Iris Xe Graphics]
Kernel driver in use: i915

0000:01:00.0 VGA compatible controller: NVIDIA Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q] (rev a1)
Subsystem: Acer Incorporated [ALI] GA106M [GeForce RTX 3060 Mobile / Max-Q]
Kernel driver in use: nvidia

Okay so that looks like it’s good. Did you look at the Bios settings? How is it set up or how do you have it set? When you boot on EdeavourOS what happens? Does it boot to the desktop or not? Where is it stopping? Have you tried setting the Bios to dedicated graphics only and see if it boots on EndeavourOS. Is EndeavourOS installed?

Here’s some info on optimus-manager so you can understand how it works.

Edit: The Arch wiki provides most of the info regarding Hybrid graphics.

https://wiki.archlinux.org/title/NVIDIA_Optimus#Using_optimus-manager

generally spoken, current state of Nvidia should work without a switcher to boot into X it will use intel per default.
But as i just get knowledge on it needs to enable Nvidia Modesetting DRM to work!
This can be done inside grub or you can put the modules inside initramfs image:

1. Adding it to grub kernel line:

or:

2. Force early load (KMS)

parts…

one or the other so only one of the ways to enable it… also it says that the best would be to have them in mkinitcpio.conf

2 Likes

BIOS does not have a switch, it’s intel 11 gen + nVidia, not uncommon