No wifi after hard freeze during AUR package installation

I just had a bad experience, where my system locked up while installing a program. TTY didn’t work at all, fan was at max speed and computer non responsive.

I tried to gain access for about 5 minutes, and then I did hard reboot. Only thing I could do at the moment.

Everything seems to be fine, no missing documents or anything, but I am not able to connect to the internet at all.

I am using r8169 driver.

I am currently at the University so plugging the computer into a router is not an option for the next 7 hours or so, and I need my connection back in less time than that.

I am hoping this is just systemctl enable service,just not sure what the service name is.

Would love to post inxi and other info, but typing on a phone is super time consuming.

Ok, managed to get connection through hot spot tethering.

I got inxi here

Try and see if rebuilding the initramfs could resolve the issue:

sudo mkinitcpio -P

Reboot afterwards.

Might be worth trying the r8168?

I’ll try rebuilding initramfs. If that doesn’t work, I’ll check the 8168 driver. System has been very stable until this predicament.

1 Like

Rebuilding initramfs did not work, checking the -8 driver

1 Like

As a side note: if you use the -z flag with inxi some identifiable info will be filtered out.

Might be worth also to run a fsck on your system partition from the live session to make sure that the filesystem is ok.

You could use Gparted, right click on the partition >> Check

The -8 driver does not work.
It seems like the system is not finding the card (realtek), and it is like it is either not there or not turned on.


1 Like

But that card is for Ethernet. I thought that was the issue.

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp1s0 state: down mac:
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: down mac:
  IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A
    mac: 14:85:7f:0a:6e:77
  IF-ID-2: virbr0 state: down mac:

Your WiFi card uses iwlwifi.


sudo modprobe iwlwifi

I used inxi -FAZ --no-host | eos-sendlog

I am not sure what that means. BUT I probably could have been clearer in my description of the problem, and use wifi instead of internet in the header.

Which program caused it and how was it installed?

But wifi is Intel. Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi. Both stopped working?

Do I get it right that we are only talking about a problem with Ethernet?

Have you tried lts kernel?

1 Like

This led me to believe you had issue with ethernet.

--no-host Turn off hostname for -S. Useful if showing output from servers 
           etc. Activated by -z as well.

Only -z is sufficient. It will filter out MAC address etc. as well

1 Like

Do you mean no Ethernet? Or are you thethering via Bluetooth and have no wifi?

Edit: still suggest trying lts kernel

:heavy_plus_sign: :one:

This did not have any effect on my problem.

The crash happened while installing FreeCAD-git with yay, searched yay freecad and selected the number for the git repo.
The install had been going on for few minutes when I opened a new tab in my browser and everything just stopped working, fan went to max. I have 16 GB of RAM, so I am not sure I replenished that.

I guess both stopped working. I can’t turn the wifi on my computer on, it stays off. Which made me consider systemctl enable but I had no luck with that (maybe because I am not sure what parameter to use).

If Ethernet is wi-fi, then yes. I have only used this computer with wi-fi. I am tethered to hotspot on my phone through Bluetooth.

I haven’t used lts-kernel and I am really not considering it at the moment, unless nothing else works.

Try sudo systemctl restart NetworkManager

No luck unfortunately

I highly recommend to install it as a fallback if you run into trouble with future kernel update and drivers and really want to use the newest kernel for whatever reason. LTS means long term support, and maybe preferred on a work computer.

Your system, your choice. just a suggestion.

Did you already deinstall it in case there are conflicting or problematic packages?

What says:

lsmod | grep iwlwifi


Uninstall regular FreeCAD, I did not, hasn’t been a problem before.
Will clean up FreeCAD and FreeCAD-git now.

When I install the lts kernel, is there any tutorial on how to make the system select one kernel all the time?