No wifi (again) after a hard crash

For those who do not know, I had this issue here No wifi after hard freeze during AUR package installation - #14 by olividir

Which solved itself for some reason.

This time, I was starting a game from Steam (which might be the reason for the crash), when the computer froze and I had to do a hard reboot.
The driver is there, just won’t start for some reason

lsmod | grep iwlwifi
iwlwifi               491520  1 iwlmvm
cfg80211             1118208  3 iwlmvm,iwlwifi,mac80211

I have tried to log in on lts-kernel, which does not affect my problem at all. I have tried turning the computer off for a while and starting it up again (solution for last time) with no effect.
Then I decided to check my Timeshift, which I have configured to take snapshots every day (so I could roll to yesterday when everything worked) just to find out that last snapshot was taken 24th of Oct.

I am literally this close :pinched_fingers: to reinstalling the OS again… which I do not want to do because I have set this up as I want to.

inxi -FAZ
  Host: ProX15 Kernel: 6.0.5-arch1-1 arch: x86_64 bits: 64 Desktop: GNOME
    v: 42.5 Distro: EndeavourOS
  Type: Laptop System: SLIMBOOK product: PROX-AMD5 v: Standard
    serial: <superuser required>
  Mobo: SLIMBOOK model: SLIMBOOK v: Standard serial: <superuser required>
    UEFI: American Megatrends LLC. v: N.1.06GRU06 date: 05/25/2022
  ID-1: BAT0 charge: 91.6 Wh (100.0%) condition: 91.6/91.6 Wh (100.0%)
  Info: 8-core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1776 min/max: 1400/4370 cores: 1: 1800 2: 1800 3: 1800
    4: 1800 5: 1800 6: 1800 7: 1800 8: 1800 9: 1800 10: 1800 11: 1800 12: 1800
    13: 1419 14: 1800 15: 1800 16: 1800
  Device-1: AMD Lucienne driver: amdgpu v: kernel
  Device-2: Chicony HD Webcam type: USB driver: uvcvideo
  Display: wayland server: X.Org v: 22.1.4 with: Xwayland v: 22.1.4
    compositor: gnome-shell driver: gpu: amdgpu resolution: 1920x1080~60Hz
  OpenGL: renderer: RENOIR (renoir LLVM 14.0.6 DRM 3.48 6.0.5-arch1-1) v: 4.6
    Mesa 22.2.1
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.0.5-arch1-1 running: yes
  Sound Server-1: PipeWire v: 0.3.59 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168
  IF: enp1s0 state: down mac: b0:25:aa:4e:4c:5b
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: down mac: 5a:af:b4:8f:96:2c
  IF-ID-1: bnep0 state: unknown speed: N/A duplex: N/A
    mac: 14:85:7f:0a:6e:77
  IF-ID-2: virbr0 state: down mac: 52:54:00:95:1b:d2
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 465.76 GiB used: 134.63 GiB (28.9%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT500P2SSD8 size: 465.76 GiB
  ID-1: / size: 465.46 GiB used: 134.63 GiB (28.9%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 912 KiB (0.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 465.46 GiB used: 134.63 GiB (28.9%) fs: btrfs
    dev: /dev/nvme0n1p2
  ID-4: /var/log size: 465.46 GiB used: 134.63 GiB (28.9%) fs: btrfs
    dev: /dev/nvme0n1p2
  Alert: No swap data was found.
  System Temperatures: cpu: 43.9 C mobo: N/A gpu: amdgpu temp: 39.0 C
  Fan Speeds (RPM): N/A
  Processes: 376 Uptime: 10m Memory: 15.02 GiB used: 2.46 GiB (16.4%)
  Shell: Zsh inxi: 3.3.22


I should mention that I am tethered through Bluetooth to phone to get internet access.

Hard reboot is not recommended at all on any OS. On Linux, you can enable Magic Sysrq Key to get an option for nice rebooting when system crashed.

You’re not on Windows, must of the times you can find a solution for your issues without reinstalling the entire OS.

Finally, your wifi device seems to be down, that’s a good point to start looking for a solution.

Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlan0 state: down mac: 5a:af:b4:8f:96:2c

Just opened an iso to check the WiFi, and it’s not working.

Might be faulty hardware. Will connect with Slimbook to get ideas on how to check it.

I know, but I lost all graphical interface. I am on a laptop so unplugging the monitor is not an option. Saw nothing else at the moment.

And again, just turned the computer off, this time for longer and now it just seems to work… super weird, I will have a talk with Slimbook about this behavior

Super weird, that seems to be hardware related…

I’m hoping by turned off you used the system rescue sequence this time. Please don’t hard turn off your computer.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.