No video playback in browsers

Hopefully this falls into the “I am an idiot” category of question… I’ve had EOS running in a VM for a few days now, and I’ve just realised that video playback in Firefox (and Chrome, euch!) is an issue. Any video will look like it is buffering, but will not play. And I perhaps missing codecs?

The same video, when downloaded with youtube-dl, will play just fine in VLC.

Any ideas?


Hello @DeinOnkelFred
Not sure here what would be the problem but do you have ffmpeg installed? Could try it i suppose. It won’t hurt!

I do, yes. Also the gstreamer components, gst-plugins-goodand gst-libav`

Firefox is pulling 468/ 555 here and the audio and video codec sections track those of a known-good Firefox install on another distro. Against my better judgement I also installed the DRM plugin after being prompted trying an Amazon prime vid.

With such a generic problem, the Googles have not been very helpful.

I have same 469/555 on html5test. I always enable Drm content in browser. I also have adobe flash plugin and pepperflash installed. I don’t have any issues. These are all the gst stuff installed.

I am not on v-box though.

Try this:

Go into Firefox’s Edit/Preferences/Privacy & Security and scroll down to Permissions. Check the settings for Autoplay and choose the option you desire: Allow Audio and Video, Block Audio, or Block Audio and Video.

Obviously you would want Allow Audio and Video.

I hope that this is of some help to you.


I appreciate the effort, Lawrence, but no dice! Also the same situation in google chrome.

Try turning off hardware acceleration in the browser.

Sorry I couldn’t help you. I do not use virtual machines and I am unfamiliar with them.

At least you can watch the videos in VLC.

I hope that someone else is able to help you.


@DeinOnkelFred, which is your setup on VirtualBox about video ?
Could you send us a screenshot to be sure ?

VBox: stuttering in yt (D)


FLVAL… here’s a quick screen recording:

Thanks @DeinOnkelFred, what I was asking was about your VirtualBox graphics settings if you setup it like this ?

If not you could follow this Thread :

Same video set up as yours, except I’ve only allocated 128MB video mem. That could well be the issue… although it has never been with 8any* other VBox VM I’ve ever used.

Can’t try it right now because I cannot shut down the VM… some trikiness WRT chrooting and all that jazz going on at the minute. Seems promising tho. Willl let you know.



UPDATE: made a local copy of the VM on a Thinkpad T460 (16GM RAM) and allocated 256MB video mem. VBoxManage modifyvm "endoskde" --vram 256.

Issue persists.

I have no issue with youtube video on my powerfull computer but on my older hardware it won’t play. It just stutters and the audio is just crackling. This is a quad core 2.4 Ghz with 8 GB memory and SSD drive but it’s also 13 years old now. My new computer is 5.0 Ghz with 32 GB of memory and fast drives so it has no problem. Vbox on my older computer used to work good back in the day but not now. I used to run vmware workstation on it. But now Virtualbox actually does not work well on it at all. Everything is just too slow.

How many cores you setup on your CPU in VirtualBox ?

Just out of interest, why do you need to watch videos in a virtual machine in a browser? :wink:

I’ve never used VM or anything setup the way described in this thread so, I have no clue what is going on. I will say that I’ve had this problem with videos (some not all) buffering-not playing in Firefox and Chrome. In my case it was ad block extensions (uBlock Origin) causing the problem.

I’m interested in seeing the fix cuz my brain is hungry for knowledge.

Nothing fancy or clever… just a little bit of entertainment. As I think I said somewhere else, I came to Endeavour to use a as host for a Linux From Scratch build, but I’m liking it a lot, and think it will likely be my desktop (“daily driver”, to use that horrible phrase).

I find it curious that video does not work on the plainest of plain EOS installs, though. Literally nothing is different from first boot except the color scheme and a couple of pacman -Syus

VBoxManage showinfo --machinereadable is at:


Yeah. me too now. Gonna pause my activity in the VM, reboot and try some of the suggestions in this thread so far. Just increased video Ram, and that didn’t do it.