Network Connection Bug

After around of 10 minutes my network is disconnected and reconnect at the same time.
Any workaround?

Welcome @talhag !

We need more information to help you !
Could you paste in these commands ?

inxi -Fcxxx0

If you do not have inxi installed you can install it with:

sudo pacman -S inxi

journalctl -b -1 → Paste in some pastebin

System:    Host: tal-pc Kernel: 5.4.15-arch1-1 x86_64 bits: 64 compiler: gcc v: 9.2.0 Desktop: Deepin 15.11 tk: Qt 5.14.0 
           info: dde-dock wm: DeepinWM dm: LightDM 1.30.0 Distro: EndeavourOS 
Machine:   Type: Desktop Mobo: Intel model: DH61CR v: AAG14064-207 serial: <root required> BIOS: Intel 
           v: BEH6110H.86A.0038.2012.0110.1653 date: 01/10/2012 
CPU:       Topology: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25554 
           Speed: 1597 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1597 2: 1597 3: 1597 4: 1596 
Graphics:  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0152 
           Display: x11 server: X.Org 1.20.7 driver: intel unloaded: fbdev,modesetting,vesa 
           resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:1c20 
           Sound Server: ALSA v: k5.4.15-arch1-1 
Network:   Device-1: Intel 82579V Gigabit Network driver: e1000e v: 3.2.6-k port: f080 bus ID: 00:19.0 chip ID: 8086:1503 
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: 4c:72:b9:20:df:31 
Drives:    Local Storage: total: 156.47 GiB used: 8.94 GiB (5.7%) 
           ID-1: /dev/sda vendor: Seagate model: ST3160812AS size: 149.01 GiB speed: 3.0 Gb/s serial: 9LS5BS22 rev: J 
           scheme: MBR 
           ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 7.45 GiB serial: 4C530301621218110112 rev: 1.26 
           scheme: MBR 
Partition: ID-1: / size: 74.48 GiB used: 8.94 GiB (12.0%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 38.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 177 Uptime: 37m Memory: 7.68 GiB used: 1.97 GiB (25.6%) Init: systemd v: 244 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: deepin-terminal inxi: 3.0.37

Ok, you have Deepin installed, this problem is known in Deepin with wifi, but it is fixable !

1 Like

I’m connecting through LAN that connected to an access point that using WiFi.

Did you have a look at this?

@talhag Oh sorry i misunderstood. You are losing your network connection as it is connected via lan which is connected with wifi access point. When you say it is disconnected and reconnected at the same time. Exactly what do you mean? It’s alternating from disconnecting to connecting? Is the lan losing it’s connection from the access point. That would be what i would look at.

I don’t have any WiFi connection issues.
The issue is that my wired connection is keep on disconnected and reconnect every ~10 minutes.

Just a guess, but installing the networkmanager-noscan package from AUR via yay might help. This will of course replace the regular networkmanager package.

no wired connected. only wlan using pcie wifi card w/ atheros chip. intermittent (connects then disconnects in cycles at default).

fix 1:
*If you can’t edit the network manager configuration, you can try a new network manager by the following command:

sudo pacman -S network-manager-applet

*then, edit NetworkManager.conf:

sudo nano /etc/NetworkManager/NetworkManager.conf

*add these lines, then save:


*restart Network Manager:

systemctl restart NetworkManager

adding those lines made it stable (no more cycling) but bandwidth’s too slow, packets drop extensively w/ too many dns probing…

search the web for the slow-down fix (credits go to solus), i found this (added also to the NetworkManager.conf first lines, before the previous fix):


Screenshot from 2020-01-30 07-29-54

restarted NM (or rebooted, i couldn’t remember), connected to the network & wifi SSID, no more slow-downs. :slight_smile:

1 Like

This didn’t help.
In fact now I need to manually disable/enable my network each time it disconnect.

Hi there. Same problem here. Any fixes?

Did you ever get this working? You could try ipv6.disable=1 editing the kernel line in /etc/default/grub and commenting out the ipv6 lines in etc/hosts file.

I have an Intel and an AMD desktop both w/ fresh EndeavourOS installations: no problems on the Intel but LAN automatically disconnects, core dump and reboots the system on the AMD after 10 min.

I guess I have to open a bug report so s.o. can take a look at the coredump caused by freedesktop?

I am not sure that this thread is identical to my problem but it may be related. I only have WiFi hardware on the Intel but not on the AMD. I do not use WiFi at all and have it turned off.

I figured the problem was the Automatic Suspend set to OFF on one and ON on the other machine. It cashes the crashes and masked the problem for me.