I can't connect wi-fi on Deepin DE

I have installed EndeavourOS without problems. Could connect to wifi in the live installer fine.
After instalation, I can’t connect to wi-fi anymore, neither through deepin interface or nmtui.

I have already added the dhcp=dhcpcd thing at the conf file, as is recomended in the bug section.

Logs: https://pastebin.com/pYF59FEn

edit: i’m running Ryzen 7 3700U laptop if it’s important.

if you type ; rfkill , you see some blocked status ?

Hi, thanks for answering.
thats the output

0: ideapad_wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: yes
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
3: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no

Disable bluetooth and try to connect a wifi.

systemctl stop or disable bluetooth says that bluetooth.service is not started / not found

Of course, now I remember that bluetooth is not enabled by default, sorry

Try systemctl status NetworkManager.service

1 Like

on the powercord does the wifi works ?

otherwise im thinking it but the wifi to sleep mode. im not sure offcourse, when you installing endeavouros did you had powercord on it ?

As Judd suggested, check that NetworkManager is installed and enabled.

I can’t check right now since I’m at work. But I can enable/disable NetworkManager.service without problems. As you can see in the logs it starts fine.

I’m a newbie at linux but couldn’t jan 07 16:20:16 mateus-s145 NetworkManager[1549]: <info> [1578424816.9714] rfkill2: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:01.2/0000:02:00.0/ieee80211/phy0/rfkill2) (driver ath10k_pci) jan 07 16:20:16 mateus-s145 NetworkManager[1549]: <info> [1578424816.9719] rfkill0: found Wi-Fi radio killswitch (at /sys/devices/pci0000:00/0000:00:14.3/PNP0C09:00/VPC2004:00/rfkill/rfkill0) (platform driver ideapad_acpi) be the problem?

Is there a switch on that laptop to turn off WiFi?

No, it’s a pretty basic ‘chassi’. And rfkill doesnt report blocks, I don’t understand what could be the cause of this

1 Like

Make sure there isn’t a key combination to disable WiFi like Fn+x

If all else fails you will need to get that machine online somehow. So either use a hardline to the router or use your cell phone as a tether. Then you can try another kernel. If that is an intel wifi adapter they are having issues on the newer kernels. Once online you can try:
In terminal:
sudo pacman -S linux-lts linux-lts-headers
sudo grub-mkconfig -o /boot/grub/grub.cfg
systemctl reboot
After reboot you should see 4 entries in grub. linux linux and it’s fallback image and linux lts and it’s fallback image. Select linux lts and boot into the system and see if you have wifi.

@mateus Could you post the output of lspci -k

systemctl status NetworkManager (forgot to start): https://pastebin.com/uVHAiJSQ
systemctl status NetworkManager (after I started the service again): https://pastebin.com/t9QQuvEz
lspci -k: https://pastebin.com/Ape18Myb

I will try tethering and kernel update as soon as I can

Cant boot with Linux lts.
I guess I should Just tive up dde for some time, not having success with this particular desktop in Amy distro

Your WiFi chip is Qualcomm Atheros and it looks like to me the broadcom-wl module is also loading, It is included with Endeavouros. (broadcom-wl)

I would try uninstall the broadcom-wl or blacklist it as your driver is ath10k. This is the module for your wifi. Someone can correct me if i’m wrong.

1. 02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)

2. Subsystem: Lenovo QCA9377 802.11ac Wireless Network Adapter

3. Kernel driver in use: ath10k_pci

4. Kernel modules: ath10k_pci, wl

It say’s that atk10k is in use?

Edit: Maybe look at dmesg

dmesg | grep ath10k_pci
1 Like

I solved this problem in Deepin, like this: ignore/remove my WiFi and then write password again. Working without reboot!

1 Like

When I “have “ this problem I install another Dm , like gdm… to login and resolve this problem. Then you can remove gdm…
sudo pacman -S gdm
systemctl enable gdm
aystemctl start gdm

If is “failed to …” you must stop Lightdm first.

Have you tried this?

Good day. Found this at YT, hope it can help just as it helped me. :slightly_smiling_face: